VirtualBox

Ticket #5237 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

non-VT-X/AMD-V mode broken in 3.0.8 under 64-bit hosts

Reported by: zsero Owned by:
Priority: blocker Component: USB
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Using 64-bit XP/Vista with 32-bit guests the system gets BSODs or restarts/freezes when VT-x/AMD-v mode is not enabled. Reinstalling 3.0.6 solves the problem.

Forum posts:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=23114

 http://forums.virtualbox.org/viewtopic.php?f=6&t=23198

 http://forums.virtualbox.org/viewtopic.php?f=6&t=23185

Attachments

VBox.log Download (37.0 KB) - added by snow00 4 years ago.
VBox.log 3.0.10-54097
Mini110309-01.dmp Download (272.7 KB) - added by snow00 4 years ago.
minidump 3.0.10-54097

Change History

comment:1 Changed 5 years ago by sandervl73

  • Priority changed from critical to blocker

comment:2 Changed 5 years ago by sandervl73

Unable to reproduce here. Could you attach a VBox.log of such a session? (close before it crashes your machine).

comment:3 Changed 5 years ago by sandervl73

A minidump would also be useful.

comment:4 Changed 5 years ago by sandervl73

Windows 7 x64 host by the way.

comment:5 Changed 5 years ago by sandervl73

Not reproducable on Vista x64 either. Both Intel machines. It would be useful if you could give some useful information about your environment. (VBox.log would show all that)

comment:6 Changed 5 years ago by sandervl73

We are not able to reproduce this on Vista x64 with AMD machines either. Without feedback, there's little we can do.

comment:7 Changed 4 years ago by Fj

Just hit the same problem (probably).

VirtualBox 3.0.8, Windows 2003 R2 x64 host on Core2Duo (curiously, with VT-x/AMD-V listed as enabled), Ubuntu 9.0.4 x32 guest. It worked fine until I enabled second network adapter in a Host-Only mode (the first one did NAT). Then restarted the virtual machine and got BSOD. Someone in the threads mentioned host-only mode, I want to emphasize that this is absolutely crucial.

Changed 4 years ago by snow00

VBox.log 3.0.10-54097

Changed 4 years ago by snow00

minidump 3.0.10-54097

comment:8 follow-up: ↓ 11 Changed 4 years ago by snow00

Sorry for the delay. I've added minidump and log files using the latest version (3.0.10-r54097).

I've also narrowed it down to the USB drivers. If I disconnect my external USB drive (normally captured by guest) then the VM boots OK.

In 3.0.10 the system freezes while the _host_ is booting. If I unplug the USB drive the host boots OK.

comment:9 Changed 4 years ago by sandervl73

snow00: if you reinstall VirtualBox without the USB drivers, then all problems vanish? The dump doesn't show much other than one cpu crashing or not responding in time.

comment:10 Changed 4 years ago by snow00

Yes. I've just tried the following:

1) Uninstall Vbox

a) Host boots OK

2) Install VBox without USB

a) Host boots OK

b) VM boots OK (but can't access USB drive)

3) Reinstall VBox with USB

a) Host freezes during boot* (if USB drive plugged in)

b) Booting VM crashes/freezes host (unless VT-x enabled)

  • - The host boot problem only occur after Windows has popped up "New hardware detected. Installing drivers" when the VM is first run.

- The VM crashing problem only occurs if VBox captures the USB device. Initially VBox said the USB device was "busy with another request" (or similar wording); and the VM booted OK, but couldn't access the USB drive. I had to reboot the host to get the VM to capture the USB drive, and then it crashed.

comment:11 in reply to: ↑ 8 Changed 4 years ago by zsero

For me, the original problem was without anything to do with USB. I did not used USB, not even the USB driver was installed on the system. Since I wrote the bug report, I have upgraded to Win 7 64-bit, I don't know if the problem still exist, but I might have a look at it. Since I changed to VT-x mode, everything is stable, so I didn't care. How can I create minidumb?

comment:12 Changed 4 years ago by avv

BSODs here on 3.0.10 Vista x64 when accessing a USB printer. VT-x/AMD-v mode is not enabled.

comment:13 Changed 4 years ago by sandervl73

  • Component changed from other to USB

comment:14 Changed 4 years ago by sandervl73

How to create a minidump:  http://support.microsoft.com/kb/315263

comment:15 Changed 4 years ago by sandervl73

Duplicates: #5190, #5560

comment:16 Changed 4 years ago by Technologov

Duplicates: #5346

comment:17 Changed 4 years ago by sandervl73

I can reproduce the problem here. Working on a fix.

comment:18 Changed 4 years ago by sandervl73

I can provide 3.1.1 test builds for those interested in testing the fix. Just post a request here.

comment:19 Changed 4 years ago by kenchinn

I'm interested in testing the 3.1.1 fix for this problem. Please point me to it.

comment:20 Changed 4 years ago by andrews240

I am interested in testing 3.1.1.

comment:21 Changed 4 years ago by sandervl73

You can download a 3.1.1 test build here:  http://www.virtualbox.org/download/testcase/VirtualBox-2009-12-11-10-48-30-win-3.1-rel-3.1.1-r55893-MultiArch.exe

This link will only be valid for up to 14 days.

comment:22 Changed 4 years ago by andrews240

The test build definately resolved the BSOD issue. Great work sandervl73! Unfortunately, the inability to capture USB mass storage remains. Every time after a reinstall or upgrade of VB, on the initial guest boot-up, it starts to install the VirtualBox USB driver, followed by abrutly stopping with a "device unplugged" error. Sub-sequential attempts to attach the USB device just gives the standard "Failed to attach the USB device Generic Mass Storage Device [0100]" error. More details are located here:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=24264

But, again, great work on correcting the BSOD. I can be patient until the USB issue is addressed.

Tony

comment:23 Changed 4 years ago by sandervl73

andrews240: that's another (known) problem. The first time you capture a new device you sometimes must close the VM and reinsert the device. Unrelated to this defect.

comment:24 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use