VirtualBox

Ticket #5238 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Time jumps of around 2 minutes in guest OS

Reported by: phantasm Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.8 Keywords: time jump flunctuation
Cc: Guest type: Windows
Host type: Windows

Description

Host OS: Windows Server 2008 R2 Standard 64-bit (6.1, Build 7600) Guest OS: Windows Server 2003 R2 Standard Edition (5.2, Build 3790)

The time in the guest OS tends to jump around 2 minutes backwards sometimes even hourly. Sometimes the problems happens hourly for days in row and sometimes there are no jumps for a day. Not sure about how the clock goes forward between 2 jumps as the clock is always in time within a couple minutes. But the guest OS clock seems to go forward chaotically. At times it goes forward around twice the normal speed with some cluttering for half a minute or so. Then at times it goes forward at normal speed without any cluttering. Random checks on the time show that the time slowly changes at small amounts. For example guest OS time can be -1 s at start, +15 s at 3 minutes, -5 s at 5 minutes, +3 s at 10 minutes and +20 s at 20 minutes.

I don't have anything directly monitoring the time of the guest OS, but when there is backward time jump over certain unknown time (probably around 30 seconds or so), Spring autohost gets ping timeout from server. That is due to protocol requiring the client to send ping to server at certain intervals without server requesting it. Thus, if time jumps back too much the client still thinks it doesn't need to send the ping yet while the server timeout for the ping has exceeded causing connection to ping timeout. The log of the program showed time jumps of around 2 minutes back at the time of the ping timeout.

One significant detail is that the time jumps backward that are big enough to cause ping timeout happen hourly within half a minute margin (due to the nature of the indirect monitoring). The given half a minute margin however stays same for at least some days, so the average interval between the time jumps backwards is exactly an hour within a second margin.

I have disabled all time sync features on guest OS itself, so only thing affecting the clock should be VBox guest additions (v 3.0.8 r53138 as is VBox itself). The host OS has time sync set properly so the time is correct at all times (at least within 1 second) and never jumps.

The whole configuration worked fine for a year or so until around the time I upgraded host OS from Windows Server 2008 SP2 64-bit to current. The upgrade happened 'on the fly' with reboot. I'm not sure if the problem started right after the upgrade or a week later, but chances are high it is somehow related to the host OS upgrade.

Attachments

VBox.log Download (40.4 KB) - added by phantasm 5 years ago.
VBox.log.1 Download (52.0 KB) - added by phantasm 5 years ago.
VBox.log.2 Download (53.9 KB) - added by phantasm 5 years ago.
VBox.log.3 Download (55.1 KB) - added by phantasm 5 years ago.

Change History

Changed 5 years ago by phantasm

Changed 5 years ago by phantasm

Changed 5 years ago by phantasm

Changed 5 years ago by phantasm

comment:1 Changed 5 years ago by phantasm

I disabled the time sync feature of VBox guest additions service on the guest OS at the time of issuing the ticket. So far there hasn't been any problems with time jumps. Given the relatively short time, it isn't 100 % sure the problem is fixed by that, but it is very likely.

Now the clock on the guest OS is 5 minutes behind from the time the time sync feature was disabled. Quite a lot for only about 2 days, especially as hardware clock on the motherboard is off by less than half a minute per month. Anyway, for time being this solution is better than jumping time as at least the often even hourly timeouts don't occur even though time is way off.

comment:2 Changed 4 years ago by phantasm

Confirmed that disabling time sync feature of VBox guest additions on guest OS fixes the problem. Currently time is 20 minutes behind real time.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4. There were many fixes in the meantime.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use