VirtualBox

Ticket #4248 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Mouse becomes uncontrollable

Reported by: harmscon Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

After several hours of guest uptime, the mouse becomes uncontrollable - in both the guest VM and host desktops. Moving the mouse sends it jumping all over the guest vm desktop and it cannot be released by using the Host Key. The only way out is to use keyboard shortcuts to close the VM. The logs show lots of these messages:

03:54:46.567 vboxClipboardConvertToCTextForX11: VBoxX11ClipboardReadVBoxData returned VERR_TIMEOUT
03:54:46.568 vboxClipboardConvertToUtf8ForX11: VBoxX11ClipboardReadVBoxData returned VERR_TIMEOUT

Host: Ubuntu Hardy i386 Desktop
Guest: MS Windows XP Professional SP3

Attachments

VBox.log Download (77.6 KB) - added by harmscon 5 years ago.
VBox.log of affected session

Change History

Changed 5 years ago by harmscon

VBox.log of affected session

comment:1 follow-up: ↓ 2 Changed 5 years ago by michael

Is this reproducible? If so, can you test whether deactivating the shared clipboard for the guest makes a difference? Thanks.

comment:2 in reply to: ↑ 1 Changed 5 years ago by harmscon

Replying to michael:

Is this reproducible? If so, can you test whether deactivating the shared clipboard for the guest makes a difference? Thanks.

Hi michael,

Yes this is reproducible. In the guest window (winxp):

  • open a doc such as notepad
  • press Ctrl PrtScn
  • mouse becomes uncontrollable
  • pressing escape a couple of times restores control

I'd originally thought this issue occurred after the user pressed control-v to load the clipboard with text and was pasting across the Host/Guest interface, but obviously from above, the clipboard is being filled with the guest screen capture. After the pressing of escape a couple of times, the user can then paste the screen capture as usual into wordpad (still within the guest os), so the clipboard *is* being filled with the screen capture data - but it's also clobbering the mouse control for both host and guest. There is no copying or pasting across the Host/Guest interface at all. Anything else I can add?

comment:3 Changed 5 years ago by michael

Again, can you try disabling the shared clipboard in the settings for that machine to see if it makes a difference?

comment:4 Changed 5 years ago by harmscon

Disabling the shared clipboard makes no difference. The mouse goes wacky as soon as the user presses Ctrl+PrtScn. The problem is reproducible 100% and there is no time factor involved as mentioned in the original post: the bug occurs at the first instance of the keypress, regardless of the uptime of the VM.

comment:5 Changed 5 years ago by harmscon

Problem persists in VirtualBox 3.0.2-49928_Ubuntu_hardy.

Ctrl+PrtScn in a WindowsXP SP3 guest sends the mouse wild. It cannot be controlled, the mouse pointer jumps erratically around the screen in response to mouse movements. Hitting escape restores the mouse control. The problem exists with Shared Clipboard either Bidirectional or Disabled. The clipboard in the guest OS is successfully loaded with the screen capture in both instances.

Further, after this event, the performance of the VM degrades: opening menus is much slower, starting applications is slower, etc.

comment:6 Changed 5 years ago by visiobox

I have the same problem.

VirtualBox: 3.0.0 Host: Windows XP Professional SP3 Guest: Windows XP Professional SP3

comment:7 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.2.4 to VirtualBox 3.0.0
  • Component changed from clipboard to GUI

comment:8 Changed 5 years ago by harmscon

Bug confirmed to still exist in VirtualBox 3.0.4

Host: Linux Ubuntu 8.04
Guest: WinXP SP3 + VirtualBox GuestAdditions
Shared Clipboard: bidirectional

And if anything, the problem seems to be getting worse. Now the escape key is not sufficient to restore mouse control. It is now required to press the Host Key to restore mouse control.

comment:9 Changed 5 years ago by harmscon

There are many tickets currently open that share this common symptom, ie the mouse becomes uncontrollable. The ticket numbers are: #4713, #4248, #2603, #4252, #3350, #2575, #4700, #2660, #2682, #4817. The issue goes back through many versions of VirtualBox.

Common themes appears to be: USB mice/device, screen capture to clipboard or just plain becoming erratic after time (memory leak?).

This bug should be upgraded to blocker priority as it is no longer possible to be productive in this unstable environment.

comment:10 Changed 5 years ago by michael

I was not able to reproduce the Ctrl+PrtScr thing here. It sounds to me like some application is started in the background on your guest (or possibly your host?) which starts heavily thrashing the hard disk and slowing down everything (hence the jerky mouse movements and the clipboard time-outs) and that pressing Esc causes it to exit again.

comment:11 Changed 5 years ago by harmscon

There is no hard disk activity in either the guest or host during the erratic mouse event. I've just installed 3.0.6 and the issue persists although I did not update Guest Additions yet. Linux Ubuntu Hardy host-> Windows XP SP3 client-> MYOB Acc Plus windows application. I'll give this another look early next week and try to write a more thorough report. Thanks.

comment:12 Changed 4 years ago by harmscon

Bug is resolved in 3.0.10 (3.0.10-54097_Ubuntu_hardy). Thanks to the devs.

comment:13 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use