VirtualBox

Ticket #3350 (new defect)

Opened 5 years ago

Last modified 5 years ago

USB mouse stops working after VirtualBox 2.1.2 boots Windows XP

Reported by: nik.nicholson@… Owned by:
Priority: major Component: USB
Version: VirtualBox 2.1.2 Keywords: Mouse
Cc: Guest type: Windows
Host type: Linux

Description

I have a Toshiba Tecra S5 with Ubuntu 8.04 installed.

I have a Logitech wireless, USB mouse.

I have been running previous versions of Virtualbox with Windows XP as the guest and mouse integration has been working fine.

I installed VirtualBox 2.1.2. Installation was not smooth. Initially the package manager complained that it could not install the 2.1 - 2.1.2 update because I had conflicting packages installed.

Eventually I deleted virtualbox 2.1 off my machine, and then the installation then proceeded OK.

Then I went to install guest additions. During this install I got a message saying that my installation type did not support mouse pointer integration. However the guest continued to work with my wireless mouse without problem.

Today (next boot of windows in virtual box) when I booted windows the USB mouse stopped working. However the touchpad mouse continues to work.

Also, after shutting down virtualbox the USB mouse does not work in Linux either.

Removing the receiver and re-inserting it brings the USB mouse back, but only when virtualbox is stopped.

After a few debug boots. The mouse stops working immediately after I click OK for the keyboard capture message during the startup of windows.

Interestingly, I also have a ubuntu instance in another VM. Mouse works fine in this instance.

Further interestingly. If I de-install the guest additions from the windows instance. I get a pop up when I click one of the mouse buttons (either touchpad or USB) Then I get two pointers in the windows desktop. Each controlled independently by the touchpad and the USB mouse. (I have not tried using the mouse stick in the keyboard).

Then I re-installed guest additions and the original problem comes back.

I tried monitoring system messages during the boot sequence. No USB disconnect messages come to the message files when the mouse dies. Message does come when I remove and re-insert the receiver.

Change History

comment:1 Changed 5 years ago by harmscon

There are many tickets currently open that share this common symptom, ie the mouse becomes uncontrollable. The ticket numbers are: 4713, 4248, 2603, 4252, 3350, 2575, 4700, 2660, 2682, 4817. The issue goes back through many versions of VirtualBox.

Common themes appears to be: USB mice/device, screen capture to clipboard or just plain becoming erratic after time (memory leak?).

This bug should be upgraded to blocker priority as it is no longer possible to be productive in this unstable environment.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use