VirtualBox

Ticket #3095 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

unmeant transparent background in gui -> fixed in SVN

Reported by: scarlip Owned by:
Priority: major Component: GUI/compiz
Version: VirtualBox 3.0.0 Keywords: transparent
Cc: Guest type: other
Host type: Linux

Description

the background in the guest-window is transparent - i can see the desktop wallpaper through

guest: windows xp sp3 x86 setup cd host: ubuntu 8.10 x86

Attachments

t0.jpg Download (68.0 KB) - added by scarlip 5 years ago.
t1.jpg Download (37.0 KB) - added by scarlip 5 years ago.
t2.jpg Download (37.8 KB) - added by scarlip 5 years ago.
t3.jpg Download (39.3 KB) - added by scarlip 5 years ago.
OpenSolaris-grub.jpg Download (126.3 KB) - added by damidalla 5 years ago.
Screenshot of grub with OpenSolaris 2008.11 installed on virtualbox
virtualbox-opensuse-closing.png Download (195.6 KB) - added by damidalla 5 years ago.
Grub with OpenSolaris 2008.11 on virtualbox - grayed out (correct!)
Virtualbox222_Full-Screen_Draw_Issues.jpg Download (305.4 KB) - added by HyRax 5 years ago.
Virtualbox screen not re-drawn properly in a dual-monitor configuration.
Virtualbox304RedrawBug_Twinview_TwoMonitors.jpg Download (344.9 KB) - added by HyRax 5 years ago.
Continuing redraw issues under Virtualbox 3.0.4 (though not as bad as previously)

Change History

Changed 5 years ago by scarlip

Changed 5 years ago by scarlip

Changed 5 years ago by scarlip

Changed 5 years ago by scarlip

comment:1 Changed 5 years ago by uwgandalf

I have got the same issue, TS, do you have a nvidia card?

comment:2 Changed 5 years ago by tarvoj

I have the same issue in virtualbox 2.2 on ubuntu 9.04. wxp sp3 as guest. Guest is unusable.

comment:3 follow-up: ↓ 26 Changed 5 years ago by damidalla

I can confirm using Ubuntu 9.04, but only using compiz. It was not present at all using 2.1.4. It is not a problem related to the guest, as the strange behaviour is present for me using opensolaris, Windows XP, openSUSE and Windows 7, even when the virtualbox window only shows grub or even the bios logo of virtualbox. I attach two screenshots.

Changed 5 years ago by damidalla

Screenshot of grub with OpenSolaris 2008.11 installed on virtualbox

Changed 5 years ago by damidalla

Grub with OpenSolaris 2008.11 on virtualbox - grayed out (correct!)

comment:4 Changed 5 years ago by ngoonee

Same issue here on Arch Linux. Previously with 2.1.4 had the issue only on the Windows XP starting up screen, not on desktop, now it is all the time.

Only occurs with Compiz. Workaround so far for me is to use a keyboard shortcut to toggle redirect (under extra WM actions).

comment:5 Changed 5 years ago by chrismja

I am having the same issue. Similar to ngoonee, I (under previous versions of Virtualbox) only had the transparent windows issue during boot, but not after the guest got fully booted. Now it happens even after the guest is fully booted. I can't get the Compiz redirect workaround to work (that ngoonee mentioned). A temporary workaround is to temporarily stop Compiz while using Virtualbox. If using Ubuntu - run the command "metacity --replace" from the command line (without the quotes). Hope they get this issue resolved soon because Virtualbox is awesome!

comment:6 Changed 5 years ago by ngoonee

If you still want compiz (and I do), here's how to get it to work.

First, the setting is under Window Management -> Extra WM Actions -> Toggle Redirect, enable the plugin and set some key combination (I use <Super>w). Make sure not to use the HOST key for Virtualbox (default right-Ctrl)

Second, when running VirtualBox full-screen (I never run it windowed, unsure how that would work), FIRST PRESS YOUR HOST KEY, then press your key combination.

The thing is, VirtualBox grabs control of your keyboard even with integration enabled. An easy way to check if you're doing it correctly is to disable integration (HOST-I). When you press the HOST key with integration disabled, you'll see your mouse cursor from the host OS instead of your guest OS, then you can toggle redirect.

comment:7 Changed 5 years ago by chrismja

ngoonee, thanks for the how to. I have to hit the host key and key combo a dozen times or so before it will work. Can't get it to work in window, only fullscreen. This isn't ideal for me, but it'll work for now. Thanks again.

comment:8 Changed 5 years ago by lafa

I have the same problem with vbox 2.2 and jaunty with compiz enabled. the supper->w does not work for me, with the latest updates.

comment:9 Changed 5 years ago by breizhman

If you want compiz and jaunty, that work :

Create a schell script with :

#!/bin/bash export XLIB_SKIP_ARGB_VISUALS=1 VBoxManage startvm "name of VM"

comment:10 Changed 5 years ago by kendon

breizhman's solution seems to work for me, thx.

comment:11 Changed 5 years ago by jedisurfer

I get an error that the name is unknown for my vbox session. Is it looking for the machine name, "WinXP Image" in this case, or is it looking for the name of the .vdi file, which is "Windows XP" in this case?

I am running ubuntu 9.04 with Compiz and vbox 2.2.

Thx....

comment:12 Changed 5 years ago by frank

jedisurfer, to start a virtual machine like described above you have to specify it's VM name. If the name contains spaces, make sure to add quotes.

comment:13 Changed 5 years ago by HyRax

My host uses two displays off an NVidia 8800GT gfx card with Compiz enabled (screen config is TwinView - one giant screen). I generally run Virtualbox full-screen on my second monitor. I am using Virtualbox 2.2.2 but have had these issues since 2.2 (2.1 and earlier didn't have this issue for me).

My guest is any OS but with 3D acceleration enabled and in the case of a Linux guest, Compiz is enabled also.

I don't get the transparent boot screens that other people have been getting, however when I click on any application on my host outside of the Virtualbox session, the host's desktop wallpaper is immediately re-drawn over the Virtualbox session - completely.

If I roll the mouse back over the Virtualbox session, without clicking on anything, parts of the Virtualbox session re-appear as those parts of the screen are re-drawn. If I then update something full-screen in Virtualbox such as scroll a browser window, open an app full-screen within Virtualbox, rotate the guest's desktop cube, etc, the screen gets re-drawn OK and stays fine until it then disappears again when I click outside of Virtualbox again. See attached pic (shows my Jaunty host desktop with a Jaunty guest VM full-screen on the second half of the pic (the second monitor).

I have no such issues running Virtualbox in a window, however.

The workaround proposed by ngoonee does not work for me.

Changed 5 years ago by HyRax

Virtualbox screen not re-drawn properly in a dual-monitor configuration.

comment:14 Changed 5 years ago by jedisurfer

Frank - I did have it in quotes. Below is the script and the exact error. Thanks in advance for the assist.

SCRIPT #!/bin/bash export XLIB_SKIP_ARGB_VISUALS=1 VBoxManage startvm "WinXP Image"

ERROR: ./StartVbox.sh: line 2: export: `WinXP Image': not a valid identifier

If I run it all as one line I get this error: /bin/bash: export XLIB_SKIP_ARGB_VISUALS=1 VBoxManage startvm "WinXP Image" : No such file or directory

Thanks again...

comment:15 Changed 5 years ago by unique

I installed VBoxGTK (a frontend for Virtualbox) And now it works PERFECT!!!!!!

comment:16 follow-up: ↓ 17 Changed 5 years ago by hotspoons

I launch the regular QT4 front end (/usr/bin/VirtualBox) using a two line bash script, and it fixed my issues with ARGB transparent weirdness on the virtual machines:

#!/bin/bash export XLIB_SKIP_ARGB_VISUALS=1 VirtualBox

comment:17 in reply to: ↑ 16 Changed 5 years ago by hotspoons

That should have been:

#!/bin/bash
export XLIB_SKIP_ARGB_VISUALS=1
VirtualBox

comment:18 follow-up: ↓ 19 Changed 5 years ago by jdeslip

I have this problem, too.

Neither of the two "export XLIB_SKIP_ARGB_VISUALS=1" fixes work for me. Guest still launches with transparent background.

comment:19 in reply to: ↑ 18 Changed 5 years ago by jdeslip

Replying to jdeslip:

I have this problem, too.

Neither of the two "export XLIB_SKIP_ARGB_VISUALS=1" fixes work for me. Guest still launches with transparent background.

Umm. Strike that. It does work now... my old vbox window was open causes the new ones not to work :)

comment:20 Changed 5 years ago by Zaspath

This may help those that found XLIB_SKIP_ARGB_VISUALS=1 didn't resolve the issue, if you disable '3D Acceleration' in the guest settings the problem also stopped for me.

comment:21 Changed 5 years ago by ngoonee

Not marked as solved in new VBox 3.0, can anyone give it a try? Am waiting for the packagers for my distro to get this, currently.

comment:22 Changed 5 years ago by ngoonee

Ah, I was free, so I decided to hunt for another source. I can confirm this is NOT fixed in VBox 3, identical behaviour.

comment:23 Changed 5 years ago by HyRax

I can confirm this problem is still present in Virtualbox 3 Beta2 as well.

comment:24 Changed 5 years ago by michael

Ticket #3995 has been marked a duplicate of this one.

comment:25 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.1.0 to VirtualBox 3.0.0
  • Component changed from GUI to GUI/compiz
  • Guest type changed from Windows to other

Ticket #4374 has been marked a duplicate of this one.

comment:26 in reply to: ↑ 3 Changed 5 years ago by red282

Replying to damidalla:

I can confirm using Ubuntu 9.04, but only using compiz. It was not present at all using 2.1.4. It is not a problem related to the guest, as the strange behaviour is present for me using opensolaris, Windows XP, openSUSE and Windows 7, even when the virtualbox window only shows grub or even the bios logo of virtualbox. I attach two screenshots.

go to System -> Preferences -> Appearance then select "Visual Effects" then select "None" then click close.

comment:27 Changed 5 years ago by damidalla

Thanks red282, I do know well what Compiz is, but I do want to use Virtualbox even with Compiz on :)

However, it seems to be fixed, for me, in Virtualbox 3.0.2.

Virtualbox version < 3 : problem present but not always. Virtualbox 3.0.0: problem present always (the black becomes transparent, and the workarounds work only until another window/effect/notification appear on top of the VB window. Virtualbox 3.0.2: no problems at all!

comment:28 Changed 5 years ago by HyRax

I'm running Virtualbox 3.0.2 and just did a quick test with an Ubuntu Jaunty VM on an Ubuntu Jaunty Host and upon making he VM go full screen on my second monitor and then click in any window on the host maachine on the first monitor, the entire VM screen suddenly gets re-drawn to show the wallpaper of the host desktop and only whatever is updating in the VM gets re-drawn back again, eg: scrolling terminal window, mouse-over something, rotate Compiz desktop cube within VM, etc. Exactly as per the screenshot I previously uploaded.

So problem still not resolved unfortunately while the host is running Compiz enabled.

The VM is running the 3.0.2 Additions drivers.

The issue does NOT occur when running the VM as a restored or maximised window. It only occurs when running the VM as a full-screen app.

comment:29 Changed 5 years ago by michael

  • Summary changed from unmeant transparent background in gui to unmeant transparent background in gui -> fixed in SVN

Fixed in SVN (and in 3.0.2 for some installer packages, notably *not* the "All Distributions" installer though). See also ticket #4430 .

comment:30 Changed 5 years ago by michael

A quick update, particularly for those using the .run installer which didn't get the original fix. We have replaced the original fix with a new one which covered a couple of additional problem cases, and it would be great to have some feedback from people who experienced (experience) this issue that the new fix also works for them. I will link to test builds here (the links will work for a week or so), so that anyone interested can give the fix a try. The usual warnings about test builds apply - please only use official releases on production systems, and please only use testbuilds if they fix a specific problem that you are experiencing :) That said, here they are:

 http://www.virtualbox.org/download/testcase/VirtualBox-2009-07-23-18-19-36-lin32-3.0-3.0.3-r50373.run

 http://www.virtualbox.org/download/testcase/VirtualBox-2009-07-23-18-09-37-lin64-3.0-3.0.3-r50373.run

And for those interested, this is the fix that was applied:

 http://www.virtualbox.org/changeset/21760 and  http://www.virtualbox.org/changeset/21761

comment:31 Changed 5 years ago by michael

Ticket #4488 has been marked a duplicate of this one.

comment:32 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:33 Changed 5 years ago by HyRax

  • Status changed from closed to reopened
  • Resolution fixed deleted

I've just installed the new release of Virtualbox 3.0.4 (5th August 2009) and tried using an existing VM previously installed with the 3.0.2 Additions Driver. Interestingly all the window decorations (window titles, window edges, etc) in the Linux Guest were completely missing until I installed the 3.0.4 Additions Driver and rebooted.

My environment is two monitors driven by NVidia TwinView. The second monitor carries the guest VM and is switched to full-screen mode. The first screen shows the Ubuntu host desktop.

The Guest full-screen display now does NOT blank out with the Host's wallpaper if I click the mouse on the WALLPAPER of the host on the first monitor, however it still completely blanks the entire Guest screen with the Host's wallpaper if I click inside a WINDOW open on the Host side.

However unlike before, when I click back into the full-screen Guest on the second monitor, the entire screen up to the XY coordinate of the mouse is redrawn, ie: If I click the mouse at X=300 & Y=200, then a rectangle of 300x400 worth of Guest display is re-drawn perfectly from the top-left of the screen (0x0) to the location of the mouse pointer, leaving the rest of the screen with the Host's wallpaper. Keep clicking the mouse further towards the bottom-right of that screen and more of the display is redrawn, again confined to that rectangle. Note that this redraw method only works when clicking on the WALLPAPER of the Guest VM. Clicking into a window or a panel in the Guest does not do anything unless you click or hover over a self-refreshing element, and even then that will only redraw that portion of the screen only.

Rotating the Compiz cube etc redraws the entire screen as described previously.

Using the Guest in a maximised Virtualbox window as opposed to Fulll Screen mode does not exhibit any redraw problems at all.

I also notice that if I take an app capable of true full-screen (such as viewing an image with Eye of Gnome or using Firefox) and hit F11 to full-screen it, it does not work (or at the very least the Guest believes it has drawn it full screen because I cannot do anything else on-screen until I hit F11 again to restore the application back to a window. Full-screening things like a Gnome Terminal are unaffected since they are not really going full-screen - they're just maximising without window decorations instead.

Just to eliminate the possibility of an old Guest doing weird things, I setup a fresh VM with a fresh install of Ubuntu Jaunty 9.04, installed the 3.0.4 Additions Driver and I had the exact same problems.

At no time did I experience any transparent boot screens in Linux guests or Windows guests.

I have also re-tested by rebuilding the Host system with Ubuntu Jaunty 9.04 64-bit using NVidia drivers v180, v185 and v190, default Compiz settings and a completely fresh Home directory with a fresh Virtualbox installation. All experience the same issues.

I've submitted a new screenshot to illustrate what I see.

So while the problem has not actually been eliminated yet, it is certainly far less annoying than it was before. I'm open to new suggestions of things to try! :)

Changed 5 years ago by HyRax

Continuing redraw issues under Virtualbox 3.0.4 (though not as bad as previously)

comment:34 Changed 5 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

HyRex: I think that your issues are not related to the original one reported on this ticket, but rather belong on a new ticket in the GUI/Compiz category. Could you create one please? Thanks...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use