VirtualBox

Ticket #3096 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

linux vboxvideo no longer works with non-standard resolutions -> fixed in SVN

Reported by: stephanecharette Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

This used to work in previous 1.x, 2.0, and 2.1 releases of VB. I have a screen resolution in my Debian Etch 4 guest that ensures the guest takes just a little bit less than one of my physical screen. This way I can see just enough of the host to interact when I need it.

The relevant lines in my guest xorg.conf file are:

DefaultDepth 24 SubSection "Display"

Depth 24 Modes "1648x936" "1280x1024" "1024x768" "800x600" "640x480"

EndSubSection

Now that I've upgraded to VB 2.1.2, I re-installed the guest additions and rebooted the guest. But the guest desktop now doesn't show up correctly. The screen is only randomly updated, the menubar does not show, and when I type into a bash command-prompt window I only see maybe 1 out of 20 or 30 characters show up on the screen. (The other characters are there, since when I press ENTER the commands execute correctly. Only screen updates are not working.)

If I remove the "1648x936" resolution, then everything works fine at 1280x1024. (But this resolution is not wide enough and too high to fit on my screen!)

If I comment out the vboxvideo driver and use the vesa driver instead, then it comes up in 1280x1024, and again screen redraws are working fine.

Change History

comment:1 Changed 5 years ago by michael

Does this occur with both 2.1.0 and 2.1.2 Additions? By the way, nice that you are giving us feedback on all these otherwise untested cases :)

comment:2 Changed 5 years ago by mhw

The problem I have may be related. Sometime between late December and now, my Windows XP virtual guests w/ the guest additions got stuck at 800x600 max 4 bit color (16 colors) max. Symptoms are very similar to the original poster. Crappy screen, random (flashy) updates, poor resolution. It initially comes up 640x480 and won't let me easily increase the resolution. Going into desktop display properties and selecting Settings -> Advanced -> Adapter -> "List All Modes" only shows 640x480 and 800x600, both in 16 color mode. Selecting 800x600 gives me a little more resolution but that's all I can get.

I first noticed it after the 1/13/2009 Windows XP updates on one of the system. Rolling XP back to a previous restore point did not resolve the problem and, at that time, I noticed a second virtual guest, which had not been updated with the 1/13 updates, was also exhibiting the same problem. Deleting the vboxvideo driver restored full resolution video through the vesa driver in both. This was with 2.1.0. Installing 2.1.2 and reinstalling the guest additions did not resolve the problem. The vboxvideo driver still gives me 800x600 w/ 4 bit color. Deleting that driver restores it. So, yeah, it's on 2.1.0 and 2.1.2.

I updated VirtualBox from 2.0.6 to 2.1.0 on 12/22 (based on timestamps of the downloaded packages) and it may have started after the guest additions back then, I just didn't notice at the time. Not sure when I updated the guest additions in the individuals VM's.

My host hardware is a Lenovo T60p laptop, which also has an unusual screen resolution of 1400x1050 although I'm generally running it in 1280x1024 for external monitors.

Unfortunately, downgrading the VirtualBox host software to 2.0.6 doesn't seem to be viable for testing and debugging, due to configuration file changes (I get an error about unable to import settings). Too bad more effort isn't put into maintaining compatibility for diagnostic purposes. However, be that as it may, I was able to extract the 2.0.6 guest additions CD from that build and install them into the virtual guests after reinstalling the 2.1.2 host software. That was no help. I was definitely NOT experiencing this problem with 2.0.6 host engine and 2.0.6 guest additions prior to December.

Deleting the driver for the Virtual Box Graphics Display adapter under the hardware device manager then does restore full resolution but it tells me it found new hardware and wants to install the driver I just uninstalled. I have to tell it to stop installation at that point.

comment:3 Changed 5 years ago by mhw

Additions to previous comments...

I'm running Fedora 9 w/ stock Fedora 9 2.6.27 kernels. Host system fully up to date.

comment:4 Changed 5 years ago by gizmo

I have the same problem as mhw, and am running a Lenovo T61p laptop (not a T60p, like mhw). However, on my system I typically use a second monitor that runs 1280x1024, so the strange resolution of the laptop (mine has a larger screen and runs 1920x1200) shouldn't be a factor.

I haven't done the same level of troubleshooting, but I seem to only be able to get 640x480 4-bit color (although the display properties dialog claims to allow up to 1280x1024 in 32-bit color, when I set it, I get reverted to 640x480 4-bit). If I remove the virtualbox graphics adapter, I can then select (and actually use) the 1280x1024 32-bit color resolution. This happened with the upgrade from 2.1.0 to 2.1.2.

I'm running Fedora 10 x86_64 as the host with all the latest patches on the 2.6.27.9-159 kernel. The guest is Windows XP SP3 32-bit fully patched.

I'll be delighted to provide any additional information you may require.

comment:5 Changed 5 years ago by bbreslauer

I'm having a very similar problem. I'm running 2.1.2 on a Debian etch host with Debian sid/experimental on the guest, with kde 4.2. Both host and guest are running kernel 2.6.26. When KDE loads in the guest with the vboxvideo driver, it performs perfectly well (the screen updates continuously). However, if I log out, then the screen no longer updates unless another window moves over it or I move the window off-screen temporarily, then bring it back on screen. Keyboard and mouse still work, though I don't see the results unless I move the window off-screen and then back on. If I switch from the vboxvideo to vesa driver in X, then none of these peculiarities occur.

Let me know if I can provide more help.

comment:6 follow-up: ↓ 7 Changed 5 years ago by michael

mhw and gizmo: your issues are unrelated, as the X11 and Windows guest additions are quite different pieces of code.

bbreslauer, I suspect that yours is a different issue, but I haven't had time to look at it yet.

stephanecharette: I have reproduced your issue, and it occurs when the virtual resolution is larger than the current resolution - in your case, this happened because the first graphics mode in your list - "1648x936" - is selected by default, but the virtual Y resolution is set to 1024 to fit the mode "1280x1024". I am working at fixing this.

comment:7 in reply to: ↑ 6 Changed 5 years ago by stephanecharette

Replying to michael:

stephanecharette: I have reproduced your issue, and it occurs when the virtual resolution is larger than the current resolution - in your case, this happened because the first graphics mode in your list - "1648x936" - is selected by default, but the virtual Y resolution is set to 1024 to fit the mode "1280x1024". I am working at fixing this.

No, my actual X resolution using a dual-head NVidia card is 3360x1050. Trying to set a guest to use just slightly smaller than 1 screen used to work. So each of my physical screens displays 1680x1050 (widescreen LCD pannels).

comment:8 Changed 5 years ago by michael

You misunderstood me - I meant the virtual and the actual resolution (both) on the guest. Do you remember the past days of Linux, when you would always scroll over a virtual desktop larger than your actual screen resolution by dragging the mouse in the edges of the screen? That is what I am talking about.

comment:9 Changed 5 years ago by michael

  • Summary changed from linux vboxvideo no longer works with non-standard resolutions to linux vboxvideo no longer works with non-standard resolutions -> fixed in SVN

This should be fixed for version 2.1.4. Please test with that version. You will need to reinstall the additions using the version in 2.1.4. bbreslauer, if stephanecharette confirms that his issue is fixed, but yours persists, please open a new ticket for it.

comment:10 Changed 5 years ago by michael

bbreslauer: I suspect that your issue is the same as this:  http://www.virtualbox.org/ticket/2985

comment:11 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in 2.1.4.

comment:12 Changed 5 years ago by stephanecharette

Michael and/or whoever worked on this bug report -- thank you! Worked like a charm as soon as I upgraded my host to 2.1.4 and my guest to the new guest additions. :)

comment:13 Changed 5 years ago by mhw

Well, this didn't fix the Windows guest problem. But I guess we didn't really expect it to, did we? I figured out a lot more whacky stuff with this one and can even recover the high res modes but they're not sticky and I'm back to the crappy res every time I shut the guest down and start it back up. I've opened a new ticket 3367 here with all the new information on the Windows guest / Linux host issue:

 http://www.virtualbox.org/ticket/3367

Fun and games with whacked out video modes in XP guest / Linux host

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use