VirtualBox

Ticket #4430 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Graphics broken with any guest on Linux host (only with 128 MB VRAM) -> reopened due to regression

Reported by: srattai Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.4 Keywords: graphics
Cc: Guest type: Linux
Host type: Linux

Description

After upgrade to 3.0.0: Graphics are mangled not only for existing guests but for new ones, too. I set up a new machine and tried to boot from an iso, the graphics is already unusable at boot time of the virtual machine.

The same is true for existing machines but if I try to close the window and cancel the 'Close Virtual Machine' dialog, the graphics output suddenly may become visible but unusable.

Attachments

VBox.log Download (43.3 KB) - added by srattai 5 years ago.
Log
virtualbox.jpeg Download (27.1 KB) - added by srattai 5 years ago.
virtualbox_canceled.jpeg Download (80.8 KB) - added by srattai 5 years ago.
vbox_at_128mb.jpg Download (104.3 KB) - added by ju2wheels 5 years ago.
Virtualbox running Ubuntu 9.04 32bit base install at 128mb vid mem

Change History

Changed 5 years ago by srattai

Log

Changed 5 years ago by srattai

Changed 5 years ago by srattai

comment:1 Changed 5 years ago by lyallp

Refer to public forum entry  http://forums.virtualbox.org/viewtopic.php?f=3&t=19498.

Contents duplicated here, just in case.

I also am experiencing this issue with Gentoo guest running in a Gentoo Host (Intel quad core CPU) using kdm as my greeter and fluxbox as my desktop. My installation is deliberately very minimal.

My guest has 2 CPU's configured.

The visual effect, for me, is the whole screen is 'compressed' to the top 5% of the screen, leaving the remaining 95% lower part, black.

Sending ctlr-alt-backspace to the machine shows the screen refreshing, so I knew it was working, just not displaying.

Host-F1 then Host-F7 refreshes and fixes the problem (thanks to an earlier post for that one!)

It should also be noted, if I restart X (ie, log out), the corruption returns, requiring another Host-F1,Host-F7.

It was not a problem with the older 2.2.4 additions.

I rebooted to single user mode and re-installed the Guest additions by using the

  • Devices->Install Guest Additions option
  • mount /dev/cdrom
  • cd /mnt/cdrom
  • ./VBoxLinuxAdditions-x86.run

This had no effect. Assorted software versions include :-

xorg 1.5.3-r6 kernel gentoo-sources 2.6.28-gentoo-r5 compiled with gcc 4.3.2

Capture from the Runtime attributes dialog.

Runtime Attributes Screen Resolution 952x727x32 VT-x/AMD-V Enabled Nested Paging Disabled Guest Additions Version 1.4

Guest OS Type Linux 2.6

Hard Disk Statistics

IDE Primary Master DMA Transfers 18,417 PIO Transfers 474 Data Read 171,660,288 B Data Written 76,237,824 B

CD/DVD-ROM Statistics

DMA Transfers 178 PIO Transfers 301

Data Read 4,110,336 B Data Written 0 B

Network Adapter Statistics

Adapter 1

Data Transmitted 1,374 B Data Received 25,580 B

comment:2 Changed 5 years ago by srattai

What would I do with Windows guests ? The lack of virtual terminals once again renders the system unusable...

comment:3 Changed 5 years ago by michael

Could you please retry this with VirtualBox 3.0.2? This issue may be fixed there.

comment:4 Changed 5 years ago by lyallp

FYI: As mentioned in the forums, lowering the Video memory to 64MB works also. I will try 3.0.2 as soon as I can organise it to be placed in the Gentoo jokey overlay.

comment:5 Changed 5 years ago by ju2wheels

This has not been fixed in 3.0.2 . It made my system lock up completely after a few minutes of use. When I turned the Video memory down to 64mb as suggested above it does work. But at 128mb it locks up my guest and makes GDM show up scrunched up into about 2% of the vertical space available at the top of the screen (once logged in however X restores itself to full size).

Changed 5 years ago by ju2wheels

Virtualbox running Ubuntu 9.04 32bit base install at 128mb vid mem

comment:6 Changed 5 years ago by sandervl73

  • Summary changed from Graphics broken with any guest on Linux host to Graphics broken with any guest on Linux host (only with 128 MB VRAM)

comment:7 Changed 5 years ago by sandervl73

The original problem report is not related to the other comments (reporter used 32 MB).

We're looking into it. Keep in mind though that you are just wasting memory configuring a VM with so much VRAM, unless you have special requirements.

comment:8 Changed 5 years ago by srattai

I just installed version 3.0.2 which doesn't make a difference. I tried with video memory sizes of 16 and 8 MB which did not change anything.

comment:9 Changed 5 years ago by lyallp

I installed 3.0.2 on Gentoo Linux, x86. Using a Gentoo Linux guest, I upgraded the tools to 3.0.2 and the problem persists. Using 128MB VMEM, the video is crunched up to the top, fixable by switching consoles. Using 64MB VMEM, no problems.

comment:10 Changed 5 years ago by michael

We have found the problem and fixed it in svn. It should hit the OSE repositories tomorrow if anyone feels like testing it. (It is an error setting the initial line pitch in the guest X.Org video driver, as you might have guessed from the look of the screen).

comment:11 Changed 5 years ago by michael

#4517 has been marked a duplicate of this ticket.

comment:12 Changed 5 years ago by lyallp

My thanks to the VirtualBox team for their efforts.

comment:13 Changed 5 years ago by srattai

I just compiled Rev. 21480 which does not work.

comment:14 Changed 5 years ago by michael

The changeset is r21532, and you only need to build the (X.Org) Guest Additions.

comment:15 Changed 5 years ago by srattai

Just tested 21573 which seems to be working.

Just out of curiousity- aren't the Guest Additions only active when the guest loads them ? The graphics output was already unusable during boot/'bios' phase.

comment:16 Changed 5 years ago by michael

srattat: sorry, I obviously paid too much attention to the (changed) ticket title and not enough to your comments and screen shots. It looks like you are seeing a different issue to the one I fixed, but one which should in fact be fixed in 3.0.2. That issue can normally be worked around by setting the environment variable XLIB_SKIP_ARGB_VISUALS=1 when starting VirtualBox, but which has the side effect of preventing guest 3D from working. (3.0.2 is actually supposed to automatically set this variable for all modules except the 3D one.) If you can still reproduce the issue, can you try starting VirtualBox with that variable set?

comment:17 Changed 5 years ago by michael

It turns out that two separate issues have been discussed on this ticket, both of which have been fixed in SVN. One is that the the VirtualBox windows are shown with the wrong colours or partly transparent, and this is discussed in #3095 . The other is that X11 guests with Additions installed and large amounts of VRAM start with their display compressed into a few lines until the window is resized. Both issues are fixed in SVN, and the fix for the first is also in 3.0.2 for most of the Linux installation packages (notably not the All Distributions package).

comment:18 Changed 5 years ago by michael

  • Summary changed from Graphics broken with any guest on Linux host (only with 128 MB VRAM) to Graphics broken with any guest on Linux host (only with 128 MB VRAM) -> fixed in SVN

Ticket #4517 has been marked a duplicate of this one.

comment:19 Changed 5 years ago by ju2wheels

Honestly michael, I actually dont consider the two issues separate because the transparency problem only appeared for me when I had VRAM set wrong, thus causing my VM to become unstable once I got passed the compressed login screen.

comment:20 Changed 5 years ago by michael

ju2wheels: interesting, I wasn't aware of that. However, when I said that they are separate issues, I meant that they are caused by separate problems in the code (the transparency is a problem in the Qt library on the host and/or the host display drivers which we work around, while the squashed display is a bug in the X11 Guest Additions).

comment:21 Changed 5 years ago by michael

A quick update, particularly for those using the .run installer which didn't get the original fix. We have replaced the original fix with a new one which covered a couple of additional problem cases, and it would be great to have some feedback from people who experienced (experience) this issue that the new fix also works for them. I will link to test builds here (the links will work for a week or so), so that anyone interested can give the fix a try. The usual warnings about test builds apply - please only use official releases on production systems, and please only use testbuilds if they fix a specific problem that you are experiencing :) That said, here they are:

 http://www.virtualbox.org/download/testcase/VirtualBox-2009-07-23-18-19-36-lin32-3.0-3.0.3-r50373.run

 http://www.virtualbox.org/download/testcase/VirtualBox-2009-07-23-18-09-37-lin64-3.0-3.0.3-r50373.run

And for those interested, this is the fix that was applied:

 http://www.virtualbox.org/changeset/21760 and  http://www.virtualbox.org/changeset/21761

comment:22 Changed 5 years ago by michael

Ah drat, this ticket was being used for the 128MB RAM issue, #3095 was for the transparency issue.

comment:23 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:24 Changed 5 years ago by michael

  • Status changed from closed to reopened
  • Version changed from VirtualBox 3.0.0 to VirtualBox 3.0.4
  • Resolution fixed deleted
  • Summary changed from Graphics broken with any guest on Linux host (only with 128 MB VRAM) -> fixed in SVN to Graphics broken with any guest on Linux host (only with 128 MB VRAM) -> reopened due to regression

This is not completely fixed - with the 3.0.4 Guest Additions the problem can be seen on Fedora guests with relatively (!) small amounts of VRAM (reproduced with 20MB VRAM) which worked fine with the 3.0.2 Additions. See  http://forums.virtualbox.org/viewtopic.php?f=1&t=20952 for details.

In fact, this seems to be a regression caused by the fix to the original problem. We have reproduced the issue locally, and I believe I have fixed it. A testbuild of the Additions ( disclaimer here...) in which the problem should be fixed can be downloaded at  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r50791.iso. The link will be valid for a week or so.

comment:25 Changed 5 years ago by bughunterbtf

I have tried the testbuild and it has fixed the video issues I was having. Host - Vista Guest - Fedora 11

comment:26 Changed 5 years ago by sej7278

3.0.5 guest additions from ISO above works for me too - GDM is not corrupted, screen resizing works up to 1920x1200, mouse integration etc.

Host: Fedora10 64-Bit, 128Mb VRAM, running 3.0.4 PUEL with VT-x enabled.

Guest: Fedora11 64-Bit, 16Mb VRAM, no 3D/compiz, kernel 2.6.29.6-217.2.3.fc11.x86_64.

comment:27 Changed 5 years ago by michael

Ticket #4764 has been marked a duplicate of this one.

comment:28 Changed 5 years ago by dmiller

Just a note to say I was having issues with Fedora 10 as a guest on a Vista Host machine, any time I booted the guest box the screen was garbled. Multiple re-starts of the X server would fix it until I restarted the guest machine.

Installing Vbox addons from the link above resolved it. I was using the default vbox addins from version 3.0.4r50677.

Thanks Michael!

comment:29 Changed 5 years ago by michael

I refreshed the link in comment 24, so it will be valid for another week or so as of now.

comment:30 Changed 5 years ago by whistman

Thanks Michael; I downloaded it this morning. Will install, test and report results tonight.

comment:31 Changed 5 years ago by dschaefer

Thanks, Michael! This helped me with latest Fedora 11 guest on Windows 7 host. Login screen and desktop no longer messed.

comment:32 Changed 5 years ago by michael

Ticket #4798 has been marked a duplicate of this one.

comment:33 Changed 5 years ago by jpellish

Thanks, Michael. This fix worked great.

comment:34 Changed 5 years ago by stuartd

I was having the same issue running Fedora 11 (2.6.29.4-167.fc11.x86_64) as a guest on Windows 7 Beta under VirtualBox 3.0.4r50677 regardless of the virtual video adapter settings. After the installation of the 3.04 GA package the Gnome login screen was scrambled and the guest basically locked.

After booting it single user mode and installing the VirtualBox-2009-07-23-18-09-37-lin64-3.0-3.0.3-r50373.run everything is working perfectly (including resize) with any combination of HW acceleration and video RAM.

Hope this helps, thanks very much for the beta GA package.

comment:35 Changed 5 years ago by stanislaw

Thank you for the solution!

Is this problem fixed in 3.0.6-52128?

comment:36 Changed 5 years ago by michael

It should be, but in the end people experiencing the issue have to decide that, so feel free to test it for yourself and post feedback here.

comment:37 Changed 5 years ago by stanislaw

Ok, I confirm it works for a fully upgraded Fedora 11. It seems, you can safely update to 3.0.6. Well, thanks again for your effort, Michael.

comment:38 Changed 5 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use