VirtualBox

Opened 17 months ago

Last modified 34 hours ago

#21515 reopened defect

Windows 11 VM: graphics are still broken. But on Windows 10 VM everything looks fine.

Reported by: boxer01 Owned by:
Component: WDDM Version: VirtualBox-7.0.6
Keywords: video glitches Cc:
Guest type: Windows Host type: Windows

Description

I already opened the ticket #21136 for 7.0 Beta / 7.0.0 release. Since then, some improvements could be seen. For example, I only see this unwanted transparency on the Windows 11 VM; the Windows 10 VM on the same host works without such troubles. And since at least builds 6.1.41-154912 / 7.0.5-154910 or 6.1.41-155125 / 7.0.5-155126, there is no crash of VM if the newer version of the display driver is installed during the guest addition installation.

But there is still this unwanted and troubling transparency in Windows 11 VM, which making usage of the Windows 11 in VM a little bit difficult. So it would be nice if somebody would correct this too. The same VM on current 6.1 has no such troubles.

As usual, I add some logs.

Attachments (12)

Vbox_7.0.97-155973_dip_logs.7z (101.6 KB ) - added by boxer01 17 months ago.
Logs of Windows 11 on VBox 7 VM
Vbox_7.0.Win10_OK.7z (20.9 KB ) - added by boxer01 17 months ago.
Logs of Windows 10 on VBox 7 VM
freezed-GA-7-0-6-uninstall-Win11-22H2.png (249.7 KB ) - added by Edmund Laugasson 16 months ago.
freezed Guest Additions 7.0.6 uninstallation inside Win11 22H2 virtual machine
VBox_7.0.9-158223_vid.7z (124.2 KB ) - added by boxer01 13 months ago.
Logs of version 7.0.9-158223.
2023-07-19-22-54-43.log (294.6 KB ) - added by gexdigital 12 months ago.
jmeter.png (30.4 KB ) - added by gexdigital 12 months ago.
OO_Shut_up.png (80.5 KB ) - added by boxer01 12 months ago.
O&O ShutUp Screenshot
%22New%22_Notepad.png (49.7 KB ) - added by boxer01 12 months ago.
"New" Notepad Screenshot
JMeter.png (39.4 KB ) - added by gexdigital 9 months ago.
MsOffice01.png (23.1 KB ) - added by gexdigital 9 months ago.
MsOffice02.png (25.7 KB ) - added by gexdigital 9 months ago.
MsOffice03.png (29.1 KB ) - added by gexdigital 9 months ago.

Download all attachments as: .zip

Change History (62)

by boxer01, 17 months ago

Logs of Windows 11 on VBox 7 VM

comment:1 by boxer01, 17 months ago

Some similar tickets from current version #21448, #21433

by boxer01, 17 months ago

Attachment: Vbox_7.0.Win10_OK.7z added

Logs of Windows 10 on VBox 7 VM

comment:2 by boxer01, 17 months ago

Still here in 7.0.97-156054.

comment:3 by boxer01, 16 months ago

Still here in 7.0.7-156262 and 7.0.97-156271.

by Edmund Laugasson, 16 months ago

freezed Guest Additions 7.0.6 uninstallation inside Win11 22H2 virtual machine

comment:5 by Edmund Laugasson, 16 months ago

I can confirm that bug. Inside virtual machine installed MS Windows 11 22H2 and after installing 7.0.6 Guest Additions (GA), having same video glitches - unwanted transparency, random menus blinking, Notepad is totally black (even menus) and therefore unusable. When trying to uninstall GA, the VM freezes (see included screenshot with name freezed-GA-7-0-6-uninstall-Win11-22H2.png). 3D acceleration was enabled in VM settings with VBoxSVGA virtual adapter as offered by default, also 256 MB of video memory (maximum) were used. RDP and recording were disabled. After forcibly resetting, still Win11 will survive and VM will boot afterwards and somehow GA are uninstalled.

Last edited 16 months ago by Edmund Laugasson (previous) (diff)

comment:6 by boxer01, 16 months ago

Still here in 7.0.7-156678 and 7.0.97-156683.

comment:7 by boxer01, 14 months ago

Finally works for me as of 7.0.9-157502. Other tickets with probably same issues: #21595, #21594, #21604, #21607, #21624, #21667

Last edited 14 months ago by boxer01 (previous) (diff)

comment:8 by boxer01, 14 months ago

Already found the first glitch. If one opens a "new" Notepad from Windows 11 (not an old one from Windows 95 days), and set it to the Dark Theme, or the OS has a dark theme - then one couldn't see any text, because the background and foreground is all black. Just a big black field.

comment:9 by ConcreteGannet, 14 months ago

Windows 11 requires hardware 3D acceleration, so I can no longer turn it off in VirtualBox. I have VirtualBox 7.0.8.

I can confirm @boxer01's observation - Notepad in dark mode is black-on-black. I get endless flickering when I use the Windows search box. Excel is unusable - mostly grey with no user interface displayed.

My stack is Windows 11 guest, VirtualBox 7.0.8, Debian 11 ("bullseye") host, nvidia driver 470-182-03-1 on Lenovo Thinkpad P1 Gen 2 with NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] (rev a1)

Is a stable 7.0.9 coming soon?

in reply to:  9 comment:10 by boxer01, 14 months ago

Replying to ConcreteGannet:

Is a stable 7.0.9 coming soon?

I see another trouble slowly coming: this behavior was first reported at the very beginning of the beta testing 9 months ago. There are some improvements here, but we still have some issues with the current Windows version as a guest. And the VBox 6.1 will be out of support in 6 or 7 months, by the end of the 2023, see the announcement on the download page. So from January 2024 on one would need to use either older Windows version with supported VBox version or downgrade the VBox to use it with modern Windows version.

Your question about stable 7.0.9 is cute. I also hope, that we get this issues fixed real soon. But looking back in the past - it is really the hope.

So, enough whining, this is not the spirit we need here. ;-)

comment:11 by boxer01, 14 months ago

Still here in 7.0.9-157689 and 7.0.97-157682.

Last edited 14 months ago by boxer01 (previous) (diff)

comment:12 by boxer01, 14 months ago

Partly good news here! With the current 1577xx / 1578xx test builds, I can see yellow text on the black background in the "new" Notepad in the dark mode, as described above. It's better than before (black on black), but the same VM under VBox 6.1.45 current build has it right: white font on the black background. And: I still can't see the cogwheel or gearwheel to the settings on the right side. But I can click it, because I know it should be here, even if it is invisible.

BTW, the all links to the test build are gone

comment:13 by boxer01, 13 months ago

It's still here in 7.0.9-158070 and 7.0.97-158051.

comment:14 by boxer01, 13 months ago

See forum topic also.

comment:15 by boxer01, 13 months ago

Still here in 7.0.9-158223. I put my current logs here.

by boxer01, 13 months ago

Attachment: VBox_7.0.9-158223_vid.7z added

Logs of version 7.0.9-158223.

comment:16 by galitsyn, 12 months ago

Resolution: fixed
Status: newclosed

Hello,

We just released VirtualBox 7.0.10. This issue should be fixed in this release. Culd you please give it a try? Packages are available on our downloads page.

by gexdigital, 12 months ago

Attachment: 2023-07-19-22-54-43.log added

comment:17 by gexdigital, 12 months ago

Definitely version 7.0.10 is better than ever with windows 11. But some artifacts still appears when 3D Hardware Acceleration is enabled and JMeter with DDRAW is in use. Looks like 3D Hardware Acceleration off runs good!. With a very low framerate in animations but is usable as previous versions of virtualbox 6.x

by gexdigital, 12 months ago

Attachment: jmeter.png added

comment:18 by boxer01, 12 months ago

Just checked the 7.0.10 and described problems with "new" notepad (see comment 12 above) are still here. I also see some problems with .NET applications. I use O&O ShutUp and the labels there are all scrambled and changing if one move mouse over it.

Another user just wrote about some problems with Java applications like JMeter.

I'm afraid we have to reopen this ticket.;-) Or should I open a new ticket for a new version?

Last edited 12 months ago by boxer01 (previous) (diff)

by boxer01, 12 months ago

Attachment: OO_Shut_up.png added

O&O ShutUp Screenshot

by boxer01, 12 months ago

Attachment: %22New%22_Notepad.png added

"New" Notepad Screenshot

comment:19 by boxer01, 12 months ago

The issues with O&O Shut up could be resolved with repaint. Either minimize it and restore it afterward. Or change the VM to the full-screen mode and back then. "New" notepad's issues can't be solved this way - font color is still wrong then. And one can barely see the settings wheel icon.

comment:20 by fth0, 9 months ago

FWIW, the issues with O&O ShutUp10++ can also be reproduced in a Windows 10 guest running in VirtualBox 7.0.12 running on a Windows 10 or Linux Mint 20 host. GPU is an Intel UHD Graphics 620 (Intel Core i5-8265U).

Last edited 9 months ago by fth0 (previous) (diff)

comment:21 by gexdigital, 9 months ago

Resolution: fixed
Status: closedreopened

This has not been fixed yet in testbuild 7.0.x revision 159676. With 3D Acceleration Enabled Font corruption persists in JMeter, and MS Office still exhibits missing icons, bad colors, and distortion on buttons. I've reopened this ticket.

by gexdigital, 9 months ago

Attachment: JMeter.png added

by gexdigital, 9 months ago

Attachment: MsOffice01.png added

by gexdigital, 9 months ago

Attachment: MsOffice02.png added

by gexdigital, 9 months ago

Attachment: MsOffice03.png added

comment:22 by boxer01, 9 months ago

As I wrote in #21806, this is now happening only if 3D is activated. But then it happens not just in Windows 11, but also in Windows 10. I have to find time to check my old Windows 8 and 7 VMs ;-).

So the original troubles with graphics, no matter if 3D was activated or not, were solved as of version 7.0.9. But issues with graphics with 3D activated are still here as of 7.0.13-159676.

comment:23 by boxer01, 9 months ago

Still here in 7.0.13-160152.

comment:24 by boxer01, 8 months ago

Still here in 7.0.13-160260.

comment:25 by ConcreteGannet, 8 months ago

Still in 7.0.12 with Windows 11. Note Windows 11 requires 3D acceleration so it's no longer possible to work around the issue by turning off 3D.

comment:26 by ConcreteGannet, 8 months ago

7.0.12 seems to be an improvement.

I updated to Windows 11 23H2, and Notepad is now working in light and dark modes, so one problem has been fixed.

I was able to fix Excel by adding a registry setting. The Excel UI option to disable hardware graphics acceleration is no longer provided.

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Graphics]

"DisableHardwareAcceleration"=dword:00000001

One problem remains. When you type anything into the search box in Windows you get endless flicker of the search menu. The search box is autocompleting, so it's as if there's an infinite loop where typing anything does a request which produces a list of results and appends some autocomplete text, which triggers another update when I haven't typed any new text. The search results flicker repeatedly.

Type a few times, and the VM and VirtualBox crashes completely after a few minutes.

in reply to:  26 comment:27 by tekstryder, 8 months ago

Replying to ConcreteGannet:

When you type anything into the search box in Windows you get endless flicker of the search menu.

I noted that in #21233 as well, and provided a screencast of the issue:

https://www.virtualbox.org/ticket/21233#comment:10

comment:28 by boxer01, 8 months ago

Still here in 7.0.97-160431.

comment:29 by boxer01, 8 months ago

Still here in 7.0.97-160458.

comment:30 by boxer01, 6 months ago

Happy New Year, everybody! ;-) This issue is still here nearly 3 Month after its reopening, and the new stable version is just around the corner, just next week. Versions 7.0.13-160845, 7.0.13-161031, 7.0.97-160850, 7.0.97-161032

comment:31 by boxer01, 6 months ago

Still here in 7.0.14-161095.

comment:32 by boxer01, 6 months ago

Still here in 7.0.15-161311.

comment:33 by boxer01, 6 months ago

See #21959 also.

comment:34 by boxer01, 6 months ago

Still here in 7.0.15-161357.

comment:35 by boxer01, 6 months ago

Still here in 7.0.15-161407.

comment:36 by sunlover1, 5 months ago

This ticket mentions several issues. For example, flickering in Search menu has been fixed. Could you please describe what exactly is "still here"?

in reply to:  36 comment:37 by boxer01, 5 months ago

Replying to sunlover1:

This ticket mentions several issues. For example, flickering in Search menu has been fixed. Could you please describe what exactly is "still here"?

As I wrote in the comment:18 I see troubles with "new" Notepad on Windows 11 and .NET application like O&O Shutup. Others see some troubles with Java applications, and I linked the ticket to some other kind of troubles with the graphics.

comment:38 by boxer01, 5 months ago

BTW, just tested with new guest additions version 161506 - still see these issues.

comment:39 by sunlover1, 5 months ago

7.0 additions build 161711 fixes O&O Shutup graphics corruption: https://www.virtualbox.org/wiki/Testbuilds

Notepad problem is not yet fixed.

Last edited 5 months ago by sunlover1 (previous) (diff)

comment:40 by ConcreteGannet, 5 months ago

Windows 11 guest, VirtualBox 7.0.14, Debian 11 ("bullseye") host, nvidia driver 525.147.05 on Lenovo Thinkpad P1 Gen 2 with NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] (rev a1) is now working fine for me, including hardware acceleration for Excel.

in reply to:  40 comment:41 by boxer01, 5 months ago

Replying to ConcreteGannet:

Windows 11 guest... is now working fine for me, including hardware acceleration for Excel.

Somebody else wrote here about other troubles with Office 365, see comments #comment:21. Did you have them, are they gone?

You didn't have troubles with notepad, but I have and they are still here.

in reply to:  39 comment:42 by boxer01, 5 months ago

Replying to sunlover1:

7.0 additions build 161711 fixes O&O Shutup graphics corruption:

Notepad problem is not yet fixed.

As of version 7.0.15-161716, I can confirm this. Thank you very much! Now waiting for solution of the other 3D related bugs like "new" Notepad, which still yellow on dark and partly invisible on my side.

Some other people wrote about issues with Office 365 or 2021 and others here and in the Linux related ticket (#21233). And the issues with Microsoft Weather in the same ticket. And the troubles with JMetter here and others have troubles with Fusion360 (#21959). Will they also be fixed, please? ;-)

comment:43 by boxer01, 5 months ago

I created a small list of graphic related bugs in version 7.0.x.

#21955 - Heavy screen flickering VirtualBox 6.1.48 / 7.0.12 Ubuntu Wayland guest kernels 6.4 / 6.5
#22012 - Windows 11 guest with 3d enabled results in black screen.
#22013 - Intense Screen Switching/blanking Win 10 Pro64 Guest on Win 10 Pro
#21886 - vbox 7.0.12 vboxSVGA with 3d "on" hangs on win 11 22h2 host
#21924 - 3d acceleration does not work
#21941 - Linux Guest graphics freezes when using 3D acceleration
#21487 - 3D acceleration causes Linux guest freezes
#21772 - Virtualbox 7.0.97 r158222 guest addition cause a bluescreen on Windows 8.1 guests
#21774 - Windows 10 guest: weird fonts after upgrade to 7.0.10
#21789 - Alibre (3D) crashes in VBox7, but worked in VBox6
#21795 - Windows 10 Host: Very small fonts on 2.8k displays
#21798 - Windows 7 on Virtualbox 7.0.10 Guest Additions MS Office 2019
#21800 - Seamless mode not restored
#21801 - Seamless mode: Window 10 task bar gone
#21811 - D3DXCreateTextureFromFileInMemoryEx not working
#21863 - Seamless mode not activated upon startup on WinXP VM
#21891 - UI starts flickering in Debian unstable
#21594 - 3D acceleration
#21595 - Windows 11 installed fresh in 7.0.8 having video issues.
#21597 - 7.0.8 Windows 7 guest with 3D acceleration enabled crashes when changing resolution / gets stuck in the bootloop if the resolution was changed
#21600 - No video output (black screen) on Windows XP after installing GAs
#21604 - Ubuntu Desktop graphics broken inside VirtualBox 7.0.8, but works well inside VirtualBox 6.1.44
#21606 - Current Stable Guest Additions break Windows XP VBoxVGA (black screen)
#21607 - Failed to boot windows 11 guest with VBoxSVGA+3D since vbox 7.0 on Archlinux host
#21608 - VirtualBox on Windows 11 AMD 5950x host, w/AMD W6800 Pro GFX, Guest Additions hang/freeze or blinking
#21624 - Transparency effects Win10, Win 11 crash 3d acceleration
#21667 - Windows 10 doesn't work with Guest additions V7.0.8
#21704 - The 3D acceleration of Windows7 has problems under certain circumstances
#21738 - VBoxVGA driver cannot display
#21754 - Unreadable font colors with dark theme on Windows
#21425 - Unreadable fonts in Windows 11 as guest in Virtualbox
#21426 - Unable to resize screen on Windows 10 guest with 3D acceleration enabled
#21427 - Unable to resize screen on Windows 10 guest with 3D acceleration enabled
#21433 - 7.0.x Graphical artifacts with 3D acceleration enabled | Windows 7/10 guest
#21448 - VirtualBox 7 VM Freezes or UI glitches
#21505 - Black Screen and Blinking Cursor using 3D Accelerator
#21411 - VBOX 7.0.x graphic corruption - Intel GPU
#21582 - Enabling 3D acceleration crashes Gnome Shell (unable to log in)
#21153 - Programs show garbage output
#21761 - AutoDesk Fusion 360 crashes with VirtualBox 7 + 3d Acceleration enabled
#21295 - Win 7 32b guest VM craash when installing guest additions 7.0.4
#21350 - 3d Graphics with windows 10 as a guest
#21405 - Linux guest on Windows 10 host does not start in seamless mode
#21146 - Buttons,transparent list background and startmenu are garbaged with 3d acceleration in win10 guest.
#21187 - Draw issues with 3d acceleration enabled on Windows Server 2016
#21195 - Display issue with Windows 8
#21198 - VirtualBox 7.0.2, Window 7 64bit guest, Linux host, 3D openGL not working with any video driver in guest additions
#21243 - WIndows 10 screen black, Mac Ventura, VB 7.0.2
#21261 - Microsoft Office 2013 not working if Guest Additions are installed
#21274 - Incorrect font size use sticks after virtualbox window is moved to the second display

Last edited 34 hours ago by boxer01 (previous) (diff)

comment:44 by boxer01, 5 months ago

My troubles with "new" Notepad are still here in 7.0.15-161959.

comment:45 by boxer01, 4 months ago

My troubles with "new" Notepad are still here in 7.0.15-162549.

comment:46 by boxer01, 3 months ago

My troubles with "new" Notepad are still here in 7.0.17-162950 and 7.0.97-162957.

comment:47 by boxer01, 3 months ago

My troubles with "new" Notepad are still here in 7.0.17-162969.

comment:48 by boxer01, 3 weeks ago

My troubles with "new" Notepad are still here in 7.0.19-163608 and 7.0.97-163606.

comment:49 by boxer01, 3 weeks ago

Some new bugs from 7.0.18:

#22100 - Mouse stops working on FULL SCREEN mode
#22087 - Mouse stops working when going full screen
#22074 - [bug] (critical) the mouse cursor disappears
#22098 - Linux-6.9.4 vboxdrv breaks detection of screen resoltuion for some Intel graphic chips
#22096 - VMSVGA/VBoxSVGA: Accelerated cursor bugs
#22092 - abysmal vmwgfx performance with kernel > 6.7
#22091 - 16 inch 4k screen scaling issues/problems
#22086 - screen resolution defaults to 1280x960 if "Maximum Guest Screen Size" is set to auto
#22082 - Host cursor on top of guest cursor, when restored from saved state
#22075 - java fonts are shown garbled with 3d support

comment:50 by boxer01, 34 hours ago

My troubles with "new" Notepad are still here in 7.0.20-163906.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use