VirtualBox

Ticket #15802 (reopened defect)

Opened 2 years ago

Last modified 5 days ago

[Regression] No microphone, Windows Guest, Linux Host.

Reported by: dark_sylinc Owned by: pentagonik
Priority: minor Component: audio
Version: VirtualBox 5.1.2 Keywords: microphone,after 5.1
Cc: Guest type: Windows
Host type: Linux

Description

Linux Host

Ubuntu 16.04

Kernel 4.7.0-040700-generic

Guest: Windows 8.1 (also appears to affect any other guest)

Audio Controller: Intel HD Audio

Microphone is enumerated by the guest, but it is always silent. On occasions fiddling with microphone driver enumeration (i.e. toggling "Show unplugged recording devices" several times, going to its properties, etc) can even crash VirtualBox (rare, happened to me only twice).

PulseAudio shows VirtualBox has requested and received microphone and speaker. I've also tried the ALSA driver, same result. Couldn't try OSS driver (immediately aborts VM, didn't look much into it; I assumed either I had a missing dependency or the OSS device couldn't be grabbed)

I tried AC97 audio controller but Windows 8.1 won't install drivers for it.

Useful info:

  • Problem shows in official virtualbox-5.1_5.1.2-108956-Ubuntu-xenial_amd64 (using matching extension pack & Guest additions)
  • Problem persists in test build VirtualBox-5.1.3-110032-Linux_amd64.run (using matching extension pack & Guest additions)
  • It works correctly in virtualbox-5.1_5.1.0-108711-Ubuntu-xenial_amd64.deb

More info:

These users seem to be affected by the same problem:  https://forums.virtualbox.org/viewtopic.php?f=7&t=78797

Attachments

VBox.log.zip Download (27.1 KB) - added by dark_sylinc 2 years ago.
Logs.zip Download (137.8 KB) - added by Galvictor 2 years ago.
Logs.2.zip Download (58.3 KB) - added by Galvictor 2 years ago.
Arch Linux with Gnome
VBox.tar.gz Download (28.3 KB) - added by gromain 2 years ago.
5.1.2 start and stop, with Manjaro host and Win7 guest
Visicom Windows-2016-08-30-20-21-37.log.zip Download (27.0 KB) - added by Selmi 2 years ago.
VBox.log of test session with skype. incoming voice was with skips, recorded voice sounded like robot from old scifi movie
Win764_VBOX.log Download (139.2 KB) - added by ChrisMW 2 years ago.
Win764_026.log Download (105.8 KB) - added by ChrisMW 2 years ago.
Logs.tar.gz Download (49.8 KB) - added by e-cloud 2 years ago.
vbox-log-ubuntu-host-win10-guest
VBox.log.2.zip Download (56.0 KB) - added by rickan 4 months ago.
VBox_Win10_Guest_Ubuntu_18.04_Host.log.gz Download (34.8 KB) - added by simonc 3 weeks ago.
Ubuntu 18.04 Host, VBox 5.2.18 with Ext pack, Windows 10 guest with 5.2.18 guest additions

Change History

Changed 2 years ago by dark_sylinc

comment:1 Changed 2 years ago by matthewls

Same here, vb5.1.4, but mic worked in 5.0.26

comment:2 Changed 2 years ago by NachoGomez

Same issue here! In my case I have openSUSE 13.2 x64 as hosts and Windows 7 as guest (and many other guests, but I only need audio in Win7 for WebEx sessions)

Regards...

comment:3 Changed 2 years ago by ElOjcar

I also have the problem, with Ubuntu 14.04LTS. Microphone worked well with virtualbox 5.0.xxx, but not with 5.1.xxx

Last edited 2 years ago by ElOjcar (previous) (diff)

Changed 2 years ago by Galvictor

Changed 2 years ago by Galvictor

Arch Linux with Gnome

comment:4 Changed 2 years ago by Galvictor

I'm having the same issue after virtualbox update. I'm using Arch Linux and virtualbox guest utils and Windows 10 as Host. If I put Intel HD works, but the sound come oddly like an echo or a little delay (if you are watching an youtube video). In my case if I change back to AC97 works normal with a little delay. (Arch Linux LTS - KDE Plasma 5) Logs.zip

On my Arch Linux Gnome I'm having diferent situations... AC97 not working after reboot Logs.2.zip

comment:5 Changed 2 years ago by karolbe

Same problem with Ubuntu 16.04.1. Sadly, this issue forced me to downgrade to VB 5.0.26.

comment:6 Changed 2 years ago by gromain

I do have the same problem here, with Manjaro, testing branch (stable branch is not working either).

VirtualBox version is 5.1.2_OSE r108956.

Guest is Windows 7.

Audio worked with previous (5.0.x) version, but not anymore since 5.1.x.

I will attach my clean log with a complete start and shutdown sequence.

Changed 2 years ago by gromain

5.1.2 start and stop, with Manjaro host and Win7 guest

comment:7 Changed 2 years ago by Mone

I have same audio issue when I use Windows 10 host and run the Linux Guest (Ubuntu 16.04) on Virtualbox 5.0.26 and Virtualbox 5.1.2 (5.1.4).

I have test the the audio emulation settings, AC97 and IntelHD

  1. Audio input and output are both workable, but the guest OS crash (freeze, and one thing I can do is force interrupt by the window close button [X] ) sometimes when I use pyaudio to start record audio. Not every time but randomly happen.
  1. Audio output is workable but the audio input is not, when I test by Ubuntu audio setting, I can not see any sound pressure when I make noise.
Last edited 2 years ago by Mone (previous) (diff)

comment:8 Changed 2 years ago by muli

Hi All, As posted in -  https://forums.virtualbox.org/viewtopic.php?f=7&t=78797&p=369610#p369610

Still experiencing the loss of mic on virtual guest after upgrading to 5.1.4, updated expansion pack, guest pack,

Only workaround is to use a USB mic.

Any reply from VirtualBox support?

Muli

comment:9 Changed 2 years ago by gromain

I believe this bug should be classified at least as major as this is a major problem for users for whom it doesn't work.

comment:10 Changed 2 years ago by hash42

Adding another voice to push this as a major issue that needs resolution.

Host: Fedora 22 kernel 4.4.14-200.fc22.x86_64

Guest: Windows 7 (64 bit) The Guest OS does not detect any Audio Input Device!!

Picture worth a thousand words: https://s3.postimg.org/vxk9a9bur/screenshot007.png

comment:11 Changed 2 years ago by skfp

I'm using Fedora 24 host and Windows 8 guest. In 5.1.4 the mic won't pick up anything. Downgraded to 5.0.26 and the mic works again.

comment:12 Changed 2 years ago by Bob_Stones

And another. I'm using Adobe Captivate in a windows VM. In VB 5.0 the sound passed through to the application is pretty bad, lots of clicks are heard when sound volume is high. I'll upgrade to 5.1.4 to get rid of all this, I thought. Unfortunately the mic just doesn't work at all now.

Ubuntu 16.04 with all latest patches, VB 5.1.4 r110228

Last edited 2 years ago by Bob_Stones (previous) (diff)

comment:13 Changed 2 years ago by pentagonik

  • Owner set to pentagonik
  • Status changed from new to assigned

comment:14 Changed 2 years ago by pentagonik

Reproduced and fixed the issue. A new test build will be available shortly.

comment:15 Changed 2 years ago by pentagonik

I've uploaded a new test build which hopefully should fix the problem:

The files can be downloaded from the Testbuilds page.

Scroll down to the Latest test builds / 5.1.x builds section and download the build appropriate for your host platform.

This test build is not intended for production use!

Thank you!

comment:16 Changed 2 years ago by sleepwalk3r

Same issue since updating to VB 5.1.X
Host: Ubuntu 15.10 x64
Guest: Windows 10 Pro

Last edited 2 years ago by sleepwalk3r (previous) (diff)

comment:17 follow-up: ↓ 18 Changed 2 years ago by frank

sleepwalk3r, which build did you test (exact revision please)?

comment:18 in reply to: ↑ 17 Changed 2 years ago by sleepwalk3r

Replying to frank:

sleepwalk3r, which build did you test (exact revision please)?

Just the standard 5.1.0 and 5.1.2; then I went back to 5.0.26 which works fine

comment:19 Changed 2 years ago by frank

Ok, then you didn't test a test build from comment 15, your comment "Same issues since updating to VB 5.1.X" was a bit misleading.

comment:20 Changed 2 years ago by Selmi

with test build microphone works, but not well - without any change in settings or sound levels microphone volume bars in skype setings and gotomeeting sound check showed that I was speaking, but other side was not hearing me. when i touched volume settings in both host and guest it started to work, but my voice sounded like robot with lot of skips

btw sound is not good in general, lot of noise like old vinyl. in linux host everything is clean, from windows 10 guest it is always noisy regardless of volume levels set both in guest and host. but it was like this even in 5.x so it is not directly related to this issue

Last edited 2 years ago by Selmi (previous) (diff)

comment:21 Changed 2 years ago by pentagonik

Could you please supply the verbose VBox.log file as shown here: Investigating audio problems

Thank you!

Changed 2 years ago by Selmi

VBox.log of test session with skype. incoming voice was with skips, recorded voice sounded like robot from old scifi movie

Changed 2 years ago by ChrisMW

comment:22 Changed 2 years ago by ChrisMW

I have similar results. There's indication of sound, but barely. Can't make out words. Used a Skype for Business test call to test. Had Linux mic on full, Skype about 50%. Host is Mint LMDE 64 bit/16GB RAM and client is Win7 64bit with 6GB Ram. Same issue, 5.1.2/.4 no sound, 5.0 was capable of using Skype for Business.

comment:23 Changed 2 years ago by ChrisMW

I have gone back to 5.0.26 and replayed the exact same sequence. Sound from microphone was perfect. One thing I noticed however, is that the windows start-up tune seems a little longer in duration on 5.0.26 than on 5.1.4. On the latter, it seems almost cut-off, although subsequent sounds sound fine. It is just the start-up tune. This might be related, or due to improved speed of 5.1.4. I can't tell.

Changed 2 years ago by ChrisMW

comment:24 Changed 2 years ago by warcop

I was having a similar problem with PulseAudio/AC97 on Windows 10. I was able to solve the issue by updating to 5.1.5_110394. There seems to be a noticed delay >300ms.

comment:25 Changed 2 years ago by e-cloud

virtualbox: 5.1.5 r110394 (Qt5.6.1)
host: ubuntu 16.04
guest: windows 10 latest Enterprise
audio setting: Pulse audio and Intel HD

still unable to detect the microphone.

comment:26 follow-up: ↓ 29 Changed 2 years ago by nixuser

Tickets #15840 #15804 #15806 #15848 #15859 and probably even #15651 are almost certainly duplicates of this issue.

comment:27 Changed 2 years ago by pentagonik

@e-cloud Can you please have a look at comment 21 and provide a verbose VBox.log? Thank you!

comment:28 Changed 2 years ago by pentagonik

@nixuser Thanks for pointing out -- I'll have a look at those tickets.

Changed 2 years ago by e-cloud

vbox-log-ubuntu-host-win10-guest

comment:29 in reply to: ↑ 26 Changed 2 years ago by ChrisMW

Replying to nixuser:

Tickets #15840 #15804 #15806 #15848 #15859 and probably even #15651 are almost certainly duplicates of this issue.

15806 is something I have noticed also, but for me started with 5.1.2, the first 5.1 version I tried. The others report a change from 5.1.2 to 5.1.4 in audio out. In my case I have not experienced this at all. VB does sometimes crap up all audio, something I put down to the host process not doing the resume well, something I can remember all the way back to 4 series. So perhaps the same reason microphones almost never make it is the same why speakers sometimes sound really bad. Interesting......

comment:30 Changed 2 years ago by frank

The "no microphone" issue should be fixed in 5.1.6.

comment:31 Changed 2 years ago by Selmi

I confirm, microphone works in 5.1.6

comment:32 Changed 2 years ago by frank

  • Status changed from assigned to closed
  • Resolution set to fixed

Thanks! Then I will close this ticket. Please open separate tickets for separate issues.

comment:33 Changed 19 months ago by Raydude

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm using VirtualBox 5.1.16 in Gentoo Linux with a Windows 10 Guest and the microphone is present but not functioning within Skype.

It's a bummer because I have to reboot to attend meetings.

I have upped the linux microphone gains to full but the meter in Skype doesn't budge.

What information do you need to debug?

comment:34 Changed 11 months ago by pentagonik

Does this still happen with 5.1.30 and/or 5.2?

comment:35 Changed 8 months ago by sergwy

Still the issue in Virtualbox 5.2 on Kubuntu 17.10

comment:36 Changed 8 months ago by pentagonik

@sergwy: Please supply all data as shown here: Investigating audio problems

Thank you!

Changed 4 months ago by rickan

comment:37 Changed 4 months ago by rickan

VirtualBox 5.2.12 r122591 (Qt5.6.1) Host: Ubuntu Studio 16.04.4 LTS Guest: Windows 10

My apps which use the mic report there isn't one When I try to set one up the diagnostic thingy comes up and thinks for awhile and finds that the mic is detected (even that it's a headset mic) but not ready and that there are no other issues.

I tried two different setups in the VB GUI for Host Audio Driver: PulseAudio and ALSA. I have attached the audio debugging logs for both cases.

Audio output is working fine and I didn't test it while debugging so all the *.wav files have no content.

comment:38 Changed 4 months ago by Magnetron

Ticket #17597 duplicate of this issue.

Changed 3 weeks ago by simonc

Ubuntu 18.04 Host, VBox 5.2.18 with Ext pack, Windows 10 guest with 5.2.18 guest additions

comment:39 Changed 3 weeks ago by simonc

I also have this issue with an HP zbook g3 laptop.

Host is 18.04, onboard audio in/out works on this.

VBox 5.2.18

Guest virtual HW configured as Intel HDA & Pulse Audio driver.

Guest is Win10, audio out works ok (bit choppy at times on headphones). Main issue is that Win10 does not see a mic device presented.

Connecting a USB sound device from Sennheiser to the host & then passing that through to the guest results in sennheiser audio out & new mic device presented, both of which appear ok (not much testing done beyond testing in the device settings). Proves audio in/out presented to guest via USB devices is ok. For native host audio, it would seem that the driver passthrough doesn't present the mic device correctly as an Intel HDA, so windows doesn't try to load/use it.

Attached the logfile VBox_Win10_Guest_Ubuntu_18.04_Host.log.gz

I also tried (briefly) use of Alsa (laggy) & ICH9/Realtek [win10 couldn't identify the hw properly] so reverted back to default (recommended) Pulse/intel HDA.

comment:40 Changed 3 weeks ago by pentagonik

Please try the latest test build from the Testbuilds page.

Scroll down to the Latest test builds / 5.2.x builds section and download the build appropriate for your host platform.

Could you please supply the verbose VBox.log file as shown here: Investigating audio problems

Thank you!

comment:41 Changed 5 days ago by Exterminator13

Hosts:

  • Linux Mint 17/17.2 (Ubuntu 14.04 LTS)
  • Linux Mint 19 (Ubuntu 18.04 LTS).

Guest OS: Windows XP SP3

VirtualBox version: 5.1.x (the latest one in the branch, 5.1.38, didn't work as well)

The problem: audio playback works great, but microphone doesn't! Moreover, USB is not recognized too!

The solution in my case was simple: you have to add the current user to vboxusers:

sudo adduser $USER vboxusers

After this action, USB devices began to be recognized as nothing happened before. And, of course, microphone also began to work!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use