VirtualBox

Ticket #15806 (closed defect: obsolete)

Opened 2 years ago

Last modified 11 months ago

Sound problems

Reported by: bmn Owned by:
Component: audio Version: VirtualBox 5.1.4
Keywords: audio sound Cc:
Guest type: Windows Host type: Windows

Description

Host Windows 7 x64 SP1 with all others update.
Guest Windows 7 x64 SP1.

Problems:
The system sounds are truncated just before they finish.
Also, if you test the speakers (Control Panel - sound; double click on Speakers, select tab Advanced, click on Test) the resulting sound is very bad: is croaky.
The problem do not appear on VirtualBox 5.1.2

Attachments

VBox.log Download (142.8 KB) - added by bmn 2 years ago.
Visicom Windows-2016-08-30-20-21-37.log.zip Download (27.0 KB) - added by Selmi 2 years ago.
VBox.log from tes build of 5.1.5 of test session with skype. incoming voice was with skips. host ubuntu 16.04, guest windows 10

Change History

Changed 2 years ago by bmn

comment:1 Changed 2 years ago by kynzie

Here more details about this matter regarding Virtualbox versions and the concerned platforms:

    HOST    - VBox version - Sound status
 Mac 10.11  -     5.1.4    - broken
 Mac 10.11  -     5.1.2    - broken
 Mac 10.11  -     5.0.26   - ok
 Windows 10 -     5.1.4    - broken
 Windows 10 -     5.1.2    - ok
Ubuntu 16.4 -     5.1.4    - broken
Ubuntu 16.4 -     5.1.2    - ok

The audio controller used on all platforms is ICH AC97. The sound is croaky and randomly no sound at all. We just tested the speakers, not the microphone.

comment:2 Changed 2 years ago by Selmi

same problem also with test build of 5.1.5 mentioned in #15802

comment:3 Changed 2 years ago by nixuser

I have the same problem with a 64-bit Win 8.1 host and Linux Fedora 24 guest.

comment:4 Changed 2 years ago by pentagonik

Could you please supply the verbose log files as shown here: Investigating audio problems

Thank you!

Changed 2 years ago by Selmi

VBox.log from tes build of 5.1.5 of test session with skype. incoming voice was with skips. host ubuntu 16.04, guest windows 10

comment:5 Changed 2 years ago by nixuser

This is still an issue in 5.1.6 release version. I have no sound at all with a fedora 24 guest on Win 8.1 host.

I've gone back to 5.0.26 which fixes the problems, but I sacrifice USB 3 support due to the Linux kernel bug which 5.1.4 worked around.

Please see #15840 and #15804 also (I believe all are the same or related).

Last edited 2 years ago by nixuser (previous) (diff)

comment:6 Changed 2 years ago by spinjector

I can confirm this happening with my setup as well, but the circumstances are a bit unique. Although I'm running Windows 7 x64 on the host, the client(s) are Windows 2000 Server. =-)

The symptoms are the same as others have described above: any sound played in Windows, regardless of the player software, gets truncated by a fraction of a second. Also, I can confirm it's not just WAV files, but MP3 files as well, so it doesn't seem isolated to a particular filetype either.

Version info is below. Plz let me know if there's any other info I can provide. Vbox: 5.1.6 r110634 (Qt5.5.1) Win2k: 5.00.2195

comment:7 Changed 11 months ago by pentagonik

  • Status changed from new to closed
  • Resolution set to obsolete

Please have a try with the latest 5.2 test build 120822, which is located here: https://www.virtualbox.org/wiki/Testbuilds. Thank you!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use