VirtualBox

Ticket #15859 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

There is NO sound after update to VirtualBox 5.1.4 from 5.1.2

Reported by: macachuto Owned by:
Component: audio Version: VirtualBox 5.1.4
Keywords: Cc:
Guest type: Linux Host type: Linux

Description

There is NO sound after update to VirtualBox 5.1.4 in Linux giests

Host: Linux Ubuntu 14.04 Host Sound settings: Alsa Audio Driver + ICH AS97

3 guests: windows xp, ubuntu 12.04 and ubuntu 16.04 Sound works only in windows

Revert to VirtualBox 5.1.2, got sound back.

Attachments

Xubuntu_16.04-2016-09-14-15-40-07.tgz Download (25.1 KB) - added by macachuto 3 years ago.
Xubuntu_16.04-2016-09-14-15-40-07.lo

Change History

comment:1 Changed 3 years ago by frank

Any VBox.log file?

comment:3 Changed 3 years ago by macachuto

There is VBox.log.7z on the forum page.

comment:4 Changed 3 years ago by cassou

comment:5 follow-up: ↓ 10 Changed 3 years ago by frank

Still relevant with VBox 5.1.6?

comment:6 follow-up: ↓ 7 Changed 3 years ago by Kevin565

Still I have this problem on VirtualBox 5.1.6. And I found a workaround.

WORKAROUND:

  1. Shutdown guest OS (Ubuntu)
  2. Settings -> Audio

Change 'Audio: ICH AC97' to 'Audio: Intel HD Audio'

  1. Boot guest OS (Ubuntu)

works fine to me.

comment:7 in reply to: ↑ 6 ; follow-up: ↓ 8 Changed 3 years ago by macachuto

Replying to Kevin565: Can you please tell what is your host system and guest one?

When I was trying to do like this in 5.1.4, I also got sound, but it came out with 2 seconds delay. And this did not work for Ubuntu 12, only for Ubuntu 16. My host is Ubuntu 14.

Still I have this problem on VirtualBox 5.1.6. And I found a workaround.

WORKAROUND:

  1. Shutdown guest OS (Ubuntu)
  2. Settings -> Audio

Change 'Audio: ICH AC97' to 'Audio: Intel HD Audio'

  1. Boot guest OS (Ubuntu)

works fine to me.

comment:8 in reply to: ↑ 7 Changed 3 years ago by Kevin565

Replying to macachuto:

Replying to Kevin565: Can you please tell what is your host system and guest one?

When I was trying to do like this in 5.1.4, I also got sound, but it came out with 2 seconds delay. And this did not work for Ubuntu 12, only for Ubuntu 16. My host is Ubuntu 14.

Still I have this problem on VirtualBox 5.1.6. And I found a workaround.

WORKAROUND:

  1. Shutdown guest OS (Ubuntu)
  2. Settings -> Audio

Change 'Audio: ICH AC97' to 'Audio: Intel HD Audio'

  1. Boot guest OS (Ubuntu)

works fine to me.

My Environments:

  • Host OS: Windows 10 64bit version 1607, Sound Device: Realtek High Definition Audio
  • Guest OS: Ubuntu 16.04

$ uname -a Linux ubuntu-VirtualBox 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux $

comment:9 Changed 3 years ago by cassou

Sorry for the confusion, my previous comment was related to host audio, not guest audio.

comment:10 in reply to: ↑ 5 Changed 3 years ago by macachuto

Replying to frank: Yes, exactly the same. I have attached my log.

Sorry, when I tried to attach file got follow:

This site can’t be reached

The webpage at https://www.virtualbox.org/attachment/ticket/15859/?action=new&attachfilebutton=Attach+file might be temporarily down or it may have moved permanently to a new web address. ERR_ACCESS_DENIED

Still relevant with VBox 5.1.6?

comment:11 Changed 3 years ago by vensasa

I can confirm this. After upgrading from 5.1.2 to 5.1.6 audio stopped working with AC97. We also get error messages about a "unreliable DMA address" if that means anything. Basically, audio will stop working when any long playing audio file is played. Mplayer gives messages about the audio device freezing up.

It does happen on 5.1.6.

Last edited 3 years ago by vensasa (previous) (diff)

Changed 3 years ago by macachuto

Xubuntu_16.04-2016-09-14-15-40-07.lo

comment:12 Changed 3 years ago by nixuser

I believe this is a duplicate of #15806.

comment:13 Changed 3 years ago by macachuto

Hello

The same issue with VirtualBox 5.1.6 and VirtualBox 5.1.8 Different hosts and different guests

Some details:  https://forums.virtualbox.org/viewtopic.php?f=7&t=79438

comment:14 Changed 3 years ago by Gene77072

I have the same issue with VB 5.1.8 running off a Ubuntu 16.04.1 LTS Host and have confirmed that backing off to VB 5.1.2 does restore missing Sound Support. I run all Daily Images of Ubuntu 17.04 and also experience this issue with Fedora Workstation 24.1.2 and OpenSuse 42.2.

comment:15 Changed 3 years ago by Kevin565

I confirmed the sound works fine on VirtualBox 5.1.10 today. Thank you very much, developer team. I bet this report will be closed.

VirtualBox: 5.1.10 Host OS: Windows 10 64bit 14393 Guest OS: Ubuntu 16.04 64bit Guest Sound: ICH AC97

comment:16 Changed 3 years ago by michael

The original report was about a Linux host with ALSA audio. We should wait for confirmation that that is fixed, preferably from the original reporter, before closing the ticket. There was a major rework of the audio subsystem in 5.1 which resulted in a number of similar looking problems.

Kevin565, glad your problem is fixed though.

comment:17 Changed 3 years ago by shillshocked

Virtualbox sound seems to crash or go off, it just stops working, have to reboot host computer to get it to work again. Arch Linux host, Windows guest. Didn't have this problem until a recent update. Currently on 5.1.10

Last edited 3 years ago by shillshocked (previous) (diff)

comment:18 Changed 3 years ago by robertsonic

With 5.1.10, I had the opposite problem: Intel HD Audio doesn't work, but AC97 does.

comment:19 Changed 3 years ago by shillshocked

I seem to have made progress by removing PulseAudio on host and just using ALSA. Will post again if problem continues.

Last edited 3 years ago by shillshocked (previous) (diff)

comment:20 Changed 2 years ago by pentagonik

Does this now work for you using latest 5.1.24?

comment:21 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please re-open if not ...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use