VirtualBox

Ticket #6251 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Unable to connect to USB device => Fixed in SVN/3.1.6

Reported by: cmeadows Owned by:
Priority: major Component: USB
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

After upgrading to 3.1.4 I'm unable to connect to a SANSA FUSE through the USB connection. Downgrading back to 3.1.2 resolved the issue. Guest OS is Ubuntu 9.10. Host is OSX 10.5.7

Attachments

VBox.log Download (55.6 KB) - added by rbalada 4 years ago.
VBox.log
Windows 7.xml Download (7.9 KB) - added by rbalada 4 years ago.
Virtual machine's config xml
USB Device list.png Download (39.0 KB) - added by rbalada 4 years ago.
Screenshot - USB devices list
Detected new network interfaces.png Download (27.4 KB) - added by rbalada 4 years ago.
Screenshot - detected new network interfaces
Unable o attach Nokia 5800.png Download (49.4 KB) - added by rbalada 4 years ago.
Screenshot - unable to attache Nokia 5800
Unable to attach Gemplus USB Smartcard reader.png Download (43.9 KB) - added by rbalada 4 years ago.
Screenshot - unable to attach Gemplus smartcard reader

Change History

comment:1 Changed 4 years ago by rbalada

I'm seeing similar issue with Mac OS X 10.6.2 (Snow Leopard) host OS running Win 7 Pro 32-bit Guest OS. I was trying to attach Nokia 5800 and GemPlus smartcard reader to Win 7 guest and VirtualBox could not attach those devices. It also used to work under VirtualBox 3.1.2 and stopped working after an upgrade to 3.1.4. Downgrade to VirtualBox 3.1.2 resolved the issue.

It's just regular bug life cycle - release being marketed as a solution for a few regressions while (quietly) bringing some new. It looks like you can either sync an iPod under VirtualBox 3.1.4 or work with anything else under VirtualBox 3.1.2.

comment:2 Changed 4 years ago by ramshankar

Could you please provide information regarding how you're "attaching" the USB device (filters or hijacking manually?), what the VM config is (VBox.log), what error you get when you say "could not attach those devices".

Changed 4 years ago by rbalada

VBox.log

Changed 4 years ago by rbalada

Virtual machine's config xml

Changed 4 years ago by rbalada

Screenshot - USB devices list

Changed 4 years ago by rbalada

Screenshot - detected new network interfaces

Changed 4 years ago by rbalada

Screenshot - unable to attache Nokia 5800

Changed 4 years ago by rbalada

Screenshot - unable to attach Gemplus smartcard reader

comment:3 in reply to: ↑ description Changed 4 years ago by harold.d.mcbane@…

Replying to cmeadows:

After upgrading to 3.1.4 I'm unable to connect to a SANSA FUSE through the USB connection. Downgrading back to 3.1.2 resolved the issue. Guest OS is Ubuntu 9.10. Host is OSX 10.5.7

I have a similar problem with Mac OS X 10.6.2 as the host OS; either WinXPProSP3 32-bit , Win7 32-bit, or Debian5 64-bit as guest OSs and an SCM SCR 3310 USB Smart Card Reader.

Under 3.1.2, I was able to use the device with the three guest OSs mentioned above using the following procedure:

1. Connect the device to the host system.
2. Start VirtualBox, but not the VM.
3. Add a USB filter for the device to the VM (required only once).
4. Disconnect the device from the host system.
5. Start the VM.
6. Connect the device to the host system once the VM is running.

This procedure no longer works under 3.1.4. I have been unable to use the device on any guest OS under 3.1.4. I also downgraded to 3.1.2.

comment:4 follow-up: ↓ 5 Changed 4 years ago by rbalada

Attached the VBox.log logfile, virtual machine's configuration xml file and a few screenshots for detailed idea of the messages.

My environment: Host OS: Mac OS X 10.6.2 (Snow Leopard), latest patches applied Guest OS: Windows 7 Ultimate 32bit, latest patches applied Guest extensions seem to be 3.0.6 (see vbox.log or xml config for details)

The virtual machine is configured to use filters (see xml config for details).

Steps to reproduce: #1 Start VirtualBox.app #2 Start the Windows 7 virtual machine #3 Login to Windows, wait for desktop to come up #4 physically plug in an USB device into Host HW USB port #5a In case it is the Nokia phone, a dialog about new network interface comes up #5b In case it's the Gemplus USB smartcard reader, nothing explicitly visual happens #6 either or both of those devices appear in USB devices list, enabled, but not check-marked (see screenshot) #7 click on either Nokia or Gemplus in the USB devices list menu and then Host OS native dialog appears saying that VirtualBox is not able to attach the USB device

I'm not able to reproduce this with VirtualBox 3.1.2, so this is a regression (pretty serious I would say).

I've checked out source code from public repo, but it does not build for me yet, so at this very moment I'm not able to determine the root cause.

comment:5 in reply to: ↑ 4 Changed 4 years ago by rbalada

Replying to rbalada:

The virtual machine is configured to use filters (see xml config for details).

[snip]

#5a In case it is the Nokia phone, a dialog about new network interface comes up

[Commenting myself] From my point of view it looks like USB filters do not work (properly). The Mac OS X network interfaces dialog seems to support that, because the Nokia 5800 gets recognized by Host OS inplace of the Guest OS.

comment:6 Changed 4 years ago by ramshankar

This is a regression but it hasn't broken USB completely, you can still capture devices manually. Thanks for the report and it's been fixed and will part of the next release.

comment:7 Changed 4 years ago by frank

  • Summary changed from Unable to connect to USB device to Unable to connect to USB device => Fixed in SVN/3.1.6

comment:8 Changed 4 years ago by pbw

I've got this problem with 3.1.4.r57640, when connecting phones to PC software.

How does "capture device manually" work? I can't find a reference to it in the User Manual. Where can I read about it?

comment:9 Changed 4 years ago by ramshankar

Capturing manual is choosing it from the devices menu after plugging in the device. Filtered capture on the other hand is setting up a filter on the host and -then- plugging in the device. It's probably not documented because ideally it should just be a developer level implementation detail.

comment:10 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use