VirtualBox

Ticket #6 (reopened defect)

Opened 7 years ago

Last modified 4 years ago

autocad 2004 install ok but failed to launch

Reported by: victor Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.4 Keywords: autocad 2004
Cc: Guest type: other
Host type: other

Description

I also found qemu has the same problem.

There is no error message, no complain.

I've tested it under windows 2k & xp.

Change History

comment:1 Changed 7 years ago by frank

Doesn't need Autocad a dongle?

comment:2 Changed 7 years ago by Technologov

What OS you run as Host and Guest ? What version of AutoCAD ? What about VMware Workstation and VirtualPC ?

comment:3 Changed 7 years ago by umoeller

  • Priority changed from critical to major

Please reserve the "critical" priority for things that cause severe trouble on your system, or crash VirtualBox altogether.

comment:4 Changed 7 years ago by victor

host os: ubuntu edgy autocad version: 2004 simple chinese

It runs ok on vmware workstation.

comment:5 Changed 7 years ago by eon

Same issue with VB 1.4.0

Autocad 2004 does'nt launch. Works well on VMWARE workstation.

comment:6 Changed 7 years ago by isaac

I confirm this failure in a debian/lenny - VB 1.4.0

Install goes well and smooth. After it ends, launching the AutoCAD fails.

Could someone confirm that it works on VMware? What version of AutoCAD? What VMware version? Player? Server? Workstation?

comment:7 Changed 7 years ago by sandervl73

Please retry with 1.5.0

comment:8 Changed 7 years ago by isaac

You mean by "retry" 1.- reinstalling operating system and autocad? or 2.- just trying with the virtual machine already created?

I can report: 1.- too much work-time, not tried. 2.- same issue with VB 1.5.0

comment:9 Changed 6 years ago by vtester

I can confirm autocad 2004 fail to start on ver 1.50, 1.52, 1.54. Installation of Guestsadditions does not help. I have tried Windows XP & 2000, Intel & AMD, all with 2 G RAM and allocate 1 G for XP guest, all tries have the same symptom. I also tried to install XP and just Autocad 2004, it's still no good. I tried the same on VMware workstation, Autocad 2004 starts smoothly and works well. To troubleshoot the problem in Vbox 1.54, I started autocad 2004 and watched the process in XP task Manager, the process acad.exe showed up in a fraction of second and disappeared. I renamed the acad.exe to bcad.exe and start it again, the autocad will give you an error "The autocad program name changed from acad.exe to bcad.exe. Some commands and add-on customizations may not load correctly, continue anyway?". As soon as you hit Yes, the process will die.

Regardless whether you start the program using the name acad.exe or bcad.exe in XP, Autocad 2004 created a log file under "\Documents and Settings\user\Local Settings\Temp\~name123.tmp" I looked at the file using a text editor and copy part of the ASCII text. There were binary character that I did not copy.

TLOSS error

SING error

DOMAIN error

R6028

  • unable to initialize heap

R6027

  • not enough space for lowio initialization

R6026

  • not enough space for stdio initialization

R6025

  • pure virtual function call

R6024

  • not enough space for _onexit/atexit table

R6019

  • unable to open console device

R6018

  • unexpected heap error

R6017

  • unexpected multithread lock error

R6016

  • not enough space for thread data

abnormal program termination

R6009

  • not enough space for environment R6008
  • not enough space for arguments

R6002

  • floating point not loaded

Microsoft Visual C++ Runtime Library

Runtime Error!

I hoped this can help to resolve the issue quickly.

comment:10 Changed 6 years ago by sandervl73

Any improvement with 1.6.0? Try using VT-x/AMD-V if your CPU supports them. (wait for 1.6.2 to try that)

comment:11 Changed 6 years ago by sandervl73

  • Version changed from VirtualBox 1.3.2 to VirtualBox 1.5.4

comment:12 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

comment:13 Changed 6 years ago by funihao

  • Status changed from closed to reopened
  • Resolution fixed deleted

Tested in Ubuntu host gusty and hardy, VirtualBox 2.0.2. I can confirm autocad 2004 fail to start over Windows XP. Guestsadditions installed. AutoCAD 2002 run fine without problems. Something about this?

comment:14 Changed 5 years ago by Yeti_69

Sorry but my english is bad (I'm french) I manage to launch Autocad 2004 installed on windows XP in virtualbox 2.1.4 (My computer works with Ubuntu). I have enabled the 3D acceleration, and VT-x/AMD-V (without Nested Paging). Only with this options enable, I can launch Autocad (but slowly). I can create a drawing, backup it. But it is slow when I want to open a little or big drawing .dwg When Autocad is launching, the computer seems to be in "16 colors", but the work on Autocad is now possible for me with virtualbox! Thanks very much to BlanchardJ

comment:15 Changed 4 years ago by russell.eberhardt

This problem has come back again. Running PCLinuxOS host, XP pro guest on virtualbox 3.2.8 with guest additions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use