VirtualBox

Ticket #2 (closed defect: fixed)

Opened 7 years ago

Last modified 3 years ago

Keyboard layout is messed up in Turkish layout

Reported by: cartman Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.2 Keywords:
Cc: Guest type: other
Host type: other

Description

I installed a Linux guest on a Linux host and guest's X.org is set to use trq keyboard layout but all the keys are mixed up. As if like some another keymap is in effect.

Attachments

trq Download (3.2 KB) - added by cartman 7 years ago.
trq keymap file
diff.txt Download (1005 bytes) - added by Aldo Nogueira 7 years ago.
keyboard.c diff
betterdiff.txt Download (1.8 KB) - added by Aldo Nogueira 7 years ago.
A better keyboard.c diff

Change History

Changed 7 years ago by cartman

  • attachment trq Download added

trq keymap file

comment:1 Changed 7 years ago by achimha

Our Qt GUI uses keyboard translation (X to scancode) borrowed from WINE. Maybe syncing this file with a more recent version of Wine (ours is several years old) will address the problem.

In general, it is problem to get the scancode of keys in X. We have not found a better way so far.

comment:2 Changed 7 years ago by cartman

I got latest wine at hand if you tell me what file to sync I can test & report back.

comment:3 Changed 7 years ago by cartman

Looking at src/VBox/Frontends/VirtualBox/src/linux/keyboard.c Turkish keyboard layout correctly matches Turkish Q layout.

comment:4 Changed 7 years ago by Olav

Same problems occur when using the "US International" keyboard layout (with the dead keys) on the host. In my case, this is happening in Ubuntu 6.10 under Gnome 2.16.1. For example, if I type a straight apostroph (') the guest will always receive a backtick (`). Double quotes (") become a tilde (~) et cetera.

comment:5 Changed 7 years ago by Aldo Nogueira

A similar problem occurs with ABNT2 (brazilian) keyboards in a Ubuntu Edgy host. No matter what keyboard layout I choose on guest (a Debian Etch, in my case), the problem is the same. All keys from the last row of the keyboard, i.e., "\zxcvbnm,.;/" are shifted by one. If I press 'v', I get a 'c', for example. I downloaded the sources today from the subversion repository.

Changed 7 years ago by Aldo Nogueira

keyboard.c diff

comment:6 Changed 7 years ago by Aldo Nogueira

There are two ABNT2 keyboards on keyboard.c file. My keyboard have ALTGR key, so I copied the array from main_key_PT_br_alt_gr to main_key_PT_br and it is behaving better, I think. At least when on type a 'v' gets a 'v' now. There are some other keys that are still messed up.

Changed 7 years ago by Aldo Nogueira

A better keyboard.c diff

comment:7 Changed 7 years ago by Aldo Nogueira

Me again. This time, I reverted the keyboard.c file and copied all ABNT parts from wine-0.9.30/dlls/winex11.drv/keyboard.c. Its better. Only two keys don't work: '\' and '/'.

comment:8 Changed 7 years ago by michael

[Note: the repository will be synchronised some time on Monday, so please wait until then to try this out].

Could those experiencing this bug, and who feel happy compiling VirtualBox themselves, test the current SVN version? You will need to create a file called LocalConfig.kmk and add the line

XKEYBOARD := 1

to it to activate the fix.

comment:9 Changed 7 years ago by michael

Forgot to say - you need to create LocalConfig.kmk in the VirtualBox source base directory (where Config.kmk is). As I said, try it on Monday!

comment:10 Changed 7 years ago by cartman

This works fine for me, thanks!

comment:11 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This is the default setting now.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use