VirtualBox

Ticket #6095 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Windows 7 Ultimate(x64) crash (PGMDynMapHCPage: set is full!) -> fixed in SVN/3.1.6

Reported by: Decept1k0n Owned by:
Priority: critical Component: other
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I'm not sure what happened but when logging on to my company's VPN and doing some work and sending email using Microsoft Outlook, the system crashed after I sent my email message.

The version of Microsoft Outlook I am using is 2007, and I'm using the Cisco VPN AnyConnect VPN client(not sure of the version but I can get this if needed).

Attachments

VBox.png Download (196.1 KB) - added by Decept1k0n 4 years ago.
VirtualBox Image
VBox.2.log Download (231.6 KB) - added by hafthor 4 years ago.
PGMDynMapHCPage: set is full! Host:Mac OSX Guest:Win7 x86
VBox.3.log Download (41.0 KB) - added by jfzed 4 years ago.
VBox.4.log Download (41.2 KB) - added by jfzed 4 years ago.
3.1.5 Aborts shortly after booting W7-64-bit 1 or 2 x CPUs
VBox.log Download (41.7 KB) - added by Decept1k0n 4 years ago.
VirtualBox Log file

Change History

Changed 4 years ago by Decept1k0n

VirtualBox Image

comment:1 Changed 4 years ago by frank

  • Summary changed from Windows 7 Ultimate(x64) crash to Windows 7 Ultimate(x64) crash (PGMDynMapHCPage: set is full!)

comment:2 Changed 4 years ago by sandervl73

#6214 marked as a duplicate of this one

comment:3 Changed 4 years ago by sandervl73

#6283 marked as a duplicate of this one

comment:4 Changed 4 years ago by hafthor

My issue like this seemed to be related to power management. Turned off all power saving stuff and haven't crashed since.

comment:5 Changed 4 years ago by Decept1k0n

I'll go ahead and try changing the power management settings to off as well and see if that fixes this Guru Mediation issue. I'll provide an update on what happens.

comment:6 Changed 4 years ago by Decept1k0n

I tried this a while ago and still got the Guru Meditation error. Attached is my most up to date log file after making the changes to power management.

Changed 4 years ago by hafthor

PGMDynMapHCPage: set is full! Host:Mac OSX Guest:Win7 x86

comment:7 Changed 4 years ago by sandervl73

  • Priority changed from major to critical

#6355 marked as a duplicate.

comment:8 follow-up: ↓ 9 Changed 4 years ago by sandervl73

  • Version changed from VirtualBox 3.1.2 to VirtualBox 3.1.4

comment:9 in reply to: ↑ 8 Changed 4 years ago by jfzed

Replying to sandervl73: 6355 has been closed and marked as duplicate of this ticket, 6095.

6355 points directly at a problem with 2 x CPUs for a W7 64-bit guest, under Mac OS 10.6.2 host, problem that is corrected once the guest is configured with 1 x CPU.

Operating with 1 x CPU works fine under all sorts of workloads: Java, Eclipse, Chrome Browser, Firefox, VPN connections, etc. Once 2 x CPUs are configured it crashes within few hours of operation, critical error screen,

Hope this information helps isolate and correct problem that under 6355 it is attributed to a 2 x CPUs configuration.

comment:10 Changed 4 years ago by sandervl73

  • Summary changed from Windows 7 Ultimate(x64) crash (PGMDynMapHCPage: set is full!) to Windows 7 Ultimate(x64) crash (PGMDynMapHCPage: set is full!) -> fixed in SVN/3.1.6

A fix will be included in the upcoming 3.1.6.

comment:11 follow-up: ↓ 12 Changed 4 years ago by aeichner

For anyone who wants to try it out, the following link contains a testbuild with the fix included:

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-18-11-26-59-mac2-3.1-3.1.5-r58961.dmg

Feedback welcome, thanks!

comment:12 in reply to: ↑ 11 Changed 4 years ago by jfzed

Replying to aeichner:

For anyone who wants to try it out, the following link contains a testbuild with the fix included:

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-18-11-26-59-mac2-3.1-3.1.5-r58961.dmg

Feedback welcome, thanks!

Tried r58961; it crashes shortly after boot; log-file is uploaded;

Changed 4 years ago by jfzed

comment:13 Changed 4 years ago by frank

jfzed, thanks for testing. The problem you see now is not related to the original problem. Can you start other guests with the test build to check if they abort as well?

comment:14 follow-ups: ↓ 15 ↓ 17 Changed 4 years ago by frank

There is another test build at

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-23-19-12-09-ac2-3.1-3.1.5-r59220.dmg

Could you install this build and test the Windows 7 guest and (is possible) other guests as well?

comment:15 in reply to: ↑ 14 ; follow-up: ↓ 16 Changed 4 years ago by Decept1k0n

Replying to frank:

There is another test build at

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-23-19-12-09-ac2-3.1-3.1.5-r59220.dmg

Could you install this build and test the Windows 7 guest and (is possible) other guests as well?

I've attempted to download this build myself so I can test it as well, but the link seems to be invalid? Can you check it out?

comment:16 in reply to: ↑ 15 Changed 4 years ago by jfzed

Replying to Decept1k0n:

Replying to frank:

There is another test build at

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-23-19-12-09-ac2-3.1-3.1.5-r59220.dmg

Could you install this build and test the Windows 7 guest and (is possible) other guests as well?

I've attempted to download this build myself so I can test it as well, but the link seems to be invalid? Can you check it out?

I've tried also, the link is mangled, incorrect; I'll be pleased o test again should you post a corrected link; thanks;

comment:17 in reply to: ↑ 14 ; follow-up: ↓ 18 Changed 4 years ago by jfzed

Replying to frank:

There is another test build at

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-23-19-12-09-ac2-3.1-3.1.5-r59220.dmg

Could you install this build and test the Windows 7 guest and (is possible) other guests as well?

The problem is not exclusive of W7-64-bit; same problem occurs with Ubuntu-64-bit + 2 x CPUs; reconfigured it with 1 x CPU and all works well; I hope this fact helps in identifying and resolving the problem; thanks;

comment:18 in reply to: ↑ 17 Changed 4 years ago by jfzed

Replying to jfzed:

Replying to frank:

There is another test build at

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-23-19-12-09-ac2-3.1-3.1.5-r59220.dmg

Could you install this build and test the Windows 7 guest and (is possible) other guests as well?

The problem is not exclusive of W7-64-bit; same problem occurs with Ubuntu-64-bit + 2 x CPUs; reconfigured it with 1 x CPU and all works well; I hope this fact helps in identifying and resolving the problem; thanks;

The link is now available; I d/loaded the 3.1.5 r58961, it Aborts shortly after boot, 1 or 2 x CPUs, log-file will be uploaded.

Changed 4 years ago by jfzed

3.1.5 Aborts shortly after booting W7-64-bit 1 or 2 x CPUs

comment:19 Changed 4 years ago by frank

Big sorry, the previous link had a typo. jfzed, you tested the old link. Could you guys try again with this build? Sorry for any inconveniences!

 http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-23-19-12-09-mac2-3.1-3.1.5-r59220.dmg

comment:20 Changed 4 years ago by Decept1k0n

After trying out the build that was suggested, I too experienced the same issue as jfzed... My Windows 7 aborted, almost immediately after launching it. I'll go ahead and post my log file as well.

Changed 4 years ago by Decept1k0n

VirtualBox Log file

comment:21 Changed 4 years ago by sandervl73

The 'new' guru (actually unrelated to the original problem, but referenced in #6125) is now also gone.

comment:22 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use