VirtualBox

Ticket #5832 (closed defect: obsolete)

Opened 4 years ago

Last modified 3 months ago

Mouse Integration fails to capture pointer in 3.1.2 -> fixed in SVN/3.1.4

Reported by: brendanl79 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.2 Keywords: mouse pointer integration capture 3.1.2
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

VirtualBox 3.1.2, host is Vista SP2, guest is Debian 5.03.

Guest Additions worked fine under VB3.1.0. After upgrading host VB to 3.1.2, then upgrading Guest Additions to 3.1.2 on the Debian guest, the mouse pointer is effectively stuck. The image of the pointer moves around the screen as expected in response to my mouse movements, but if I press a mouse button the click location is always at the lower right hand corner of the screen (on my LXDE desktop it's the location of the shutdown button).

I need shared folders so I can't disable Guest Additions as a workaround.

Attachments

vbox-badmouse-2009-12-23-21-22-16.log Download (57.1 KB) - added by brendanl79 4 years ago.
VBox.log for Debian 5.03 32-bit guest on Vista SP2 host, VB3.1.2, GA installed, mouse misbehaving
Debian-5.03-2009-12-27-11-19-39.log Download (61.9 KB) - added by Perryg 4 years ago.
Log of Debian-503 with GA 3.1.2
Debian-5.03-2009-12-27-12-02-50.log Download (62.1 KB) - added by Perryg 4 years ago.
Log of Debian-503 with GA 3.1.0

Change History

Changed 4 years ago by brendanl79

VBox.log for Debian 5.03 32-bit guest on Vista SP2 host, VB3.1.2, GA installed, mouse misbehaving

comment:1 Changed 4 years ago by brendanl79

This might be the same phenomenon reported by a MacOS host / Debian-Lenny guest in #5791.

Changed 4 years ago by Perryg

Log of Debian-503 with GA 3.1.2

Changed 4 years ago by Perryg

Log of Debian-503 with GA 3.1.0

comment:2 follow-up: ↓ 3 Changed 4 years ago by Perryg

I can confirm this on 64 bit Debian 503. I have worked around the problem by re-installing version 3.1.0 GAs. I am attaching (2) log files one with the 3.1.0 GA and one with the 3.1.2 GA. It looks to me like the new mouse drivers are what is not making Debian happy. The mouse pointer is stuck in the lower right corner and can not be moved. I saw a minor movement from left to right but upward movement is zero. I use the Gnome desktop, no 3D (not available in the Debian 503) if this helps.

I also tried to regress the xorg.conf file to the point just before the update and that had no effect

Let me know if you require any further file.

comment:3 in reply to: ↑ 2 Changed 4 years ago by brendanl79

Replying to Perryg:

I can confirm this on 64 bit Debian 503. I have worked around the problem by re-installing version 3.1.0 GAs.

Just confirmed I was able to do the same thing.

It would be nice if the Guest Additions ISO's were made available as separate downloads. I had to reinstall 3.1.0, copy and rename the ISO, then reinstall 3.1.2. But in any case I can hold on now until the fix arrives. Thanks Perryg!

comment:4 Changed 4 years ago by Perryg

Sorry. I should have provided the link to the guest additions ISO

 http://download.virtualbox.org/virtualbox/3.1.0/

comment:5 Changed 4 years ago by elfueda

I have had the same problem and had been struggling for a couple of days. I am using a Windows Vista 32bit host and Debian Lenny 5.0 Guest. This was my last problem and it was fixed installing Guest Addition 3.1.0.

As a matter of documentation, the GA will not install if the 'linux-headers' for the appropriate kernel being used.

My installation didn't run either, so I just copied all the contents of the CD to a local directory and it ran fine from there.

Not a bad idea to have uninstalls. I scripted mine out, since even after deleting the unnecessary ose stuff a few files are left. dpkg --purge <ose install> was also needed for a clean uninstall.

#! /usr/bin/tcsh

set rel = `uname -r`

sudo find /etc -name \*vboxadd\* -exec rm {} \;
sudo find /etc -name \*vboxvfs\* -exec rm {} \;
sudo rm -r /usr/src/vboxadd-\*
sudo rm -r /usr/src/vboxvfs-\*
sudo rm /usr/sbin/vboxadd-timesync
sudo rm /lib/modules/$rel/misc/vboxadd.ko
sudo rm /lib/modules/$rel/misc/vboxvfs.ko


comment:6 in reply to: ↑ description Changed 4 years ago by Tungsten

I must confirm this bug when using a Linux host (Ubuntu 91.0 karmic 64 bits) and a Linux Debian 5.0.x guest.

Host type should probably be set to "any".

Regards.

comment:7 Changed 4 years ago by uchima

FWIW I am also seeing this issue with an Ubuntu 8.04 LTS host and Debian 5.0.x guest, X server 1.4.2 and lxde desktop.

comment:8 Changed 4 years ago by shawncm217

I am also seeing this issue.

Host: Windows 7 Ultimate 64-bit Guest: Debian 5.0.3 "Lenny" amd64 VirtualBox: 3.1.2

comment:9 Changed 4 years ago by yohann.martineau

Same problem here with virtualbox on windows 7 32 bits. Problem on Debian 5.0.3.

comment:10 Changed 4 years ago by michael

Ticket #5791 has been marked a duplicate of this one.

comment:11 Changed 4 years ago by michael

  • Summary changed from Mouse Integration fails to capture pointer in 3.1.2 to Mouse Integration fails to capture pointer in 3.1.2 -> fixed in SVN/3.1.4

Committed a fix.

comment:12 Changed 4 years ago by michael

Ticket #5922 has been marked a duplicate of this one.

comment:13 Changed 4 years ago by gionn

Tried the 3.1.4 beta 1 - Fixed!

comment:14 Changed 4 years ago by psycada

I just upgraded my guest additions about 45 minutes ago but didn't reboot for 30 minutes. After rebooting the guest machine, my cursor was stuck as well. I am delighted to see a fix. Could you please explain how to install the beta version? Thanks in advance for your assistance.

Host: Windows 7 Pro Guest: Debian 5

comment:15 Changed 4 years ago by Perryg

You can find the files here  http://download.virtualbox.org/virtualbox/3.1.4_BETA1/ Install the Beta Version in the Host then start the guest and install the guest additions.

*Beta Versions are not intended to be used on production equipment*

But yes it is fixed in this release.

comment:16 Changed 4 years ago by psycada

Thank you again. Everything is working now with the beta version.

comment:17 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:18 Changed 3 years ago by mikl

  • Status changed from closed to reopened
  • Resolution fixed deleted

I've got the same problem with mouse synch. VB 3.12.2 host: Windows 7 professional guest: Windows Server R2 x64

The mouse behavior is same as discribed plus jumping Message Box ascing press home + ctrl every time after captured mose click occurs.

comment:19 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use