VirtualBox

Ticket #5791 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

No left click -> duplicate of #5832

Reported by: gionn Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

Lost the ability to left-clicking on Debian Lenny guest with MacOsX host, Guest additions upgraded.

I tried to empty my xorg.conf (rm /etc/X11/xorg.conf*) and relaunched Guest Additions Install, but left click doesn't work.

A workaround is disabling mouse integration or starting X with a blank xorg.conf.

Attachments

vboxmouse_fix_for_lenny.diff Download (3.2 KB) - added by gionn 4 years ago.
Patch from Carsten Juttner

Change History

comment:1 Changed 4 years ago by gionn

This is the xorg.conf generated from scratch by Addittions installer:

# VirtualBox generated configuration file # based on /etc/X11/xorg.conf.

Section "Monitor"

Identifier "Monitor[0]" ModelName "VirtualBox Virtual Output" VendorName "Sun Microsystems Inc"

EndSection

Section "Device"

BoardName "VirtualBox Graphics" Driver "vboxvideo" Identifier "Device[0]" VendorName "Sun Microsystems Inc"

EndSection

Section "Screen"

SubSection "Display"

Depth 24

EndSubSection Device "Device[0]" Identifier "Screen[0]" Monitor "Monitor[0]"

EndSection

Left click works, but because Seamless mode isn't started (cannot get out of screen with pointer)

comment:2 Changed 4 years ago by gionn

Sorry, I was deceived by the host mouse pointer, the problem is that I can't move the mouse at all (remains in his initial position, probably bottom-left or bottom-right on the screen, I saw it when right-click kde menu appear).

This is the default debian lenny xorg.conf, modified by the Guest Additions installer:

Section "InputDevice"
  Identifier   "Keyboard[0]"
  Driver       "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "it"
  Option       "Protocol" "Standard"
  Option       "CoreKeyboard"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "9"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "VirtualBox Mouse Buttons"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sun Microsystems Inc"
  Option       "ZAxisMapping" "4 5"
  Option       "CorePointer"
EndSection

Section "InputDevice"
  Driver       "vboxmouse"
  Identifier   "Mouse[2]"
  Option       "Device" "/dev/vboxguest"
  Option       "Name" "VirtualBox Mouse"
  Option       "Vendor" "Sun Microsystems Inc"
  Option       "SendCoreEvents"
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  InputDevice  "Mouse[2]" "SendCoreEvents"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "Monitor"
  Identifier   "Monitor[0]"
  ModelName    "VirtualBox Virtual Output"
  VendorName   "Sun Microsystems Inc"
EndSection

Section "Device"
  BoardName    "VirtualBox Graphics"
  Driver       "vboxvideo"
  Identifier   "Device[0]"
  VendorName   "Sun Microsystems Inc"
EndSection

Section "Screen"
  SubSection "Display"
    Depth      24
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

On Ubuntu Karmic the mouse is working, so it's probably a regression only for old Xorg release.

ii  xserver-xorg                         1:7.3+20                      the X.Org X server
ii  xserver-xorg-core                    2:1.4.2-10.lenny2             Xorg X server - core server

Thanks.

comment:3 Changed 4 years ago by michael

I'll set up a Lenny guest to investigate. I take it this is a 32bit guest?

comment:4 Changed 4 years ago by gionn

Yeah, 32 bits.

I already tried messing with some option in xorg.conf, with any luck.

Thanks.

Changed 4 years ago by gionn

Patch from Carsten Juttner

comment:5 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from No left click to No left click -> duplicate of #5832

I will mark this as a duplicate of #5832, as that ticket contains more information.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use