Ticket #5266 (closed defect: wontfix)

Opened 12 years ago

Last modified 5 years ago

Shared Clipboard stops working -> closed, please use new tickets

Reported by: Perryg Owned by:
Component: clipboard Version: VirtualBox 3.2.10
Keywords: Cc:
Guest type: Linux Host type: Windows


After a period of time the shared clipboard will stop working either in one direction or the other and sometime in both directions. A reboot of the guest will bring it back. Logfile included.

HOST = Vista Business 32
Guest = Ubuntu Jaunty 32


VBox.log Download (37.3 KB) - added by Perryg 12 years ago.
Jaunty Logfile
VBoxClient.log Download (6.2 KB) - added by Perryg 12 years ago.
Clipboard problem logfile
New-VBoxClient.log Download (14.0 KB) - added by Perryg 12 years ago.
New one captured today with errors
clipboard.jpg Download (37.1 KB) - added by Perryg 11 years ago.
Cliptest.jpg Download (59.4 KB) - added by Perryg 11 years ago.
VBox.2.log Download (62.3 KB) - added by Lexxa 11 years ago.

Change History

Changed 12 years ago by Perryg

Jaunty Logfile

comment:1 Changed 12 years ago by Perryg

Additional Info. The guest can for the most part copy to the host, but not the other way around. Then after a while longer it simply gives up and does not copy to either. This is seamless mode as well but taking it out of seamless mode does not change the way it behaves.

comment:2 Changed 12 years ago by michael

Silly question, but you did update the Additions on the guest, didn't you? Assuming you did, could you please try stopping the clipboard service on the guest and restarting it (as your logged on user) as follows:

$ VBOX_RELEASE_LOG_DEST=file VBOX_RELEASE_LOG=all.e.l.l2.f VBoxClient --clipboard --nodaemon

That should create a log of clipboard activity, seen from the guest's point of view. Once you have reproduced the issue, you can stop the service again and upload the log, with a brief explation.


comment:3 Changed 12 years ago by Perryg

Well you got me. I do have 3.0.8 GA and verified it again by looking at the Vboxadd-install.log I killed the service and ran the command. I saw that the VBoxClient --Clipboard service was started as stated in the command.
I copied from the host to the guest = worked
I then copied from the guest to the host = worked.
I then copied from the host to the guest = did not work. It pastes the same info that was copied and pasted to the host
It did not flush the clipboard on the last copy from the guest to the host.
Stopped the service that was running in terminal (ctrl+v) saw that the service had in fact stopped.
I can not find a file that contains the information anywhere.

It appears to be working as it did before the 3.0.2 upgrade just so you know.

Want to point me to where this file is and what it should be called?

comment:4 Changed 12 years ago by michael

The file should be called VBox.log in the directory you ran the command from. I assume that you are using bash, so that the environment variables on the command line get passed to the programme.

comment:5 Changed 12 years ago by michael

And when you said that "the service had in fact stopped", do you mean that the VBoxClient application had crashed?

comment:6 Changed 12 years ago by Perryg


Good morning.

Standard Ubuntu terminal logged in as myself. No file is created in the home folder period called anything.

(1) I killed the service using htop

(2) started the service with the command you sent.

(3) copied from the host to the guest (worked) then from the guest to the host (worked) then from the host to the guest paste is the exact content that was copied from the guest.

When I said the service had stopped I mean the VBoxClient --clipboard ( I verified that I had killed the service). The VBox app does not crash. I can (once I start the VBoxClient --clipboard), copy and paste once from the guest and then the second copy from the guest stays in the cue. I can kill the service and start it again and it will copy Once and the second copy hangs in the cue. The local clipboards do not seem to be affected. I tested copy and paste within each and they work as expected. The only one that fails is the VBoxClient --clipboard.

There was an Ubuntu update last night and I ran it this AM watching the process I saw that the VBox GAs were being updated due to a kernel update in the Ubuntu Guest. I saw the 3.0.8 GAs getting recompiled (dkms installed). Re-ran the test and same thing. VBoxClient --clipboard fails and no file created.

comment:7 Changed 12 years ago by Perryg

You know I just have this bad feeling that no matter what I do this is going to be an on-going problem with this OS. It is the same one that was fixed with version 3.0.2. If there was a way to actually remove the guest additions and then install clean I believe this might work, but it appears that there is some artifact that was left behind that crops up every so often. I have tested on several other OSes and they simply don't have this problem. Do you have a way that I can actually remove them? If not I will just bite the bullet and re-create the OS all over (although I would really not like to). I understand that from you end this is not going to be easy to troubleshoot since for some reason I can not supply you with the information that you need. So Let me know and I will either try to remove or install a new copy.

comment:8 Changed 12 years ago by Perryg

OK I have it fixed.

I finally disabled the bidirectional clipboard in the GUI and booted the guest. Then shut down and enabled it again.

I had checked the machine.xml and it was enabled but somewhere it was getting lost. I know this OS has been running for a while and gone through a lot of GA updates, but it never occured to me that something like this could happen since the xml showed it enabled. Strange huh?

By the way the logfile never was able to be created. I copied and pasted it in the guest so I don't know what to tell you about that. Everything worked as I think it was supposed to but no file.

comment:9 Changed 12 years ago by r_mano


I have the same problem but with Linux host and Windows XP guest. Right now, for example, cut and paste from guest to host works, but not the other way around. I have VB 3.0.8 on Jaunty, and Win Xp up-to-date on the guest, with GA 3.0.8 too. I do not know how to fiddle with GA setting, given that a mouse click on the icon in the system tray (or double click, or right click) does nothing. Have you any advise?

comment:10 Changed 12 years ago by Perryg

Well I jumped the gun and it did not stay working.

I can copy and paste to the host from the guest with no problems. If I copy from the host the first time (before I copy from the guest) I can paste once to the guest. It is as if the bidirectional part is stuck. machine xml shows it is bidirectional. I have tried every combination I can think of to get your command to work and it does not create a log anywhere that I can find. As I said the update from 3.0.2 fixed this for me until the upgrade to 3.0.8

If you have anything else I can try I will be glad to try.

comment:11 Changed 12 years ago by Perryg

OK started a different version of Ubuntu. This one is Karmic (9.10) Works fine for a while just as the 9.04 Jaunty does then somewhere after a bit it starts acting the same way. Bidirectional functionality is not there. One way is. Guest to host works. The command that you sent me works the same way as well. No logfile.

comment:12 Changed 12 years ago by r_mano

I see exactly the same than Perry g with Linux Host and Windows guest. I think that someone that can should change host to Any and guest to any in this ticket. It seems a unix-windows problem, no matter which is guest and which is host.

comment:13 Changed 12 years ago by Perryg

I did some more testing today and it is definitely tied to time. A clean boot of the Host and of course the guest, will allow it to work for hours (random, depends on activity I think). Then it simply hangs in the clipboard buffer. (Guest Copy is all that pastes).

I started a Debian 5 guest (did not shut down the Ubuntu guest) after the paste messed up and it works while the Ubuntu still could not.

While both were running the Ubuntu one would not work, but the Debian 5 one would. If I leave the Debian 5 one running in time it fails as well.

comment:14 Changed 12 years ago by michael

Ticket #5279 has been marked a duplicate of this one.

comment:15 Changed 12 years ago by Perryg


I have an update for you. If I start the VM using

VirtualBox.exe --startvm Ubuntu-Karmic or Ubuntu-Jaunty (trying both distros)

The copy/paste function does not fail. If I start it via the GUI, it will sometimes work for 5 minutes and sometimes as many as 5 hours before it fails.

This should really make it difficult to run down, but I will send more data as it becomes available. Still the command that you sent does start the clipboard as nodaemon, but no file is generated. Wish I knew why that is. I would like to see what the clipboard had to say about this as well.

I have tested the clipboard function on Ubuntu host 64 bit with both windows and Linux guest and I can not make it fail.

comment:16 Changed 12 years ago by Perryg

My work around Vista business host

Create cmd file Start-Karmic.cmd

@echos off
start VirtualBox.exe --startvm Ubuntu-Karmic

Execute instead of starting in VBox GUI. Clipboard does not fail.

I do not see any adverse reactions while running this way. It appears that everything is happy. Let me know what else I can do to help find this. I am able to work with the temporary solution so I will await your word.

comment:17 Changed 12 years ago by michael

Shame on me. I investigated why the logging was not working, and it turned out that I gave you the wrong syntax, and that the correct syntax (to create a log file called VBoxClient.log in the current directory) is:

$ VBOX_RELEASE_LOG_DEST=file=VBoxClient.log VBOX_RELEASE_LOG=all.e.l.l2.f VBoxClient --clipboard --nodaemon

Would you be able to run that to create a log file and then reproduce the problem/VBoxClient crash? Thanks.

comment:18 Changed 12 years ago by Perryg

Sure thing. I thought I was going crazy! Give me a bit to shut down and restart and we will see what I can come up with.

comment:19 Changed 12 years ago by Perryg

@Michael, Well I started the guest with the command and it did create a log file there is only one problem. I can not make it fail now, and on top of that we had a version upgrade today. So it may be a while until I can send you any report. Hopefully I can report back that it appears to be fixed, but i will let you know.

comment:20 Changed 12 years ago by Perryg

OK It finally messed up and right after the upgrade. (3.0.10 GAs are installed) I can copy and paste to the host from the host. I can copy and paste to the guest from the guest. I can copy from the guest to the host. I can not copy from the host to the guest

File attached.

Changed 12 years ago by Perryg

Clipboard problem logfile

comment:21 Changed 12 years ago by Perryg

Additionally, If I do not reboot the host the shared Clipboard fails a lot sooner. Rebooting the Host will give me from hours to days before it finally fails. Is there some way I can monitor this from the Host side?

Changed 12 years ago by Perryg

New one captured today with errors

comment:22 Changed 12 years ago by Perryg

What ever is in the guest buffer stays in the guest buffer as far as pasting. It looks like there are (2) separate buffers instead of (1) when the problem occurs.

Guest to guest and guest to host works. host to host works but not host to guest.

Now I can start the host and the guest fresh and have not problems at first. If I do nothing in the guest the C/P works for a long period of time. If however I start something like rhythmbox and listen to last fm for say 30 minutes, then the problem occurs within the 30 minute window. However it does not seem to effect things while working on the Host.

I have tried this on several programs including FireFox, Gedit, OOo, Notepad and Office word. Stopped all drag-to-disk services plus anything that could mess with the clipboard but they did not change this behavior. The only thing that I have not done was uninstall MS Visual Studio 2005 (really don't want to do that unless I must) It is a real hassle to install and get back up to date.

comment:23 Changed 12 years ago by r_mano

I do not think you need to uninstall anything. I have the same problem, guest and host interchanged, and never got even near to Visual Studio.

comment:24 Changed 12 years ago by michael

Perryg: you might want to try a couple of different Guest Additions versions to see if that makes a difference (<x>/VBoxGuestAdditions_3.0.<x>.iso ). Do you have any Windows guests on the system where you see the problem, and if so, do they ever suffer from this?

comment:25 Changed 12 years ago by sunlover

Perryg, when "host to guest" stops working, please close the VM window to save the VM state and then start the VM again. Will "host to guest" work after such a restart?

comment:26 Changed 12 years ago by r_mano

I tried it with my case, which is reversed (host is linux, guest is windows, what stops working is copy in guest and pasting in host). No change, if I save the VM state and start again, the problem continues.

comment:27 Changed 12 years ago by Perryg


Thank you for the suggestion however I had already tried to regress the GA's. Problem still existed. I started a WinXP guest (while Linux was still running) and C/P works in the Win guest while it still did not work in the Linux guest. I will monitor the WinXP guest today and let you know. Only other thing that I can think of to do is regress the VBox program and see if that will solve the problem.


Thank you for your suggestion. Unfortunately this does not solve the problem. This allows the guest to function properly but here again this is just a moment in time. As soon as I start using it to do various tasks it too fails again. Not a solution as I run these things 24/7 and do not need to be closing and starting them multiple times each day to be able to use the bidirectional clipboard.

comment:28 Changed 12 years ago by sunlover

Perryg, it was a test. Do I understand it right that restarting the VM process as suggested allows you to copy from host to guest?

In that case there could be some application on your host which interferes with host clipboard viewers, which monitor clipboard changes (VBox VM process is one of them). Restarting the VM process allows it to reregister as a clipboard viewer.

If you have an XP installation, you could try another test. Get windows\system32\clipbrd.exe from XP and copy to your Vista host. Start the VM, after that start clipbrd.exe. clipbrd.exe will show you everything pasted to the host clipboard. Reproduce the problem. Then check whether clipbrd.exe still show you new data pasted to clipboard. That is try to paste some text and check whether clipbrd.exe gets the change.

If clipbrd.exe does not see new changes, then someone broke clipboard viewers chain. If it gets new changes then the problem is elsewhere.

comment:29 Changed 12 years ago by sunlover

r_mano, in you case you would have to restart VBoxTray.exe application in the guest.

comment:30 Changed 12 years ago by Perryg

@sunlover, As I indicated above I have done as you suggest and it does allow C/P for a time. Usually 2 to 4 C/P events and then fails.

I am not inclined to install the XP clipboard in Vista but I do have a clipboard viewer that can see these events being copied correctly on the host side, but it does not transfer to the guest side. As I say it appears that the link between the two is broken in one direction. Equate this to changing the clipboard from bidirectional to guest to host in the settings is the exact how it appears.

I have tried the Windows guest but this sometimes takes all day to fail depending on the amount of use that I impose on the guest.

I had this (or similar) problem when 3.0.0 first came out and the problem was resolved with 3.0.2 . Now as far as restarting the clipboard service, I have also done that. segkill it and then restart it with command Michael sent. Sometimes it works for a short time, and other times longer. It appears to be use specific. If I do little in the guest it can last for a full day before it stops responding. If however I use the guest for my normal activities it will not last for more than 30 minutes.

I am going to do some more testing today, but unless someone has something else they would like to try first, I am going to regress the VBox program to version 2.2.4 tomorrow to see it it allows the clipboard to work properly. Then I / we will know if it is some Windows app problem or VB code.

Oh and just an observation on my part. If the problem is VB code I think it is on the program side as regressing the GAs on the host do not fix the problem. I down-stepped one at a time all the way back to 3.0.0 with no effect. Problem still existed.

comment:31 Changed 12 years ago by Perryg

Host Vista running Clipboard Viewer.
Guest 1 = Ubuntu 9.10
Guest 2 = Windows XP

Copy from any of the guest or host all show in the viewer on the host.

For a period of time paste works to all. Then paste from host to Guest 1 fails. (still shows the new copy in the viewer, but pastes the last thing that was in the guest 1 buffer.

XP has not failed yet, but I have not pushed it hard enough to fail. Will continue and post that result later.

comment:32 Changed 12 years ago by Perryg

Same thing the XP guest finally failed the same way. Host clipboard viewer sees everything, but paste to the XP guest shows the last thing in the copied in the XP buffer.

So where to? Any more ideas?

comment:33 follow-up: ↓ 34 Changed 12 years ago by AntiMatter

I have encountered the same issue.

Virtualbox 3.0.10.r54097 + Guest Addition installed. Host = Win XP SP3. Guest = Win2003 x32. All up to date.

Clipboard copy / paste: work OK from Guest (copy) to Host (paste). The other direction is not working. Content copied into Host clipboard is ignored by Guest clipboard.

SO the issue is not Linux - Windows. This is also Windows - Windows.

comment:34 in reply to: ↑ 33 Changed 12 years ago by AntiMatter

Replying to AntiMatter:

I have encountered the same issue.

Virtualbox 3.0.10.r54097 + Guest Addition installed. Host = Win XP SP3. Guest = Win2003 x32. All up to date.

Clipboard copy / paste: work OK from Guest (copy) to Host (paste). The other direction is not working. Content copied into Host clipboard is ignored by Guest clipboard.

SO the issue is not Linux - Windows. This is also Windows - Windows.

Self correction: issue has disappeared today. I can't reproduce the issue today. Now clipbaoard working OK in both directions. Host and Guest are identical. The only difference is the host which has been rebooted this morning. And yesterday I had viewed some youtube video on the host.

comment:35 follow-up: ↓ 130 Changed 12 years ago by Perryg

Pretty much what I see too. After a host reboot it appears to last longer. Guest boot is a lot shorter. Saved start is even shorter. Sometimes only allowing 2 to 3 C/P's. Listening to or using flash player will cause it to fail quicker. I can not explain it any clearer than to say it appears to be use based and it is definitely loosing the hook (stream) to the guest paste from the host only, or in my case the Windows host to the Linux guest.

comment:36 Changed 12 years ago by LesDes

Same problem here. Something I came across quite a long time ago (many versions back). I only notice a problem pasting from host to VM. If I save the machine state and restart the VM then functionality returns.

Running v 3.0.10. This is a brand new VM created only a week or so ago. Host is XP SP3 and VM is W7.

How do I check the version of GA? Machine > Session Information shows "Guest Additions Version 1.4" which looks odd.

The problem never goes away by itself – I have to restart the VM in some way. It’s a major pain but does not take too long to save state and restart [though sometimes saving state goes to 100% and then hangs :( ]

comment:37 Changed 12 years ago by TwoBit

I am a user with this same problem. Vista Host, Kubuntu client. Clipboard is dead in both directions after working for a while.

If I execute this on the Kubuntu command line:

$ VBOX_RELEASE_LOG_DEST=file=VBoxClient.log VBOX_RELEASE_LOG=all.e.l.l2.f VBoxClient --clipboard --nodaemon

I get this:

"Failed to create a pidfile. Exiting."

comment:38 Changed 12 years ago by michael

TwoBit: that "failed to create a pidfile" is likely to mean one of two things. Either VBoxclient can't erase an existing pidfile ("" in your home directory) for some reason, or it can't write to that directory. (There may also of course be other, more subtle problems, but those two are the most likely). Could you check those please? Thanks.

comment:39 Changed 12 years ago by kidault

I have the same question.
Host: Windows 7 Pro Guest: Windows XP Home SP3 Virtualbox 3.1.3, a beta version.

comment:40 Changed 12 years ago by r_mano

Still here, with Linux host and winXp guest. version 3.1.2, all updated.

comment:41 Changed 12 years ago by r_mano the way (hit the submit button too fast) if I stop VBoxTray.exe in task manager in the winXP guest, and then restart it via command line, cut'n'paste starts working again.

I am a Windows illiterate, so I do not know how to generate a core dump or debug trace of the guilt process... if it's not difficult, I can help.

comment:42 Changed 12 years ago by LesDes

Just tried the above suggestion and I can confirm the same on W7 32 client running in W7 64 bit host. Killing VBoxTray.exe and then restarting it fixes the problem - till the next time I presume. At least we now have a simple workround. Thanks.

comment:43 Changed 12 years ago by DieterFauth

I have seen this with various versions of VBOX. Currently using the 3.0.10 r54097. Host is XP, guest XP or Linux (Debian, Ubuntu). Next time it happens, I will take some experiments an post the results here.

comment:44 Changed 11 years ago by eewww

same problem here.. I thought new version (3.1.4) solves this problem but it is still here. Just like that - "After a period of time the shared clipboard will stop working either in one direction or the other and sometime in both directions"

My host Win_xp32_sp3 and guest same Win_xp32_sp3 (i use it as a sandbox for surfing web sites, so clipboard is very important to me) How many versions need to be released to solve this damn BUG ?

comment:45 Changed 11 years ago by dest

The same problem still exists on a Windows 7 (64bit) host and Windows 2003 (32bit) guest with 3.1.4 and latest guest additions

If the vboxtray process is killed on the client and restarted the clipboard begins to function for awhile

comment:46 Changed 11 years ago by klaus

Could someone please take the time to describe step by step how to reproduce such a failure? Preferrably with a freshly installed VM and well-defined applications. Otherwise I see no change of getting this fixed.

comment:47 Changed 11 years ago by dest

In my situation it's not easily reproducable however once it starts occuring shutting down the VM and restarting it is the only fix.

Yesterday I had to restart the VM 5 times because of the issue (killing the vboxtray and restarting seems to resolve it for one copy/paste function, then it needs to be repeated)

Today however I have not had the issue at all.

Host is a Windows 7 64bit system Guest is a WIndows 2003 server 32bit system.

Guest is being run in window mode.

I can't tell if it's an issue of multiple guests running or if it's a matter of switching in and out of the guest/host or even if it's the guest being minimized.

The log file in it's current state shows no sign of anything that could be causing the issue. I'd be happy to enable a debug log however (if still possible) if that would assist.

Changed 11 years ago by Perryg

comment:48 Changed 11 years ago by Perryg

Good day klaus, I have been quiet on this because I know how difficult it is going to be. It only seems to effect a handful of people and unfortunately I am one. I am enclosing a snap shot of the occurrence and described below.

(1) using gedit from Ubuntu 10.04 (fairly new install) I typed test to host and selected and copied.
(2) I then pasted it into notepad on the host. (worked)
(3) I then typed test to guest and copied it (clipboard viewer on the host shows it copied)
(4) When pasting to the guest however it pastes what the last thing I copied from the host.

I will try to run the command from above again today and tomorrow and see if I can capture anything that could help.

Changed 11 years ago by Perryg

comment:49 Changed 11 years ago by Perryg

Rebooted the guest and sigterm vbox --clipboard Ran debug script and did the same copy paste and the results are in Cliptest.jpg (attached) Nothing shows in the VBox log. If however I reboot the host it will last longer. Weird huh? You would think that if the clipboard viewer were seeing it since that is being run from the host the results would be 180 degree different. The only thing that I have ever come up with is that somehow the VBox program is loosing its hook to the host clipboard, but I am no expert.

Let me know what other tests I can run.

comment:50 Changed 11 years ago by r_mano

For me it is quite easy to reproduce. Host Ubuntu Karmic 9.10, guest Windows XP. Simply leave the guest running a whole day, best overnight, using it to read Outlook Exchange mail and using Word. With a freshly booted guest, cut and paste works between host and guest; after a while it stops, either in one direction or in both. Killing and restarting VBoxTray.exe in the guest sometimes solves the problem, temporarily. The same happens on my two machines.

I am available to test more. For example, is there an equivalente to "strace -p" for windows? Maybe a strace of the vboxtray.exe process while failing could be useful.

comment:51 Changed 11 years ago by kidault

cmd file solution by Perryg don't work for me.

But I use another walk around for someone who use MS windows as host and guest, and need to work in both OSes all day long like me. I am using a clipboard tools called "ditto" on sourceforge( It has a feature that allows keeping multiple computer's clipboards in sync through network. Further information could be found in its help.

And I hope following pages will be helpful too:  this one and  this one.

comment:52 Changed 11 years ago by AntiMatter

Using v3.14.57640, Host Ubuntu 9.10 x32, Guest WinXP x32, Guest Additions v3.14.

After a while (a few hours?) copy (from host), paste (to guest) no longer work. Reboot guest fixes issue. The issue cannot be reproduced and unfortunately I cannot determined the triggering conditions.

I have also noticed that the Host key (Right-Ctrl) does not release the mouse cursor back to the host. Example: Menu Machine / Disable Mouse Integration. Then the mouse stay inside the Guest, a press on Right-Ctrl doesn't release the mouse to the host. Instead it opened a context menu on the guest desktop (like a right mouse click). So the only way to go back to the host is to restart the guest. Does this have some relation to the copy/paste issue?

comment:53 follow-up: ↓ 129 Changed 11 years ago by maggix

I can confirm I have the same behavior on Mac OS X host (10.6.2) running virtualBox 3.1.4

comment:54 Changed 11 years ago by edward_silicon

I am also having the exact same behavior on a Windows 7 x64 host with an Ubuntu 9.10 guest. Here are some details:

Virtualbox Version: 3.1.4r57640 Host System: HP 6530b business laptop (Core2 Duo w/ 8GB of RAM)

This issue has been rather persistent over the last year with the last few versions of VirtualBox. I have also moved from a Vista 32bit host OS to Windows 7 x64 (clean install), problem still exists. The guest has also been updated from Ubuntu 9.04 to 9.10.

I'm willing and able to do testing to assist in identifying this problem.

comment:55 Changed 11 years ago by r_mano

(Remind: it happens to me with host: linux and guest: winxp sp3).

Another point (hoping to shed some light). Doing the following: copy in host (e.g., from firefox) and then paste in guest, sometime the guest application (in my case Outlook) hangs until I kill the infamous VBoxTray.exe. After killing it, Outlook resumes normally. Restart it, all is back to normal.

Anyone can teach me how to put the equivalent of a cron job on windows so that I can kill and restart VBoxTray.exe every, say, couple of hours?

comment:56 Changed 11 years ago by TwoBit

Windows cron jobs are implemented by the Task Scheduler service. You can just type "Windows Task Scheduler" into an Internet search to get the details.

comment:57 Changed 11 years ago by commorancy

I am confirming that this bug still exists in 3.1.4r57640.

Host = Win 7 64 bit Guest = Win XP 32 bit

The first time I copy from Win 7 to XP (after a reboot), the first paste works fine into XP. The second time I try the copy, the newest copy no longer pastes in XP. It keeps pasting only the first thing copied. Copying from XP to Win 7 still works multiple times and properly. Restarting vboxservice doesn't affect this issue. Killing and restarting vboxtray.exe works again only once.

Please fix.

comment:58 Changed 11 years ago by frank

  • Component changed from other to clipboard

comment:59 Changed 11 years ago by karolrvn

Hi. I'm having this problem too.
Host: Win7
Guest: Linux * 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009 i686 GNU/Linux
Could you sum up this volumous thread?

  1. What's the (current) best (quickest / most reliable / least disruptive) workaround?
  2. Is it going to be fixed?
  3. Etc.


comment:60 Changed 11 years ago by karolrvn

Hmm.<br/> Are newlines ignored?

comment:61 Changed 11 years ago by frank

Yes. Have a look at the  wiki formatting rules.

comment:62 Changed 11 years ago by karolrvn

Sorry for littering I should have been more careful with that and should have used preview.
I have occasionally used trac before, but apparently, not enough to remember, in a hurry, about


I see, that someone edited my comment to the right multiline form. Can I edit my own comments?

comment:63 Changed 11 years ago by frank

No, unfortunately not because the right management of this trac version is not fine-granular enough.

comment:64 Changed 11 years ago by r_mano


when it happens, in the guest Windows machine kill and restart VBoxTray.exe. Sometime this solves the problems. In general, you need to reboot the guest machine.

Will try 3.1.6 shortly, but there is no mention about this bug in the Changelog.

comment:65 Changed 11 years ago by eewww

Is there some replies from developers about this BUG? This ticket must be on top of their TODO list.. This bug will be never solved until some of developer spare some time to investigate it himself.

comment:66 Changed 11 years ago by karolrvn

In my case (host:Win, guest:Linux): it is enough to have virtualbox save state of machine, close window, restore machine window. Fortunately no reboot required but still annoying. That maybe a different bug.

comment:67 Changed 11 years ago by javajunkie

Watching this bug.

comment:68 Changed 11 years ago by mperry

Just have noticed one other dynamic with this that I can reproduce 100% of the time. Any time my laptop running Ubuntu Karmic with a Win7 guest suspends leaving Virtualbox running, the clipboard just stops working completely until I reboot the guest. The keyboard also stops working until I minimize or roll-up the window on Karmic. I've changed the clipboard behavior from bidirectional to guest to host but after any suspend event clipboard just stops.

comment:69 Changed 11 years ago by bingwang

Not working for me: copy on guest, and paste to host. The other direction works. Host: Ubuntu Lucid x64. Guests: Win 7 x64, Win Vista x64.

comment:70 Changed 11 years ago by r_mano

Still here, virtualbox 3.2.4-62467~Ubuntu~lucid.

comment:71 Changed 11 years ago by RodCole

This issue and the lack of response from the developers is unacceptable.

I have been dealing with this seemingly simple problem for three months now and have even upgraded to the latest version of VirtualBox with the expectation that so doing would resolve the clipboard problem. I see where others have been complaining about this problem since October, 2009 on ticket 5266. Just how long can it take to fix this problem? It leaves one to think that Oracle could care less about fixing problems with Sun's opensource software. VMWare does not have this problem.

I am running VirtualBox 3.2.6 r63112 in Fedora 13. My virtual machine is Windows 7, X86. I also could never get this version of VirtualBox to open my previously created version of Windows 7, x64, nor could I create a new VM using the 64-bit version of Windows 7 due to "hardware" errors. However, the previously created VM ran fine on this same hardware. I have tried several of the suggested fixes from this Wiki including removing and reinstalling VirtualBox, removing and reinstalling the Guest Additions, etc.

Overall, I am greatly disappointed in Oracle VirtualBox and will probably have to migrate to a VM technology that works without all these problems.

comment:72 Changed 11 years ago by RodCole

I forgot to mention that at times, I can get the clipboard working between the host and the guest and vice versa by pasting into another text editor or even a Take Note session, then I can copy that text and paste it to either the host or the guest. This has stopped working altogether today and I will probably have to reboot the guest in order to make it work. Having to do this is ridiculous and I cannot get any work done if I have to do this all day.

I need the Windows 7 guest only because I have one program I must run daily to do my job. If my company would provide a Linux based version of that program, I would not need Windows at all.

comment:73 in reply to: ↑ description Changed 11 years ago by karolrvn

Did any of the Developers ever respond here? If yes, when and how many times? Are They marked somehow as VirtualBox staff?

comment:74 Changed 11 years ago by michael

For the record, I am one of the developers, although I didn't write the Windows clipboard code (I did write the Linux version). It seems that the problem is due to a design problem in the Windows clipboard monitoring functionality (if you are interested in the technical details,  this MSDN blog explains it - I note that they mention that Vista added improved APIs, which I wasn't aware of before). If this occurs on a Windows guest system, a quick fix that should work is to restart the "VBoxTray" application. This will not require you to reboot the guest, or even to log out and back in again.

comment:75 Changed 11 years ago by michael

Just a shame that I don't seem to be able to find any mention of how to use the improved APIs on the net, and Microsoft's documentation still describes the old ones.

comment:76 Changed 11 years ago by michael

Ah, seems to be  WM_CLIPBOARDUPDATE.

comment:77 Changed 11 years ago by Perryg


Thank you for the link. This confirms my theory that the clipboard does loose the connection or at least appears to. I will note that I have since moved on to Windows 7 and the problem is not as bad, but can not say that it is gone. Hopefully when you find the proper way to use the API this will be put behind us. I appreciate all that you and the other Devs do and will watch for more. Let me know if you would like anything else tested.

comment:78 follow-up: ↓ 79 Changed 11 years ago by r_mano


I understand that the clipboard protocol is complex and - probably - buggy, but a workaround should exist even with Windows XP, given that other virtualization software do work. I use the kill-an-restart VBoxTray.exe method, when I need to use the clipboard, but I can't say this is a solution or even an acceptable workaround. I hope you (the developers, I mean) could find a way to fix it for good.


comment:79 in reply to: ↑ 78 Changed 11 years ago by spstarr

Replying to r_mano:


I understand that the clipboard protocol is complex and - probably - buggy, but a workaround should exist even with Windows XP, given that other virtualization software do work. I use the kill-an-restart VBoxTray.exe method, when I need to use the clipboard, but I can't say this is a solution or even an acceptable workaround. I hope you (the developers, I mean) could find a way to fix it for good.


I'm having this issue also from home, XP to Fedora 13, it fails to copy one way from Windows -> Linux

comment:80 Changed 11 years ago by michael

If anyone has information about how to make this work reliably on XP (without hacks involving timers), please provide a pointer. When I search, I only find developers complaining that there is no good way to do it.

comment:81 Changed 11 years ago by michael

Ticket #3303 has been marked a duplicate of this one.

comment:82 Changed 11 years ago by drumbaby

Dear Michael,

Let me join the chorus. This has been an incredible time waster for me in the past months (Host: WinXP, Guest: Ubuntu, several recent VirtualBox versions). Following the hints you provided I saw that several effected programs offer a "fix clipboard chain" utility. These merely register their own application first. Silly, but useful, and much better for your users than the current situation. Some applications even run this every 10 seconds or so. Again, silly, ugly, non-scalable, and all that. But also much much better for your users than the current situation. If you provide us some feedback, maybe each user will even figure out which is the offending 3rd party application on his system and find alternatives to it. etc.

So yes. It's all MS' fault - what a horrible Win3.1-style design. But we could use your help is using VirtualBox in WinXP despite this.

Thanks in advance.

comment:83 Changed 11 years ago by michael

I have added a hack to the Windows Additions which tries to check the validity of the clipboard chain up to our viewer and re-registers us if the chain looks like it might be broken. The changesets are r32200 and r32211 for anyone interested in the details, and the short summary is that we send a message for ourselves to the top of the chain which should get passed down to us if everyone in-between is behaving as they should. We also switch to doing timed waits instead of waiting for ever (as the Windows API documentation says we should) when passing on messages to viewers further down the chain, in case one of them doesn't respond and leaves us blocked. As I am not a Windows person by any stretch of the imagination (to the point that I built this under Wine when I tested it for want of a Windows build box handy) this is probably not done optimally, so anyone with Windows development experience should feel free to take a look.

I have uploaded an Additions ISO image containing this change to

This is a snapshot from the unstable branch of VirtualBox - see disclaimer here - but it should work fine with the 3.2 series and shouldn't have many terrible things in it that aren't already in the 3.2 Additions. Since the Windows host clipboard code will have the same issues and I have not yet ported over these changes it makes most sense to test this on a Windows guest running on a non-Windows host.

Feedback appreciated.

comment:84 Changed 11 years ago by Perryg

I will give this a shot tomorrow Michael. Thank you for you trials and tribulations. As stated above it seems the problem is not as bad with Windows 7 host so it may be a while before I can report back.

comment:85 Changed 11 years ago by michael

Perryg: thanks in advance. As I pointed out though, my fix, if it works, is only for the guest anyway at this point.

comment:86 Changed 11 years ago by Perryg

I figured that. Kind of makes it interesting though. With the articles I have read and the gripping of the actual Redmond guys I know you would think they would fix this internally. Go figure. I guess that would be the easy approach and we all know sometimes big companies don't usually take that approach.

comment:87 Changed 11 years ago by LesDes

I'm running W7 guest inside W7 host and have this problem virtually all the time. I have a VB script to restart VBoxTray and I have to use it each time I copy paste or I use a shared text file. Perryg, let us know if it is any help and I will also give it a go.

comment:88 Changed 11 years ago by r_mano

I am running a WinXP guest (32bit) on a Linux host (32 bit). I installed it this morning, so far all is going well(*). The bug here shows up after several hours normally, so that I will comment tomorrow (or on monday :-)) if is still ok.

Thanks a lot, Michael.

(*) PD: well, installing the additions crashed my VM on the first try (windows XP locked hard). Probably a windows problem.

comment:89 Changed 11 years ago by r_mano

Good news, after 4 hours cut-and-paste is still working, both directions. Will continue testing, and report on Monday.

comment:90 Changed 11 years ago by dest

I as well have been using this on my virtual machines and haven't noticed the cut out yet.

The only thing I did see (which I could live with) is at times If I try to copy/paste from virtualmachine to virtualmachine I have to paste/copy in the host first

virtualmachine1 (copy) <-> Host(paste) -> Host(copy) <-> Virtualmachine2(paste)

The full cutout though has not happened to me yet.

Fedora 13 x64_86 host, winxp guests

comment:91 Changed 11 years ago by michael

dest: does the effect which you describe only occur with Windows guests, or can you reproduce it with Linux ones? I am asking this to make a guess about whether the problem is on the host side or the guest side.

comment:92 Changed 11 years ago by dest


I'm not sure as I only have windows guests currently.

I will set up a linux guest this weekend and see if I can reproduce

comment:93 Changed 11 years ago by Perryg

I am running the test GAs in Ubuntu 10.10-Beta guest as we speak. C/P is holding out longer so at least at this point it appears better. I am setting up a host side clipboard viewer later today to see what if anything happens. Windows guests seem to work at this point as well. Install was not really messy on either Linux or Windows guests as far as I can tell but only XP and Ubuntu guests tested at this point from a Windows 7 host.

Added benefit is the support for Xorg 1.9! Thanks.

comment:94 Changed 11 years ago by r_mano


Tested just now again, over a RDP-over-ssh connection, and it seems it still works. So congrat, I think you got it. Monday I will try locally again, and report, but I am quite confident your solution smashes the bug.

comment:95 Changed 11 years ago by r_mano

Monday, cut&paste still ok both ways. For my case, Linux host, windows guest, the Michael's solution fixes the bug. Thanks (a lot).

comment:96 Changed 11 years ago by Perryg

I had one hiccup where it pasted the previous copy but recopying and pasting worked so I consider this a major improvement. The tests were done in rapid succession so I may have gotten ahead of your code. All tests were done mixed with mouse C/P and keyboard C/P.

Works good enough for me. Well done Michael!

comment:97 Changed 11 years ago by r_mano

Bad news. After the machine was up for 4 days, today C/P has broke again, in both directions. :-(

comment:98 Changed 11 years ago by Perryg

I was getting ready to post the same this AM because it failed for me last night. It works for a lot longer and does help a lot but it appears to me as it always has that it is the fault of the host side. Rebooting the host brings it back to service. If this is truly the case the only real fix is for MS to fix the clipboard code. Michael, you have gone far above and beyond here and I think I speak for everyone when I say thank you very much for your efforts.

comment:99 Changed 11 years ago by r_mano

Yes, I completely agree with the thanks to Michael. In my case host is Linux, and I do not know if the problem could be on the host side (I have to at least suspend the VM to reboot the host... if you want, I can test it).

Nevertheless, if the problem appears now one time a week, and it's just a question of killing/restarting VBoxTray.exe, I can say that has moved from the category of "pain in the back" to "acceptable hiccup". So thanks again Michael.

comment:100 Changed 11 years ago by michael

Perryg: I hope that the fix I applied to the Windows Guest Additions clipboard code will also make it into the (Windows) host side in any upcoming releases, which might further relieve your pain. You say that you have to restart the host to recover the shared clipboard. Does just stopping and starting the virtual machine ever help?

comment:101 Changed 11 years ago by Perryg

Actually I can suspend the guest and restart and it will actually start to work but failing at a much faster rate. Rebooting the host allows at least 5 times longer. The host side intrigues me though. I would be happy to test that for you too.

I also have an Ubuntu 10.04 x86-64 host that I have never seen this issue in but rarely run Windows guests in it. Mostly *NIX and it is not on 24/7/365 like the Windows host is.

comment:102 Changed 11 years ago by dest

Just wanted to add in that I still have not had a failure outside the occational copy/paste issue i mentioned before about occationally having to paste into the host then into the guest. This has happened very rarely though.

To add, I'm running Fedora 13 OS86_64 as a host.

Before the new guest additions I had the issue almost always within a few minutes of the machines being up, after, I haven't had it once.

With that being said though my guests are rarely on for more then 6-8hrs a day and the host is rebooted daily.

Just trying to add to the list of works/doesn't work

comment:103 Changed 11 years ago by michael

If you would like to try out the fix on a Windows host, here is a test build from the stable branch (disclaimer here):

(link orphaned)

comment:104 Changed 11 years ago by Perryg

I have installed the test and will test it for you. I only saw one problem during install at the finish when Windows said the program might need to run as administrator to work. I have not seen this error in a long time. It appears to work though but figured you would want to know. I will report back as soon as I have more information.

Question; will the next maintenance release have this fix code? I figure the next release is due out in the near future and with the last fix to the GAs working for almost 4 days I wonder. Also with this program update test I assume the GAs must be updated as well, right?

comment:105 Changed 11 years ago by michael

I passed on the bit about the installation message to our installer person. The fix should indeed be in any upcoming maintainance releases. And you could update the Additions to match the new version, but if you aren't experiencing any issues with the Additions test build I provided you with there is no real reason to switch, as there shouldn't be much difference between them.

comment:106 Changed 11 years ago by Perryg

Michael, So far so good. I had to reboot once due to updates but it appears to be solid and I see nothing adverse with the test install either. Of course I will let you know if it does fail but thought you would need to know how it is going so far. Not bad for someone that does not work in the Windows environment my friend. Thanks!

comment:107 Changed 11 years ago by Lexxa

Well I've got the same problem, but it's actually even worse. Host-guest copy/paste has never worked for me. Host-host guest-guest and guest-host do work. Restarting that tray application makes no difference.

VB version - 3.2.8 Host - Ubuntu 10.04 Guest - Win XP SP3

comment:108 Changed 11 years ago by michael

Lexxa: do these updated Guest Additions (which are from the updated Windows package linked above, same disclaimer re stable test builds) make a difference:

comment:109 Changed 11 years ago by Lexxa

Still the same. Sorry.

comment:110 Changed 11 years ago by michael

Lexxa: please make sure that the shared clipboard is enabled in both directions in the settings of that machine. Other than that, if you start VirtualBox using the command line

$ VBOX_RELEASE_LOG=+shared_clipboard.e.l.l2.l3.f VirtualBox --startvm "<your VM name>"

you will get a detailed trace of what is happening with the shared clipboard which might help me to understand what is going wrong if you reproduce your issue while it is enabled.

Changed 11 years ago by Lexxa

comment:111 Changed 11 years ago by Lexxa

Here you go. I've tried all c/p directions here. If it's not the log you want please give detailed instructions where to find one.

comment:112 Changed 11 years ago by michael

Lexxa: the log is indeed what I wanted. It looks like VirtualBox is unable to work out what formats are available on your X11 host for some reason. Perhaps you could try running the test programme I attached to ticket #3755, which should provide detailed information about what VirtualBox sees on the host clipboard? Thanks.

comment:113 Changed 11 years ago by Lexxa

I am sorry, but please specify what to do. The program is viewclipformats I guess, but when should I run it?

comment:114 Changed 11 years ago by michael

The output of the programme at a time when you try and fail to copy from host to guest should be useful (at least I hope it will help me). VirtualBox is basically failing to read the host clipboard properly, and that programme will give details of what VirtualBox can see, so it will hopefully provide a clue about what VirtualBox can't cope with.

comment:115 Changed 11 years ago by Lexxa

Well... This.

Time out getting clipboard format data.

comment:116 Changed 11 years ago by Lexxa

When I copy a file I get this

Found clipboard format: application/x-kde-cutselection
Found clipboard format: text/uri-list
Found clipboard format: text/x-moz-url
Found clipboard format: text/plain
Found clipboard format: UTF8_STRING
Found clipboard format: STRING
Found clipboard format: TEXT
Found clipboard format: COMPOUND_TEXT
Found clipboard format: TARGETS
Found clipboard format: MULTIPLE
Found clipboard format: TIMESTAMP
Found clipboard format: SAVE_TARGETS''

And I can paste a filepath in VM.

comment:117 Changed 11 years ago by Perryg

@Lexxa, File copy is not a function of the clipboard AFAIK! Paste of filepath is text and is what is associated with the clipboard.

@michael, I have not seen the error since both host and guest sides were installed. While I can not say it is totally fixed for certain, I can say I am more than satisfied.

Thank you my friend.

comment:118 Changed 11 years ago by Lexxa

Perryg, the point is that the program cannot get a text from clipboard, but when a filepath is copied (even as a text) it works fine.

comment:119 Changed 11 years ago by michael

Lexxa: are you running any applications on the host that you are aware of which might be interfering with the clipboard? At a random guess from the clipboard format you posted above, klipper (the KDE clipboard manager)? You could try stopping anything that might be interfering to see if it makes a difference.

comment:120 Changed 11 years ago by Lexxa

No that I know of. Never did use any of clipboard managers. Everything should be standart Ubuntu. I use Krusader in GNOME, that's why clipboard looks like that. I'll keep trying, maybe see what's what after a restart.

comment:121 Changed 11 years ago by Lexxa

Okay, I restarted PC. After a restart everything worked fine, so I started launching software I use one by one. The one that broke it was Opera (10.62). When I close it clipboard begins to work.

comment:122 Changed 11 years ago by Perryg

Oops, Sorry Michael but I must report that the clipboard failed me. A reboot is the only way I can get it back. Took a while though. I still think it is a Windows problem (at least for me) I was present in Vista and now in Windows 7.

comment:123 Changed 11 years ago by michael

Perryg: do you happen to have any other XP-compatible clipboard monitoring software that you can use to compare, in order to see whether that also fails in the same way?

Lexxa: I was able to reproduce what you see with Opera but haven't had time to investigate further.

comment:124 Changed 11 years ago by Perryg

I can try to see what happens. It is more difficult now that it takes weeks to happen. But I will see what I can do.

comment:125 Changed 11 years ago by Lexxa

michael, it still counts. At least now I know it isn't something I've done wrong. :)

comment:126 Changed 11 years ago by Dest


I've been having a lot of failures now like i mentioned before where I need to paste into the host, Copy then paste into second guest.. so:

Guest1 {copy} -> Guest2 {paste} = fail Guest1 {copy} -> Host {paste} -> Host {copy} -> Guest 2 {paste} = OK

These are all XP Guests, Fedora 13 x86_64 host. I tried updating to one of the daily builds w/ the guest additions you posted here to try w/ the same effect.

Any additional logging or options I should turn on to help w/ that?

It seems to be a guest2 failure though because most times I can paste into Guest3 w/out an issue when Guest2 if failing

comment:127 Changed 11 years ago by grahamperrin

Cc: grahamperrin (I assume that adding a comment makes me a Cc: without actually showing it.)

comment:128 Changed 11 years ago by grahamperrin

Wondering about aspects of this bug that may appear to be random.

  1. Is a clipboard bug more, or less likely to bite if you use keyboard acceleration to switch from host to guest (in Mac OS X, command-tab) or from guest to host (command then command-tab)?
  2. Is a clipboard bug more, or less likely to bite if you use the mouse alone to switch from host to guest and vice versa?
  3. When a clipboard bug bites, can you work around by preceding the paste with two clicks (once, then wait, then once more; not double clicking) in the machine to which you want to paste?

Points 1 and 2 are long shots, based on vague recollection of a bug in Chandler Desktop that presents only when application switching is performed using the keyboard.

Point 3 is another long shot, based on recent behaviour of a Java applet running in Safari.

The underlying message: think carefully about actions that we perform without thinking (actions that may be not yet noted within this ticket).

comment:129 in reply to: ↑ 53 ; follow-up: ↓ 132 Changed 11 years ago by grahamperrin

Replying to maggix:

Mac OS X host (10.6.2) running virtualBox 3.1.4

Bug bites Mac OS X 10.6.x host, Windows XP guest, VirtualBox 3.2.10 r66523

  • a few minutes ago (whilst drafting the preceding post) paste to guest worked
  • now, paste to guest fails.

What's to be pasted is visible in Clipboard of Finder (four words, "copied in the past", rich text RTF, probably copied using command-c).

I usually command-tab to switch from host to guest.

In the Windows guest, what's pasted is an earlier copy.

Should I try the VBoxGuestAdditions-r65982.iso offered by michael on 2010-09-20? (Additions currently in the guest have a greater revision number 66523.)

comment:130 in reply to: ↑ 35 Changed 11 years ago by grahamperrin

#6150 where the host is Linux, guest is Windows, may be a duplicate of this #5266

Replying to Perryg:

… Windows host to the Linux guest …

Replying to michael:

… try out the fix on a Windows host …

Replying to r_mano:

… Linux Host and Windows guest. I think that someone that can should change host to Any and guest to any in this ticket. It seems a unix-windows problem, no matter which is guest and which is host. …

+1 to any/any for this ticket. It's already a mixture.

comment:131 Changed 11 years ago by michael

  • Version changed from VirtualBox 3.0.8 to VirtualBox 3.2.10

I marked #5266 a duplicate of this ticket. Graham, you don't need to try the Additions that I linked to (the link should be stale now in any case) as the fix is also in version 3.2.10. If you can find any way to reproduce this systematically and quickly that would certainly be much appreciated. The fix that I added to 3.2.10 was a shot in the dark as I have never seen this issue myself, and I don't have much of an idea about what might be happening that it doesn't fix. And regarding X11-related issues, we might as well keep them on this ticket too at this point, particularly as I am much more familiar with the X11 clipboard code than the Windows code. Please no Mac-related issues though...

comment:132 in reply to: ↑ 129 Changed 11 years ago by grahamperrin

Replying to michael:

Please no Mac-related issues though...

Should I keep separate any copy/paste-related bug that involves my Mac OS X host?

In my comment:129 :

  • the host side seems good (is presence on Clipboard in Finder a definite indication of goodness on that side?)
  • the guest side seems bugged (not matching what I copied in the host)

comment:133 Changed 11 years ago by Burfee

hi, i had the same problem because i used to ran virtualbox as administrator (linux host, windows guest) because i created the raw drive image as administrator. when i finally figured it out i recreated the image with my normal user (took me some time to figure out the errors - i wasn't in the disk group) and now the shared clipboard problem is gone.

hope this helps someone. Good luck!

comment:134 Changed 10 years ago by redtech

OH MY GOD. Burfee has found the fix. I have Ubuntu 10.10 32bit running and was having this VERY annoying issue until I added my ubuntu login to the disk group. Now Clipboard is working.

All hail the genius.

Seriously thank you

comment:135 Changed 10 years ago by Burfee


Be careful because the actual problem was creating the raw drive as admin and then using it as normal user. You then run virtualbox using sudo, but the elevated privileges go away after a while and then the clipboard stops working.

Glad it solved your problem.


comment:136 Changed 10 years ago by nestoru

Hi, I ended up here from because this is considered a duplicate.

I have been using Virtual Box for some years now with the following configurations: host guest Ubuntu windows OSX ubuntu OSX windows

I have gotten the clipboard problem unidirectional and bidirectional in all of them for different versions of VirtualBox.

I can confirm that this problem happens when memory resources get scarce in the host and from the moment it happens only a reboot of guest solves the problem.

I am unsure if that is enough information but one way to possibly recreate this problem would be to open enough apps on the host to push it to its limit of physical memory.

I hope you are able to find out a better way to share clipboard between guest and host.



comment:137 Changed 10 years ago by gabrielcossette


I had the same bug as well.

Windows 7 host + Windows 7 guest

Text copy from host to guest began randomly working. Sometimes if I did CTRL+C multiple times in host, it would copy correctly. A reboot fix everything.

Also, I suspended/restored the state of this VM often, may be related to that...

There's definitely something here to check.

comment:138 Changed 10 years ago by Ynk

I have some more information about this, where the host is Linux. I use KDE, which means the clipboard manager Klipper is installed by default. The behavior with Klipper makes me think that it it is somehow a mixup between the clipboard and the X selection.

If you copy text in the host, it will not be available in a Windows guest. But if you open the Klipper menu and re-select the item you just copied to the clipboard *twice* then it becomes available in the guest. This has always worked for me, 100%, since the regression first appeared in 3.2.something.

If you open the Klipper settings, clear "Ignore selection," and select "Synchronize contents of clipboard and the selection," then it starts working again, just as it did before the regression. Text copied in the host is available in the guest without having to do the workaround above. Of course, as a side effect anything you select also goes to the clipboard in both the host and the guest, which is annoying for some people, but this is another workaround for KDE users.

Text copied on a Windows guest is always available to the Linux host, probably because the X clipboard/selection is not involved.

comment:139 Changed 10 years ago by michael

Does the problem persist if you temporarily disable Klipper? We definitely target the clipboard (the "CLIPBOARD selection" for X11 afficionados) not the middle-button-paste feature (the "PRIMARY selection"), though when text is copied from a guest to an X11 host (or guest for that matter) we do set PRIMARY too for convenience.

comment:140 Changed 10 years ago by linulin

It's a pity you do not support the "PRIMARY selection". I find it the main VirtualBox usability defect because it breaks copy/pasting from X11 host text console to gust WinXP VM. (This was the exact reason for me to start following the ticket.)

comment:141 Changed 10 years ago by michael

I fear though that many people would not appreciate losing the contents of their Windows clipboard every time something gets (even accidentally) selected in X11.

comment:142 follow-up: ↓ 143 Changed 10 years ago by cmcnally

I'm still having this problem... Windows xp host, centos guest... any update?

comment:143 in reply to: ↑ 142 Changed 10 years ago by michael

Replying to cmcnally: If logging in and out of X on your Linux guest doesn't help it is probably related to something else running on your Windows host which breaks the clipboard. So you should check what else you have installed/running (possibly in the background) and if you can spot what triggers the problem.

comment:144 Changed 10 years ago by michael

  • Status changed from new to closed
  • Resolution set to wontfix
  • Summary changed from Shared Clipboard stops working to Shared Clipboard stops working -> closed, please use new tickets

I will close this ticket, as it has become too long and confused (different hosts, guests and issues). Anyone still experiencing clipboard problems can create a new ticket (feel free to add a reference on to this one though). The main problem that I am still aware of is that on Windows hosts and guests the clipboard often stops working after a while. This is usually due to some other application misbehaving and the problem showing up in VirtualBox, but it is also because we use the old, more fragile Windows XP clipboard chain functionality to listen for clipboard changes, which can be broken by any misbehaving application. In a Windows guest this can be diagnosed by stopping and re-starting the "VBoxTray" application.

comment:145 Changed 10 years ago by michael

#9682 reports clipboard failure between two (Linux) guests although guest <-> host works for both.

comment:146 Changed 9 years ago by imran-uk

I'm using Virtualbox 4.1.22 with a Debian Squeeze guest and Windows 7 64-bit host. I also found that the clipboard stops working after a while.

Things to try:

  • re-install guest additions in the guest (prolly also needs reboot but annoying and invasive)
  • try killing and restarting VBoxClient --clipboard
$ pgrep -fl VBox
1757 /usr/bin/VBoxClient --clipboard
  • Try to eliminate programs on the host that may be interfering the the clipboard, in my case I found that RealVNC Server service was causing problems. Host-to-guest copy/paste now seems to work reliably.

Side note: I found I had to run "parcellite" in my Debian guest to make things work from the guest-to-host side (especially when copy/paste from vim visual selection in an ssh session).

$ aptitude search parcellite
i   parcellite                      - lightweight GTK+ clipboard manager  

Hope this helps someone.

Last edited 9 years ago by imran-uk (previous) (diff)

comment:147 Changed 5 years ago by Redfred Garett

I have the same problem of copying from the office (Server) to my remote computer. I'm using VirtualBox 3.2.10 under OSX 10.6.4, hosting ubuntu 64 bit ( uname -a : Linux sym-ecl-vm 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:05:27 UTC 2010 x86_64 GNU/Linux ) and can easily cut and paste from ubuntu to osx and the other way around.

Thanks !!

Redfred@ Redgage

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use