VirtualBox

Ticket #3303 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

Clipboard does not work -> see #5266

Reported by: Spock Owned by:
Priority: critical Component: clipboard
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

If i try to copy something from Virtual Box to the HOSTS clipboard... Nothing happens... There is nothing (new) inserted in the clipboard. so i can paste only old things or nothing.

I tried to copy something from the VB config windows on the host... no Guest was running... It does not work :-/

Change History

comment:1 Changed 5 years ago by utility73

i am experiencing the same problem version: virtualbox 2.1.2 host: windows server 2003 SP2 guest: windows xp professional SP3 clipboard sharing has been activated ("bidirectional") guest additions (2.1.2r41885) have been installed.

copy & paste does not work in either direction.

comment:2 Changed 5 years ago by guoguy

I am also suffering from the same pain, but luckily, it happens occasionally. I have noticed this issue have happend on many hosts and guests(linux, windows, max os x, opensolaris). Here are some links:
 http://www.virtualbox.org/ticket/3105
 http://forums.virtualbox.org/viewtopic.php?t=12356&highlight=clipboard
 http://forums.virtualbox.org/viewtopic.php?t=10306&highlight=clipboard+problem
 http://forums.virtualbox.org/viewtopic.php?t=10969&highlight=clipboard+problem
From these cases it seems it's the guest additions problem, hope sb. fix it up.
Besides, once my guest shared folder couldn't work with "network name not found" error, and I fixed it by reinstalling the guest additions. It may also the guest additions problem. A related link:
 http://forums.virtualbox.org/viewtopic.php?t=2759
Host: debian lenny
Guest: windows xp sp3

comment:3 Changed 5 years ago by marji.cermak

I have the same problem virtualbox 2.1.2 (and a few previous version too) host: windows XP SP3 guest: Ubuntu 8.10

I'm unable to reproduce the problem. It happens a few times a day. I suspect there is a possible connection with MS Outlook 2003 running on the host, as I just got the same problem (unable to copy from host to guest and vice versa - the VM clipboard support is set to bidirectional support). Outlook was the only running app in the windows host which, when I used cliboard, hang up for a few seconds. Other Win apps were fine.

When I was logging off to get rid of the problem, there was a process

vboxshareclipboard class

wchich was not responding.

comment:4 Changed 5 years ago by kronenpj

I found that using a program that supports copy/paste specifically, like jEdit, will work pretty consistently to get data into a Windows VB. Using an xterm to highlight and expecting it to paste into the VB window doesn't work.

Hopefully this helps.

comment:5 Changed 5 years ago by michael

kronenpj: this is the documented (in the user manual) behaviour of the shared clipboard.

comment:6 Changed 5 years ago by kronenpj

Oh, sure RTFM... ;)

Then the shared clipboard works just fine for me...

comment:7 Changed 5 years ago by michael

kronenpj: don't complain, I even read it for you :) Seriously, "traditional" X11 copy and paste is somewhere on my wishlist, but it is unfortunately sufficiently low that I may never get around to implementing it. Plus I'm not quite sure how it ought to interact with e.g. Windows guests.

comment:8 Changed 5 years ago by myxiplx

Just wanted to add my comments to this, I've seen many of the symptoms mentioned in the various clipboard bugs since upgrading to version 2.

With 1.6.2, the shared clipboard feature worked absolutely fine. I have a Ubuntu host (which has gone from 7.04, to 7.10, 8.04 and now 8.10), and a Windows XP guest (originally SP2, now SP3).

Since upgrading to version 2 (originally 2.1.0, now 2.1.4), I've had constant problems with the clipboard, and have seen the following:

  • Clipboard in the guest stops working (this has just happened to me again)
  • Clipboard in the host and guest works, but there is no sharing between them
  • Clipboard in each works, but the host clipboard overwrites the guest one every few seconds

I have recently completely removed the guest additions, rebooted, and then installed them from scratch. After doing that the shared clipboard feature worked absolutely fine for a few hours, but now it has stopped working again.

I have also had a message to the effect that the shared clipboard service is not responding on the guest during a shutdown.

My belief is that the shared clipboard occasionally encounters data that causes it to crash, in ways that can lead to the symptoms above. Next time I get it working again I intend to keep a close eye on it to try to spot exactly when the problem first occurs.

comment:9 Changed 5 years ago by darkoth

I'm having the same problems. I'm using Ubuntu 8.10 as the host and Windows XP as the guest. The clipboard in XP will just suddenly stop working. I can't even cut/paste inside the guest...

comment:10 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if the clipboard still does not work with version 2.2.2 for you. With Windows hosts there were known problems since we migrated to Qt version 4 which are finally fixed with VirtualBox 2.2.2. And this version contains various Linux-related clipboard fixes as well. Before you consider to reopen this bug, better distinguish between Linux and Windows hosts and guests.

comment:11 Changed 5 years ago by dmgeurts

  • Status changed from closed to reopened
  • Resolution fixed deleted

Not sure if another ticket has been opened for this on VB 2.2.4...

I'm using VB 2.2.4 on Ubuntu Jaunty with winXP SP3 as guest. Have just experienced the following trying to copy from one Excel page to another. The moment I select the other page the screen is completely refreshed, probably due to 95% of the screen output changing, and my clipboard is overwritten with data from the host system. Sometimes is does work but 75% of the time I lose the content of my guest clipboard. Running the guest in full screen seems to make matters worse...

comment:12 Changed 5 years ago by dmgeurts

Just found out that switching back to a single monitor seems to have resolved the issue. Just to be clear I'm not talking about dual screen in the guest VB session.

comment:13 Changed 5 years ago by dmgeurts

More info to add. Not sure anymore what exactly causes the error but I have observed the following behavior.

The clipboard works fine except for when OpenOffice (3.0) is running on the host. Closing OpenOffice resolves the issue and the guest clipboard does not get overwritten by the hosts clipboard every few seconds or major guest screen update. I'm open to suggestions etc but right now I've gone back to using excel and word in my guest OS. Was hoping to use dual screen but lack the time right now to figure that one out. Also seamless mode doesn't seem to play well with dual screen (and compiz?) in Ubuntu, I lose my gnome panels on my main screen. On the secondary monitor the explorer/task-bar is trunkated etc etc (that should be another ticket I guess)

Anyway feel free to close this ticket again. I need to open two new ones once I find the time...

comment:14 Changed 5 years ago by michael

dmgeurts: could you please provide more information about your OpenOffice issue? I had a brief play with OO 3.0 on my Ubuntu host and notepad in my Win XP guest (I don't have MS Office available at the moment) but didn't see anything unusual, apart from extra characters appearing at the end of the pasted text a couple of times (which I will follow up :) ).

comment:15 Changed 5 years ago by michael

dmgeurts: I may have fixed this problem. If you are still experiencing it with VirtualBox 3.0.4 and feel like testing the fix, you can try out a test build of the future 3.0.6 release via one of the links below. As these are generic script-based installers, you will need to uninstall your current version before installing one of them. Obligatory disclaimer  here.

 http://www.virtualbox.org/download/testcase/VirtualBox-2009-08-14-15-24-08-lin32-3.0-3.0.5-r51088.run

 http://www.virtualbox.org/download/testcase/VirtualBox-2009-08-14-15-30-51-lin64-3.0-3.0.5-r51090.run

comment:16 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing. VBox 3.0.8 containing the fix as well was released two days ago.

comment:17 Changed 4 years ago by jbailey

  • Status changed from closed to reopened
  • Resolution fixed deleted

This apparently is still not working. I'm using Virtual Box 3.1.6 r59338 and am still experiencing this issue at least two times a day.

comment:18 Changed 4 years ago by darekvb

Hi, same here as described by jbailey. Host windows 7, guest windows xp.

comment:19 Changed 4 years ago by darekvb

This time it works only one direction, from guest to host but not other way round. Bidirectional option is set.

comment:20 Changed 4 years ago by wouterk

Could this bug be related to the one described in ticket #4491 ? (See my last post there for further discussion.)

comment:21 Changed 4 years ago by cmcardle75

I also see this problem, along with a colleague. Host is always Windows 7 x64. Guest is Windows Server, either 2003 R2 or 2008 R2. In either case, you're lucky to get 5 minutes of clipboard operation after reboot. Afterwards, nothing in either direction. Seen on 3.0.4, 3.1.4 and 3.1.6. I've pretty much given up on ever seeing the clipboard integration work, which is very frustrating.

comment:22 follow-up: ↓ 23 Changed 4 years ago by iancast

Most of the time, the clipboard works. But sometimes it stops working and I have to reboot the guest OS. It's extremely frustrating! I have to use a shared text file to copy urls for example.

comment:23 in reply to: ↑ 22 Changed 4 years ago by iancast

Replying to iancast:

Most of the time, the clipboard works. But sometimes it stops working and I have to reboot the guest OS. It's extremely frustrating! I have to use a shared text file to copy urls for example.

Here are my specs: Host - Windows 7 x64 Guest - Windows Server 2008 R2

comment:24 Changed 4 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Summary changed from Clipboard does not work to Clipboard does not work -> see #5266

I will mark this ticket as a duplicate of ticket #5266. While that ticket is technically for Windows hosts and Linux guests, it has strayed off-topic sufficiently to cover the issues in this ticket and we might as well keep everything in one place.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use