VirtualBox

Ticket #5267 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

WinXP on immutable disk crashes on restore

Reported by: gholder@… Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.8 Keywords: WinXP Immutable restore
Cc: Guest type: Windows
Host type: Linux

Description

I have a working guest WinXP. I am able to save the state of the machine and restore it if the disk type is normal.

I shut the machine down and change the disk type to immutable with the following commands:

VBoxManage modifyvm winxp_1 -hda none
VBoxManage closemedium disk c6647fc2-84c9-4bfd-8a54-cec38a0ea256
VBoxManage openmedium disk winxp.vdi --type immutable
VBoxManage modifyvm winxp_1 -hda c6647fc2-84c9-4bfd-8a54-cec38a0ea256

I boot XP and save the machine state. When I restore the machine state, WinXP crashes with:

The problem seems to be caused by the following file: afd.sys

PAGE_FAULT_IN_NONPAGED_AREA

....

Technical information:

* STOP 0x00000050 (0xc60306DA,0x0000000,0xF6C99C09,0x00000000)

* afd.sys - Address F6C99C09 base at F6C92000, DateStamp 48a40333

Attachments

VBox.log Download (35.9 KB) - added by gholder@… 5 years ago.
Log file when VB crashes on restoring state

Change History

Changed 5 years ago by gholder@…

Log file when VB crashes on restoring state

comment:1 Changed 4 years ago by gholder@…

I've verified this problem remains in 3.0_3.0.10-54097_Ubuntu_jaunty_i386.deb

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.2.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use