VirtualBox

Ticket #9682 (closed defect: invalid)

Opened 3 years ago

Last modified 18 months ago

clipboard not working -> configuration issue

Reported by: mschelm Owned by:
Priority: major Component: clipboard
Version: VirtualBox 4.1.4 Keywords: copy/paste
Cc: Guest type: Linux
Host type: Linux

Description (last modified by michael) (diff)

Not Working for Version 4.0.12, 4.1.2, 4.1.4

Host: Debian 6, Ubuntu 10.04 LTS Guest: I test with opensuse 11.4, ubuntu 11.04, debian 6, Linux Mint 11, Mandriva 2011, zenwalk 7.0 .

-> all with the the same symptom

You can only copy for one time between two guest and then the clipboard wont refresh with a new copy command. Guest clipboard configuration is bi-directional.

This is an error you can find similar in many previous versions with linux host systems.

kind regards

Change History

comment:1 Changed 3 years ago by michael

Is this copy and paste between two guests or between host and guest? If the first, does copy and paste between host and guest still work, and does it stop for all guests when it stops for one?

comment:2 Changed 3 years ago by mschelm

The problem occures always between 2 Guests. Bediectinal copy between host and guests works fine.

comment:3 follow-up: ↓ 6 Changed 3 years ago by michael

Not immediately reproducible here. Host: Ubuntu 11.10 current, guests Ubuntu 11.10 current and Fedora 16 more or less current. VirtualBox and Guest Additions are current development builds, although hardly anything has changed (if at all) in the clipboard code since 4.0. Could you please provide me with a more detailed recipe in case I am doing something differently to you?

comment:4 Changed 3 years ago by vanto

I have the same scenario happening here when copying from the Host to the guest running in GUI and the clipboard is available for some VMs and not for the others. I have the following setup: Host > win 7 64bit Guest > Win 2008 R2 64 bit Vbox Version > 4.1.4 Please rectify

Thank you

comment:5 Changed 3 years ago by michael

Vanto, are you sure this is the same issue? My understanding was that mschelm was unable to copy and paste between two virtual machines, but that host to any given guest and back worked fine. If not, you might want to open a different ticket, possibly adding a reference to it on ticket #5266.

Both of you might try running VirtualBox with the environment variable "VBOX_RELEASE_LOG=+shared_clipboard.e.l.f" set, which will cause lots of information about clipboard transactions to be written to the virtual machine log file on the host, and then trying to reproduce your problems quickly while checking the time entry in the log file before and after.

Vanto, you could see if stopping and re-starting VBoxTray on your Windows guests helps.

mschelm, on your Linux guests you could stop the "VBoxClient --clipboard" process on your Linux guests and restart it (as your user in your X session) as "VBoxClient --clipboard --nodaemon" with the environment variables "VBOX_RELEASE_LOG_DEST=file=vbox.log", "VBOX_RELEASE_LOG=all.e.l.f" and "VBOX_RELEASE_LOG_FLAGS='timeprog thread'" set. This will produce a similar log file called vbox.log for the guest in the current directory. When you are finished you can stop VBoxClient --clipboard again and restart it without the --nodaemon parameter, so that it goes back into the background.

comment:6 in reply to: ↑ 3 Changed 3 years ago by mschelm

Replying to michael:

Not immediately reproducible here. Host: Ubuntu 11.10 current, guests Ubuntu 11.10 current and Fedora 16 more or less current. VirtualBox and Guest Additions are current development builds, although hardly anything has changed (if at all) in the clipboard code since 4.0. Could you please provide me with a more detailed recipe in case I am doing something differently to you?

Addition: My host os was 64Bit sysem and all my guests are 32Bit ones.

Today, I test your constellation. I use a new installed ubuntu 11.04 32-bit as host and reuse my guest debian 6, ubuntu 10.04 and ubuntu 11.04 (all 32-bit). The same error occures: After a while of copy and paste beetween each other circa 6 times the shared clipboard chrashed. That meens that the clipboard doesn't refresh in the target guest. I see the old clipboard entry again, but I did copy another string from the source guest. When I change the direction mostly the error disappeared for one operation or two and appear again. Conclusion: The error is similar to the 64Bit installation.

comment:7 follow-up: ↓ 8 Changed 2 years ago by viniciusnz

Hi,

I'm using Host -> Windows 7 64bit, Guest -> Ubuntu 11.10 32bit with xubuntu. I can copy from guest -> host fine and continuously, but can only copy once from host -> guest. If I execute VBoxClient --clipboard I can copy another time from host -> guest, but afterwards it fails, until I execute the command again.

It seems VBoxClient is stopping monitoring my host clipboard after copying the first time. Could you please verify?

Best,

comment:8 in reply to: ↑ 7 Changed 2 years ago by michael

Replying to viniciusnz:

I'm using Host -> Windows 7 64bit, Guest -> Ubuntu 11.10 32bit with xubuntu. I can copy from guest -> host fine and continuously, but can only copy once from host -> guest. If I execute VBoxClient --clipboard I can copy another time from host -> guest, but afterwards it fails, until I execute the command again.

It seems VBoxClient is stopping monitoring my host clipboard after copying the first time. Could you please verify?

If you need to restart VBoxClient then it is likely that it is crashing. Doing "ps aux | grep VBoxClient" will tell you if it is still running or not.

comment:9 follow-up: ↓ 10 Changed 2 years ago by rincewind23

I have VirtualBox 4.1.4 on Windows 7 (64bit) host with Windows 2008 R2 (64bit) guest. The clipboard doesn't work here either, but killing VBoxTray.exe on the guest makes it work again.

comment:10 in reply to: ↑ 9 Changed 2 years ago by michael

Replying to rincewind23:

I have VirtualBox 4.1.4 on Windows 7 (64bit) host with Windows 2008 R2 (64bit) guest. The clipboard doesn't work here either, but killing VBoxTray.exe on the guest makes it work again.

I'm afraid that this is off-topic for this ticket, as the clipboard code is very system-specific, so Windows clipboard issues are not likely to be related to X11 ones. Could you create a new ticket for it? Lots of other tickets discuss this, but none of them are really to the point. Basic information to your issue is that we use the Windows 2000/XP clipboard viewer functionality to monitor the clipboard in Windows hosts and guests, and that this will stop working as soon as any other application on the host/guest tries to use it improperly. So your issue is most likely due to some other application on your guest listening to the clipboard too and not sharing it. If you can find which application that is and remove it you should solve your problem.

comment:11 follow-up: ↓ 12 Changed 2 years ago by therealmarv

I also had problems with Host (Windows 7 32bit) to Guest (Ubuntu 32Bit) Copy&Paste only working one time or the first time. I also reinstalled guest additions which do not had any effect (4.1.8) . This solution worked for me:

  1. Deinstall VBoxGuestAdditions. Go to directory /opt/VBoxGuestXXXX and run: sudo ./uninstall.sh
  2. Reboot
  3. Install guest additions again.

It's strange that doing this uninstall and reinstall worked. But just reinstalling VBoxGuestAdditions did not solved the problem.

comment:12 in reply to: ↑ 11 Changed 2 years ago by michael

Replying to therealmarv:

I also had problems with Host (Windows 7 32bit) to Guest (Ubuntu 32Bit) Copy&Paste only working one time or the first time. I also reinstalled guest additions which do not had any effect (4.1.8) . This solution worked for me:

  1. Deinstall VBoxGuestAdditions. Go to directory /opt/VBoxGuestXXXX and run: sudo ./uninstall.sh
  2. Reboot
  3. Install guest additions again.

It's strange that doing this uninstall and reinstall worked. But just reinstalling VBoxGuestAdditions did not solved the problem.

Possibly restarting "VBoxClient --clipboard" in the guest would also help. If you are interested in taking a closer look, you could restart it as "VBoxClient --clipboard --nodaemon" with the environment variables "VBOX_RELEASE_LOG=+all.e.l.l2.l3.f" and "VBOX_RELEASE_LOG_DEST=file=~/clipboard.log" set, to create a log file for clipboard activity in your (guest account) home directory. This is most likely due to a host issue (another host application not playing nicely) though.

comment:13 Changed 2 years ago by PK

Running into the same issue with VirtualBox 4.1.8 in Windows 7 64-bit with guest OS Ubuntu 11. I couldn't use the shared clipboard and I couldn't copy/paste between host and guest OS and vice versa.

The following steps fixed my issue as well.

In the Guest OS

  1. De-install VBoxGuestAdditions. Go to directory /opt/VBoxGuestXXXX and run: sudo ./uninstall.sh
  2. Reboot
  3. Install guest additions again

Thank you, PK

comment:14 Changed 20 months ago by kaipanoi

$ cat vbox.log 
vboxClientSetSignalHandlers: 
00:00:00.001 main     vboxClientSetSignalHandlers: returning
00:00:00.001 main     vboxClipboardConnect: 
00:00:00.001 main     Initializing X11 clipboard backend
00:00:00.001 main     ClipStartX11: 
00:00:00.006 SHCLIP   Shared clipboard: starting shared clipboard thread
00:00:00.006 main     Error connecting to host. rc=VERR_HGCM_SERVICE_NOT_FOUND
00:00:00.006 main     vboxClipboardConnect: g_ctx.client=0 rc=VERR_HGCM_SERVICE_NOT_FOUND
00:00:00.006 main     ClipboardService::run: guest clipboard service terminated abnormally: return code VERR_HGCM_SERVICE_NOT_FOUND

Re-installed, not better. M$ vms share the clipboard with each other and the host well. This Linux guest will not. Tried Fedora and Ubuntu.

comment:15 Changed 19 months ago by michael

  • Description modified (diff)

kaipanoi: looks like the clipboard is disabled for that VM.

comment:16 Changed 18 months ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from clipboard not working to clipboard not working -> configuration issue

Feel free to re-open this if that turns out not to have been the issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use