VirtualBox

Ticket #9683 (new defect)

Opened 3 years ago

Last modified 3 years ago

Bug in versions 4.1.x?? Strange error with Delphi 7 app after version 4.1.x upgrade

Reported by: Speaker Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.0 Keywords: Delphi, Stream read error
Cc: Guest type: Windows
Host type: Windows

Description

Bug in versions 4.1.x?? Strange error with Delphi 7 app

Postby Speaker » 3. Oct 2011, 20:20 Hi! something rare happens when i update from version 4.0.12 to version 4.1.x Host: Windows 7 ultimate 64b. Guest: Windows XP sp2 32b. I had a vm with a development enviroment with Delphi 7. I run the same machine, with the same disk (i copied it for test this issue), in my notebook (i5, 4gb, video Intel HD Graphics) and in my desktop pc (i5, 8gb, video geforce gts 250) In notebook, virtual box version is 4.0.12, y pc 4.1.4 (but i try with 4.1.0 and the same error occurs). When i execute and exe compiled from my application code, in notebook runs ok, in pc crashed with an "Stream Read Error".

I run the application from the IDE and the lines of code reaching the error are:

      TPicture.RegisterFileFormat('xI', '', TIcon);
      TPicture.RegisterFileFormat('xL', '', TBitmap);
      TPicture.RegisterFileFormat('xF', '', TJpegImage);
      Application.Icon.LoadFromFile(IncludeTrailingPathDelimiter(CarpetaDeEjecucion) + ChangeFileExt(ExtractFileName(Application.ExeName), '.xI'));
      imLogo.Picture.LoadFromFile(IncludeTrailingPathDelimiter(CarpetaDeEjecucion) + ChangeFileExt(ExtractFileName(Application.ExeName), '.xL'))
      imPrincipal.Picture.LoadFromFile(IncludeTrailingPathDelimiter(CarpetaDeEjecucion) + ChangeFileExt(ExtractFileName(Application.ExeName), '.xF'));

Is not a problem with the code (although it may be better). The same code, same vm configuration, same vdi works fine in notebook with version 4.0.12. In PC with version 4.1.4 do not work. But... in PC i have downgrade to 4.0.8, try... fine... update to 4.0.12, try... fine... update to 4.1.0... get the error... I have corresponding (same version) extended pack installed (an updated as i try with different versions). By the way... this is the last thing i think... i am blaming my underlying hardware... update geforce drivers a time ago... but now... with same geforce drivers, but version 4.0.12, it works fine again

The same exe (compiled in pc) runs without any problem in notebook, or host OS. But from the IDE or as an standalone exe, it reach the exception.

My video memory is set to 128Mb, with 1 monitor, without remote screen. I try with different combinations of HW acceleration (3D, 2D), but still get to the error.

It seems to be some change (bug) on version 4.1.x

Thanks you all for any suggestion or solution... (i actually have working version 4.0.12 installed, but i will probably want to update in a future)!

Change History

comment:1 Changed 3 years ago by Perryg

Adding comment to follow this ticket.

Comments are also here:  https://forums.virtualbox.org/viewtopic.php?f=6&t=45102

comment:3 Changed 3 years ago by Speaker

Punctually, i have found the origin of the issue... still a change made from version 4.1.x that do not work properly.

 https://forums.virtualbox.org/viewtopic.php?f=6&t=45102&p=204080#p203991

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use