Ticket #4587 (closed defect: obsolete)

Opened 9 years ago

Last modified 23 months ago

3D Acceleration & WPF Development

Reported by: Snotface Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.0.2 Keywords: WPF
Cc: Guest type: other
Host type: other

Description (last modified by misha) (diff)

I know that 3D Accel is publicised at (Beta) and therefore unstable, but i was requested to create a ticket, so here is a direct quote from the forum as well as my log file. Please note that VirtualBox is not crashing, it merely does as outlined below. Host Vista 64, Guest Vista 32.

Enabling 3D Acceleration nerfs WPF development on the guest (VS 2008, .NET 3.5). Creating a new WPF application doesn't render any controls in the design window. It also causes an <Exception in HRESULT: 0x88980406> of that control (i was trying to edit a Grid). It results in you not even being able to edit the properties of the control.

I've done some investigation and found this on the VMWare forum: <Quote> OK. We've reproduced this internally and have a fix we plan to make available in the next Fusion 2.0 release. The problem was that WPF apps (along with iTunes and a few other programs) combine 2D and 3D rendering in the same window. When 3D was enabled, Fusion's SVGA driver had an issue where the 2D and 3D rendering would both try to update the same area of the guest framebuffer at the same time, causing the rendering issues you described. Sorry for the inconvenience, and stay tuned for this and lots of other fixes. </Quote>

I'm not sure if VirtualBox's problem is related, but disabling 3D acceleration for the guest fixes the problem, but obviously you won't be able to combine WPF and 3D applications together at the moment.


VBox.log Download (61.0 KB) - added by Snotface 9 years ago.
Log file. Though VB isn't crashing.

Change History

Changed 9 years ago by Snotface

Log file. Though VB isn't crashing.

comment:1 Changed 9 years ago by empee584

This problem indeed is causing 3D software built with WPF to abort with strange error messages.. An example of this is SolidWorks 2009 which fails with


Stopped working

Problem signature:

Problem Event Name: CLR20r3 Problem Signature 01: sldworks.exe Problem Signature 02: Problem Signature 03: 48c60fc1 Problem Signature 04: PresentationFramework Problem Signature 05: Problem Signature 06: 4a174fbc Problem Signature 07: 624f Problem Signature 08: e1 Problem Signature 09: System.Windows.Markup.XamlParse OS Version: 6.1.7260. Locale ID: 2057

when 3d acceleration is enabled, but works fine (no display problems or anything) without acceleration. BTW this same program was working (3d accelerated) before with a 2.x version, but had obscure redrawing glitches (ticket:3193, ticket:3068)..

comment:2 Changed 8 years ago by empee584

IMHO this bug is preventing lots of companies and professionals from the engineering industry to make use of VirtualBox, because these CAD programs are essential to their work..

To bring this forward a bit, here's a minimal test case, including source files: Just tried it and with 3D acceleration enabled all included samples crash on startup (in System.Windows.Markup.XamlParse of course), without acceleration they work. This is with 2D acceleration activated in both cases.

comment:3 Changed 8 years ago by empee584

Forgot to add: this is with 3.1.2 of course, but only the OP can change the version..

comment:4 Changed 8 years ago by empee584

.. and just checked, it's still present in 3.1.4_beta1, too.

comment:5 Changed 8 years ago by csizo

is there or will there be any update on the bug?
It is still present in version 3.2.4. Host Ubuntu 10.04 x32, Guest Windows XP x32.

comment:6 Changed 8 years ago by leonid

There's a work in progress which should fix this issue. For now you can just disable 3d accel if you intend to work with VS etc.

comment:7 Changed 8 years ago by skolima

This still does not work in VB 3.2.8 - starting Visual Studio 2010 shows a transparent windows (VS 2010 usus WPF for UI).

comment:8 Changed 7 years ago by hummerd

Sill does not work in 4.0.0.

comment:9 follow-up: ↓ 10 Changed 7 years ago by skmzy

Still does not work in 4.0.2.

comment:10 in reply to: ↑ 9 Changed 7 years ago by rsbarro

Replying to skmzy:

Still does not work in 4.0.2.

Still does not work in 4.0.4 either. Cannot run VS.NET 2010 with 3D acceleration enabled. It would be tremendous if someone could address this issue. VS.NET 2008 was great in VirtualBox, but 2010 drags, presumably because of the lack of 3D support.

comment:11 follow-up: ↓ 12 Changed 7 years ago by leonid

Should be fixed in 4.1.

comment:12 in reply to: ↑ 11 Changed 7 years ago by rsbarro

Is there a rough date for when 4.1 is scheduled to be released?

comment:13 in reply to: ↑ description Changed 7 years ago by Snotface

Is there any feedback on this problem? VS2010 is now the norm and with Phone 7 being Silverlight-based, this problem is a major stumbling block.

comment:14 follow-up: ↓ 15 Changed 7 years ago by skmzy

Is fixed in 4.1?

comment:15 in reply to: ↑ 14 Changed 7 years ago by Snotface

Replying to skmzy:

Is fixed in 4.1?

I haven't tried 4.1 yet. Will probably try over the weekend. I hope it's fixed, though no mention in the Change Logs. I guess there aren't too many VS2010/Silverlight developers that want to use VirtualBox.

comment:16 Changed 7 years ago by hummerd

It seems like it is fixed in 4.1. VS2010 and other WPF applications work fine with 3d acceleration enabled.

comment:17 Changed 7 years ago by CrazyCasta

Just so that people don't think this issue is completely fixed. I am still getting the same exception with SolidWorks 2010-2011 with VirtualBox 4.1.0 on gentoo. It starts up, I click on the new icon and then it crashes and gives me the option to report the crash, from which I have the crash log attached. The guest operating system is Windows 7 SP1. SolidWorks 2010-2011 is SP5.

comment:18 Changed 7 years ago by CrazyCasta

Nevermind, after fighting with this problem for about 2 hours and having a 100% repeatable method of crashing SolidWorks (name clicking on the new icon), it isn't crashing anymore. I have no idea what I did, as far as I know I didn't do anything.

comment:19 Changed 7 years ago by Snotface

After initial tests it does seem as if this is working in 4.1, though there is no mention of it in the change log.

comment:20 Changed 7 years ago by CrazyCasta

Just to further report my issue. The WPF driver seems to cause other issues. While SolidWorks does work (if I can manage to boot the machine), several other problems related to base Windows usage occur. I have documented the problems in #9330. As far as I can tell, this is not the same issue (not causing the same error message).

comment:21 Changed 7 years ago by empee584

Btw, if someone just cares basically for solidworks (or probably some other cad program?) - recent versions of WiNE run that amazingly well, see f.e.

comment:22 Changed 6 years ago by misha

  • Description modified (diff)

As a work-around for now you might try using Windows Vista+ guests with WDDM driver installed and Aero theme enabled in guest OS.
WPF-based applications should work OK in that environment. Here are the test builds which include recent fixes for VBox 3D functionality to make WPF-based applications work in guest with Aero enabled for several hosts:

Linux 32:
Linux 64:

Note that you'd need to update guest additions also.

Last edited 6 years ago by misha (previous) (diff)

comment:23 follow-up: ↓ 24 Changed 6 years ago by neuroticmonk

This appears to work correctly in 4.1.10, but only if Aero is enabled. With Aero disabled, Visual Studio 2010 works just fine, but the WPF applications I develop (.NET 4.0) fail to render correctly. (Portions of them don't actually get drawn on the screen so it's like having transparent windows.)

comment:24 in reply to: ↑ 23 Changed 6 years ago by misha

Replying to neuroticmonk:

This appears to work correctly in 4.1.10, but only if Aero is enabled.

This is a known issue. This will take quite some time to fix the Aero-disabled case.

comment:25 Changed 23 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use