VirtualBox

Ticket #3068 (new defect)

Opened 5 years ago

Last modified 3 years ago

Screen redrawing problem in SolidWorks2008 with opengl

Reported by: denisb Owned by:
Priority: major Component: 3D support
Version: VirtualBox 2.1.0 Keywords: Solidworks OpenGL
Cc: Guest type: Windows
Host type: Linux

Description

With NVidia 6800 : When SolidWorks 2008 runs in a XP box with 3D OpenGL activated, the screen is not correctly redrawn when the mouse is over any other part of the application except the graphics windows itself. The background image of SW window is then displayed. Only a small rectangle under the cursor is refreshed, but rotating the part or zooming refreshes correctly the window.

Sporadic application freezes when movingg or redimensionning windows

With Intel i865 : Solidworks graphics windows are not refreshed, and the application freezes.

Freely downloadable SolidWorks viewer has the same behavior

Change History

comment:1 Changed 5 years ago by john.m.lang

I am also experiencing this problem.

VirtualBox 2.2.0 on Ubuntu Linux 8.10 with latest updates. Video Hardware: ATi Radeon HD 2400 XT with driver 8.54.3 X.org server version: 1.5.2

Guest: Windows XP SolidWorks 2006 SP4.1 Educational Edition

Disabling 3D acceleration in VirtualBox causes the application to behave as expected. Note that SolidWorks uses OpenGL and not DirectX.

comment:2 Changed 5 years ago by keepiru

Confirmed: SolidWorks 2006 on XP on 2.1.4_OSE on Ubuntu 9.04, with Guest Additions 2.0.0, 2.0.8, 2.1.4, and 2.2.2.

However, I found a workaround: Downgrade VirtualBox Guest Additions to 1.6.6, and everything works great.

comment:3 Changed 5 years ago by frank

Are you 100% sure that you successfully installed the additions 2.0.0 and 2.0.8? Please make sure by hovering the guest try icon. I assume that you simply were not able to install these older guest additions. And, of course, 3D/OpenGL support is supported starting with release 2.1.0 so if there is some emulation problem this wouldn't occur with older guest additions.

comment:4 Changed 5 years ago by keepiru

Double checked, and confirmed. Upgrading to 2.0.8 (verified by hovering) breaks it. Downgrading to 1.6.6 (with warnings about overwriting newer versions, and hover-verified) fixes it.

This is all with SolidWorks' built-in software OpenGL, so OpenGL support shouldn't matter. SolidWorks won't deign to run hardware OpenGL without a blessed (Quadro or FireGL) card, so even on 2.2.2 the checkbox stays grayed out (since the Sun Microsystems VirtualBox Graphics Adaptor, as it's reported in GLDiag, isn't whitelisted).

comment:5 Changed 5 years ago by keepiru

Oh, I forgot to mention: It works fine with 2.2.2 with the VirtualBox 3D acceleration checkbox unchecked.

I have no idea why this matters when I'm running software GL. SolidWorks does some kind of probe to see if the checkbox should be grayed or not. Perhaps that fouls something up?

comment:6 in reply to: ↑ description Changed 5 years ago by sir.charleston

I have the same Problems using VirtualBox 3.02, 3.00 and earlier versions. I can use software OpenGL when the 3D-acceleration box is unchecked. It is very slow though...

Guest OS is Windows XP SP3, I tried Solidworks 2008 & 2009. Host OS is OpenSuse 11.1 64 bit, tried Desktops KDE, Gnome, XFCE with and w/o compiz. No change. Video Adapter is a Nvidia GeForce 7300 LE with current nvidia-drivers.

A collegue has almost the same (physical&OS) machine and for him OpenGL works perfectly. But his virtual machine wouldn't run OpenGL correctly on my computer. GlxGears seems to run well.

So, any clues where I could start off?!

comment:7 Changed 4 years ago by ktf

I can confirm this bug occuring in a mild form on both VirtualBox 3.0.8 and 3.0.10 when using SolidWorks Student kit 2008-2009. Quite often, when working on a model, parts of the screen blacks out or show an item in the buffer, such as a recent dialog box or my desktop wallpaper. When clicking or moving the mouse, the screen is redrawed right, but when trying to perform the same action again, the problems araise in exactly the same way. This is with acceleration turned on, turning it off solves the problem, but is not really a nice way to solve it as performance drops.

Within a week I'll try SolidWorks 2009

comment:8 Changed 3 years ago by Technologov

VirtualBox 4.0 has many improvements in the OpenGL area. Can you try it ?

-Technologov

comment:9 Changed 3 years ago by john.m.lang

I am currently running VirtualBox 4.0.0 on a Ubuntu 10.04 host with latest updates and using an ATi HD 2400 XT with the proprietary Catalyst 10.12 driver. I am running SolidWorks 2009 SP2.1 in a Windows XP guest using the latest additions with the 3D driver installed in safe-mode.

When 3D acceleration is disabled, SolidWorks runs as expected.

When 3D acceleration is enabled, SolidWorks crashes just after starting with the error: "SldWorks has encountered a problem and needs to close. We are sorry for the inconvenience. If you were in the middle of something, the information you were working on might be lost."

comment:10 Changed 3 years ago by arsenix

This problem still exists in Virtualbox 4.1.0. Running Solidworks 2009. I am running Ubuntu 11.04 with latest stable nvidia driver.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use