Ticket #9330 (closed defect: obsolete)

Opened 7 years ago

Last modified 18 months ago

WDDM driver causes blank screen on login

Reported by: CrazyCasta Owned by:
Priority: major Component: WDDM
Version: VirtualBox 4.1.0 Keywords: WDDM
Cc: Guest type: Windows
Host type: other

Description (last modified by misha) (diff)

After upgrading to VirtualBox 4.1.0 and upgrading guest box additions, using the WDDM driver (answering no to the 3D question), Windows gives me a blank screen after logging in. I am using Windows 7 x86. I was previously using VirtualBox 4.0.12 (as well as other previous versions) and associated guest addition 3D drivers (previous versions being installed in safe mode of course).

I can get past the problem by saving the state and then restarting the VM. In this case, I get a crash message from Desktop Window Manager and the graphics are rather strange. I'm not sure if the strangeness of the graphics is related to the WDDM driver or the fact that I saved the state and then restored it.

Change History

comment:1 Changed 7 years ago by msdobrescu

I confirm, using Windows 7 Ultimate x64.

comment:2 Changed 7 years ago by michalu

I confirm. Ubuntu 11.04 amd64 host, Win7-64 guest. After the latest VBox update to 4.1.2 I installed the Aero support from guest additions. After that, as standard user I get a black screen. As admin I can work almost as usual, but IE9 is blank/black as well. Other browsers run. I tried both other possibilities, i. e. installed no 3D driver at all and in safe mode classic 3D driver. Much worse, Windows did not start at all.

comment:3 Changed 7 years ago by frank

Any change with VirtualBox 4.1.4 (update the Additions)?

comment:4 Changed 7 years ago by oreru

I confirm Windows 7 Ultimate x64 on 10.6 OsX host. Also, login is black even after clean desinstall and reinstall of guest box additions _without_ WDDM drivers.

comment:5 Changed 7 years ago by oskar.berggren

Windows 7 Ultimate 32bit on Ubuntu 10.04 32bit. Working fine on 4.1.2 without 3D support. After upgrade to 4.1.4, I get the following weird behaviour, in the order attempted:

No 3D-support installed and 3D-support DISABLED in VBOX: Upgrade guest additions (GA) to 4.1.4. Reboot guest. Black screen when guest login should appear.

Use safe mode to remove GA.

WDDM-driver installed and 3D-support ENABLED in VBOX: Install GA with WDDM 3D. Shutdown guest. Enable 3D acceleration. Boot guest. Login screen appear but goes black after login. Ctrl-del correctly shows the windows control menu but going back to normal mode it's just black.

WDDM-driver installed and 3D-support DISABLED in VBOX: Shutdown guest. Disable 3D acceleration. Boot guest. Graphics seems to work properly.

No 3D-support installed and 3D-support DISABLED in VBOX: (repeat attempt) Uninstall GA. I think I did a reboot here. Then reinstall without WDDM. Reboot guest. Black screen when guest login should appear.

No 3D-support installed and 3D-support ENABLED in VBOX: Shutdown guest, enable 3D acceleration. Boot guest. Login, start menu, desktop, seems to work properly.

No 3D-support installed and 3D-support DISABLED in VBOX: (repeat attempt) Shutdown guest, disable 3D acceleration. Boot guest. Login, start menu, desktop, seems to work properly.

So at first it seemed weird and like some settings were reversed. However, because of the final attempt were it suddenly started working with no-wddm + no-3d again, I suspect that what was needed was a complete shutdown of the VM after the GA was installed/upgraded. Not just a guest reboot.

comment:6 Changed 7 years ago by misha

  • Component changed from 3D support to WDDM

comment:7 Changed 6 years ago by misha

  • Description modified (diff)

We've made some fixes recently that solved black screen issues we saw here. Assuming you have Linux hosts here are test builds with the fixes included:

Linux 32:
Linux 64:

Note that you'd need to update guest additions also.
Let me know whether it solves the black screen issues for you.

comment:8 Changed 5 years ago by misha

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing. Please give a try VBox 4.3 and re-open if needed.

comment:9 Changed 4 years ago by QuadraQ

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm having exactly the same symptoms using 4.3. Specifically Windows 7 Pro 32-bit (running on Win 7 Ultimate 64-bit host OS) upgrading from guest box additions 4.3.6 with Direct3D support installed to guest box additions 4.3.8 without Direct3D support. Uninstalling the 4.3.6 guest box additions first and restarting and then installing 4.3.8 doesn't work either (same black screen instead of login screen).

Only if I install the 4.3.8 guest additions with the Direct3D support checked, does the upgrade succeed and I get to the login screen normally.

comment:10 Changed 21 months ago by aeichner

  • Status changed from reopened to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

comment:11 Changed 18 months ago by PSF_


I have a similar issue with Virtualbox 5.1.4r110228 (Qt5.5.1).

Host: Windows 10 Guest: Windows 7 - Two virtual monitors, with the second how main.

At boot time, the login dont show, the monitor 1 show blank but with the correct size, but the second show blank too with default size. If I pause de VM the 2sd monitor show the correct preview, when I quit the pause it show blank again.

If I click on 2sd monitor and enter the password then do login ok and when I resize de 2sd monitor windows, it repair itself showing the desktop ok.

The VM configuration is:



Las Palomas . Desarrollo Tipo SO

Windows 7 (64-bit)


Memoria base

2560 Procesador(es)

8 Límite de ejecución

100 Orden de arranque

Óptica, Disco duro VT-x/AMD-V

Habilitado Paginación anidada

Habilitado Interfaz de paravirtualización



Memoria de vídeo

256 Pantallas

2 Aceleración 3D

Habilitado Aceleración de video 2D

Habilitado Servidor de escritorio remoto



Controlador: IDE

IDE primario maestro

Las Palomas . Desarrollo.vdi (Normal, 50,00 GB) IDE primario esclavo (Unidad óptica)



Controlador de anfitrión

Windows DirectSound Controlador

Audio Intel HD


Adaptador 1

Intel PRO/1000 MT Desktop (Adaptador puente, Qualcomm Atheros AR956x Wireless Network Adapter)

 Carpetas compartidas

Carpetas compartidas



 Runtime attributes

Resolución de pantalla 1

1562x985x32 @1600,-150 Resolución de pantalla 2

1600x835x32 @0,0 Tiempo de actividad

0d 00:04:30 Modo portapapeles

Bidireccional Modo arrastrar y soltar

Bidireccional VT-x/AMD-V

Activo Paginación anidada

Activo Ejecución sin restricciones

Activo Interfaz de paravirtualización

Hyper-V «Guest Additions»

5.1.4 r110228 Tipo de SO invitado

Hyper-V Puero del servidor de escritorio remoto

No disponible

 Network statistics

Adaptador 1

Datos transmitidos

94390 B Datos recibidos

433123 B

 Storage statistics

Controlador: IDE

IDE primario maestro

Transferencias DMA

42575 Transferencias PIO

2968 Datos leídos

1045084672 B Datos escritos

55026688 B

IDE primario esclavo

Transferencias DMA

0 Transferencias PIO

351 Datos leídos

0 B Datos escritos

0 B

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use