VirtualBox

Ticket #4101 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Segfault in VBoxDD.so with Windows guest after some time

Reported by: yagood Owned by:
Priority: critical Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I'm using 32-bit Arch Linux (kernel 2.6.29) with 32-bit Windows XP guest to run a HTTP proxy server inside the VM and proxy Linux Firefox traffic through it.

Starting with VirtualBox 2.2.2 I get a segfault after some time (several minutes, sometimes seconds) of web browsing on the host.

Below is the stack trace obtained by attaching gdb to VirtualBox process.

Program received signal SIGSEGV, Segmentation fault. [Switching to Thread 0xb0a6cb70 (LWP 28797)] 0xb331a974 in tcp_input () from /opt/virtualbox/VBoxDD.so (gdb) bt #0 0xb331a974 in tcp_input () from /opt/virtualbox/VBoxDD.so #1 0xb3310d9a in slirp_select_poll () from /opt/virtualbox/VBoxDD.so #2 0xb32fe0b1 in ?? () from /opt/virtualbox/VBoxDD.so #3 0xb5903d5f in ?? () from /opt/virtualbox/components/VBoxVMM.so #4 0xb7c35552 in rtThreadMain () from /opt/virtualbox/VBoxRT.so #5 0xb7c59ae6 in ?? () from /opt/virtualbox/VBoxRT.so #6 0xb7f136bc in start_thread () from /lib/libpthread.so.0 #7 0xb7d9fffe in clone () from /lib/libc.so.6

Change History

comment:1 Changed 5 years ago by yagood

Back trace properly formatted:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb0a6cb70 (LWP 28797)]
0xb331a974 in tcp_input () from /opt/virtualbox/VBoxDD.so
(gdb) bt
#0  0xb331a974 in tcp_input () from /opt/virtualbox/VBoxDD.so
#1  0xb3310d9a in slirp_select_poll () from /opt/virtualbox/VBoxDD.so
#2  0xb32fe0b1 in ?? () from /opt/virtualbox/VBoxDD.so
#3  0xb5903d5f in ?? () from /opt/virtualbox/components/VBoxVMM.so
#4  0xb7c35552 in rtThreadMain () from /opt/virtualbox/VBoxRT.so
#5  0xb7c59ae6 in ?? () from /opt/virtualbox/VBoxRT.so
#6  0xb7f136bc in start_thread () from /lib/libpthread.so.0
#7  0xb7d9fffe in clone () from /lib/libc.so.6

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3976.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use