VirtualBox

Ticket #3124 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Guru meditation (MM_RAM_FLAGS_CREFS_PHYSEXT)

Reported by: r007 Owned by:
Priority: major Component: VMM
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Possibly related to #3047.

Restarting X three times reproducibly causes vbox to meditate.

Attached are a screenshot of the process, and a matching VBox.log.

Attachments

VBox.log Download (200.2 KB) - added by r007 5 years ago.
VBox logfile of meditation
VBox.png Download (24.5 KB) - added by r007 5 years ago.
Screenshot of restarting gdm.
VBox.2.log Download (187.5 KB) - added by ttmrichter 5 years ago.
VBox.3.log Download (193.8 KB) - added by ThatFoxyKid 5 years ago.
Crash log for Guru Meditation MM_RAM_FLAGS_CREFS_PHYSEXT (Zenwalk 5.2 guest)

Change History

Changed 5 years ago by r007

VBox logfile of meditation

Changed 5 years ago by r007

Screenshot of restarting gdm.

comment:1 Changed 5 years ago by sandervl73

  • Summary changed from restarting Xorg several times causes guru meditation to restarting Xorg several times causes guru meditation (MM_RAM_FLAGS_CREFS_PHYSEXT)

comment:2 Changed 5 years ago by sandervl73

#3131 was marked as a duplicate of this one.

comment:3 Changed 5 years ago by sandervl73

Same for #3158.

comment:4 Changed 5 years ago by sandervl73

  • Host type changed from Mac OS X to other

comment:5 Changed 5 years ago by sandervl73

  • Guest type changed from Linux to other

comment:6 Changed 5 years ago by tvo

From #3131:

One of my VirtualBox virtual machines had this same problem last friday while it was performing a rather intensive computing task in MATLAB.

I'm running VirtualBox 2.1.2 (from the repository linked to on the Download page) on an Ubuntu (8.04) Linux host (Linux 2.6.24-23-generic #1 SMP i686 GNU/Linux), an Intel(R) Core(TM)2 Duo CPU T5750 @ 2.00GHz with 3G RAM.

The guest OS is Windows XP SP3. The virtual machine had 1G RAM. At the time of the crash 2 virtual machines with 1G RAM were running. Both were using the same base disk image, the crashed one was differencing due to snapshot, and it's base disk image attached (with the blue star) to the other one too as differencing disk. Both VMs were started using the GUI.

At the time of the crash probably both machines were doing computations in MATLAB at 100% CPU and 250-750 MB RAM usage.

I didn't do any X restarts for I wasn't even near my machine at the time of the crash.

Log file:

 http://www.virtualbox.org/attachment/ticket/3131/TUD%202008%20Q1-2009-01-23-18-21-42.log

comment:7 Changed 5 years ago by sandervl73

  • Summary changed from restarting Xorg several times causes guru meditation (MM_RAM_FLAGS_CREFS_PHYSEXT) to Guru meditation (MM_RAM_FLAGS_CREFS_PHYSEXT)

comment:8 Changed 5 years ago by ttmrichter

Same problem running a Slackware 12.2 guest under Ubuntu 8.04. The guest worked fine under VB 2.1.0, started failing after upgrading to 2.1.2. Log file attached.

Changed 5 years ago by ttmrichter

comment:9 Changed 5 years ago by sandervl73

  • Priority changed from minor to major
  • Component changed from guest additions to VMM

#3252 is a duplicate

comment:10 Changed 5 years ago by sandervl73

Can you reproduce this easily? If so, would you be willing to try out a test build?

comment:11 Changed 5 years ago by ThatFoxyKid

I am able to reproduce this easily, whenever the guest operating system exits the XServer, ie Ctrl-Alt-Backspace, Logout, Reboot, Shutdown. Occurs whether in desktop environment or in GDM.

My guest is Linux Zenwalk 5.2 (Slack derivative) kernel 2.6.27.10. running on Linux Zenwalk 5.2 kernel 2.6.27.10

I thought it was related to 3D acceleration but I disabled that and it still crashes.

My desktop environment (XFCE) restores to strange "default" settings without a main panel, and custome desktop background absent, which is probably a result of xfce-session terminating unexpectedly.

I'd be willing to try a test build. Will attach my log.

Changed 5 years ago by ThatFoxyKid

Crash log for Guru Meditation MM_RAM_FLAGS_CREFS_PHYSEXT (Zenwalk 5.2 guest)

comment:12 Changed 5 years ago by r007

For me, this is fixed in 2.1.4, see related ticket in the summary.

comment:13 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

comment:14 Changed 5 years ago by ThatFoxyKid

Confirmed squashed in 2.1.4. Thanks so much!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use