VirtualBox

Ticket #3047 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

vboxvideo produces garbled screen -> obsolete

Reported by: r007 Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 2.1.0 Keywords: vboxvideo
Cc: Guest type: Linux
Host type: Mac OS X

Description

Upon switching from vesa to vboxvideo driver in a linux guest, X video becomes garbled. I will be attaching a screenshot and X log file.

Attachments

garbled.jpg Download (181.3 KB) - added by r007 5 years ago.
garbled X logon screen
Xorg.0.log Download (21.9 KB) - added by r007 5 years ago.
Xorg logfile of X server startup
garble-correctsize.jpg Download (187.7 KB) - added by r007 5 years ago.
garbage still happening at correct size

Change History

Changed 5 years ago by r007

garbled X logon screen

Changed 5 years ago by r007

Xorg logfile of X server startup

comment:1 Changed 5 years ago by r007

Most prominent error to me seems:

(WW) VBoxVideo(0): Failed to set up write-combining range (0xe4000000,0x2000000)
(WW) VBoxVideo(0): Failed to set up write-combining range (0xe0000000,0x6000000)

I had this same setup working with VBox 2.0.0, then upgrading (including the guest additions) to 2.1.0 broke things.

comment:2 Changed 5 years ago by michael

I suspect that this is a duplicate of #2783. If so it is fixed in the development tree.

Changed 5 years ago by r007

garbage still happening at correct size

comment:3 Changed 5 years ago by r007

Looks very much like a duplicate, except it's a 32bit Etch guest.

Tried the proposed fix from #2783, which corrects the window size, but leaves the lower third or so of the screen still unusable (see tearing in newly attached screenshot). Looks to me like said part of the screen is just not redrawn properly.

comment:4 Changed 5 years ago by michael

Which fix exactly did you apply? There were at least two changesets in SVN for this (although the first, r15665 in the public repository, should be enough as a workaround).

comment:5 Changed 5 years ago by r007

Sorry for not having been clear enough, I meant the HOST-CTRL-F1 then ALT-F7 fix mentioned in the bug itself.

If you'd like me to test a newer svn release however, I'll consider building VBox myself.

comment:6 Changed 5 years ago by michael

Hm, perhaps this is not fixed, I have just seen something similar myself with a 32bit Etch guest with additions.

comment:7 Changed 5 years ago by r007

I just want to confirm that this still exists in 2.1.2

comment:8 Changed 5 years ago by r007

And I filed anoher bug (#3124) which is possibly related to this.

Interestingly, in the gdm login window the screen is garbled no matter what I do (switching back and forth between text console and X does not help). Once logged in, a switch back and forth fixes the garbage, but the lower tier is still not redrawn. (Though controls can be clicked and work as expected.)

As an aside, 2.1.2 indeed fixes the resizing issue.

comment:9 Changed 5 years ago by michael

  • Summary changed from vboxvideo produces garbled screen to vboxvideo produces garbled screen -> possibly fixed in SVN

Could you retry with 2.1.4 when it is released? You will need to reinstall the Guest Additions using the version which comes with that release.

comment:10 Changed 5 years ago by r007

It seems that 2.1.4 Fixes the main issue. When the xorg.conf Display Section is limited to one resolution, it works as expected.

Changing the Resolution using RandR still leads to the lower third of the screen not being redrawn. (Which I gues is what was happening before, too: Screen at 1920x1200, RandR'd down to 1440x900.)

Garbage on gdm start is gone, too.

comment:11 Changed 5 years ago by michael

Can you give version 2.2 with the 2.2 Guest Additions a try to see if they solve your issue? Thanks.

comment:12 Changed 5 years ago by r007

It still exhibits this specific behaviour (i.e. Lower third not redrawn when at 1440x900). The same is true for all resolutions lower than native.

When switching to native resolution (1920x1200) with RandR though, everything works as expected. To me it seems to be a bug in the redraw handling at less-than-maximum resolution.

xorg.conf has the resolutions listed as ""1440x900" "1920x1200" ..." because I usually start out on the small screen and then opt to switch to the big version when an external monitor is connected.

Interestingly, on gdm login window (which due to the above configuration always comes up at 1440x900), once -- not reproducably though -- X went into what I call viewport mode (i.e. seeing a portion of the screen which you can move by hitting the edges), which when I moved the viewport the screen redrew correctly.

Sorry for probably driving you into madness with this bug...

comment:13 Changed 5 years ago by michael

That viewport mode is what we fixed for this release, I hoped that it might be related to your other issue. No problems, I will take a proper look by copying your xorg.conf to my Etch guest when I have a bit of spare time (whenever that may be :) ).

comment:14 Changed 5 years ago by MrX1980

Please try it with v3.0.0 again.

comment:15 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

comment:16 Changed 5 years ago by r007

  • Status changed from closed to reopened
  • Resolution fixed deleted

Just tried with 3.0.2. Still persists.

(e.g. Native resolution works, RandR'd down doesn't.)

comment:17 Changed 5 years ago by michael

Are the symptoms still the same as before? Is this still a Debian Etch guest? Have you tried 3.0.4 with the 3.0.4 Guest Additions? (Sorry to keep referring you to new versions, but I do do regular driver fixes :) )

comment:18 Changed 5 years ago by r007

No doubting that. But it still doesn't work with 3.0.4. I'll keep trying new versions then... At some point I will probably just upgrade to lenny where I hope it's fixed.

comment:19 Changed 5 years ago by michael

Tried again to reproduce this yesterday but failed (I get your viewport mode right from the login screen). Could you please attach your guest's xorg.conf? Thanks!

comment:20 Changed 4 years ago by r007

By now I have reinstalled that VM with lenny which does not exhibit these problems any more.

You can therefore close the ticket if you want to.

comment:21 Changed 4 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Summary changed from vboxvideo produces garbled screen -> possibly fixed in SVN to vboxvideo produces garbled screen -> obsolete

Thanks for getting back to us! Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use