VirtualBox

Ticket #3131 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Guru Meditation 1103 (VINF_EM_DBG_HYPER_ASSERTION)

Reported by: tvo Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.2 Keywords: assertion failed guru meditation pgmPoolTrackPhysExtDerefGCPhys MM_RAM_FLAGS_CREFS_PHYSEXT
Cc: Guest type: other
Host type: Linux

Description

One of my VirtualBox virtual machines crashed today while it was performing a rather intensive computing task in MATLAB. It said to report the bug, so here it is.

The log shows an assertion failed somewhere:

             !!Assertion Failed!!
             Expression: cRefs == MM_RAM_FLAGS_CREFS_PHYSEXT
             Location  : /home/vbox/vbox-2.1.2/src/VBox/VMM/VMMAll/PGMAllPool.cpp(3076) void pgmPoolTrackPhysExtDerefGCPhys(PGMPOOL*, PGMPOOLPAGE*, PGMPAGE*)
             cRefs=0 HCPhys=00000000289d5000 pPage=f65795a8:{.idx=529}

I'm running VirtualBox 2.1.2 (from the repository linked to on the Download page) on an Ubuntu (8.04) Linux host (Linux 2.6.24-23-generic #1 SMP i686 GNU/Linux), an Intel(R) Core(TM)2 Duo CPU T5750 @ 2.00GHz with 3G RAM.

The guest OS is Windows XP SP3. The virtual machine had 1G RAM. At the time of the crash 2 virtual machines with 1G RAM were running. Both were using the same base disk image, the crashed one was differencing due to snapshot, and it's base disk image attached (with the blue star) to the other one too as differencing disk. Both VMs were started using the GUI.

At the time of the crash probably both machines were doing computations in MATLAB at 100% CPU and 250-750 MB RAM usage. (I do not know for sure since I was away.)

I'll attach the log and I can provide further info on request.

Attachments

TUD 2008 Q1-2009-01-23-18-21-42.log Download (245.2 KB) - added by tvo 5 years ago.
log file of crash

Change History

Changed 5 years ago by tvo

log file of crash

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3124. Add your comments there please.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use