VirtualBox

Ticket #1633 (reopened defect)

Opened 11 years ago

Last modified 8 months ago

Windows XP cannot boot natively after installation of Guest Additions (BSOD during boot)

Reported by: marq Owned by:
Component: guest additions Version: VirtualBox 4.0.6
Keywords: Cc:
Guest type: Windows Host type: other

Description

I have successfully managed to run Windows XP Home / SP3 from a raw partition within Virtual Box on an OpenSUSE 10.3 Linux host. Without Guest Additions installed, the windows installation can be booted both natively as well as in a virtual machine.

Once the Guest Additions are installed, booting natively fails. Immediately after showing the initial Windows splash screen, the mouse pointer appears in the center of the black screen, and the machine locks up completely. The keyboard doesn't react at all; doing a CTRL-ALT-DEL, for example, doesn't work.

I have further managed to reproduce the problem by simply installing the Guest Additions into the natively running Windows (from a CD-Rom that contains the Guest Additions). Installation apparently proceeds without problems (no warnings or error messages), but the machine freezes up at the next native boot as described above. Booting into the virtual machine is fine (and the Guest Additions work properly).

In both cases, the windows Windows installation boots natively again after the Guest Additions have been uninstalled, e.g. from within a virtual machine. On the first native boot of the Windows installation, some device drivers are apparently reinstalled (Graphics and Mouse, I think).

If a native boot has failed with the Guest Additions installed, all Linux partitions (extfs3) are checked during the next Linux boot because of not being unmounted properly, although the previous Linux shutdown proceeded without problems. The NTFS partition holding the Windows install is also flagged as being not clean (an ntfs-3g mount has to be forced, for example, and during a boot into a virtual machine the Windows installation starts up with offering to boot into previous configurations or a safe mode).

Hardware: Samsung X20 laptop with an Intel i915 Graphics chip set, a single SATA drive holding several partitions, the first one being used for the Windows installation.

Attachments

VBox.log.2 Download (54.5 KB) - added by WTcIPv2Ers 10 years ago.
WinXP running in VB under FreeBSD 7.2

Change History

comment:1 Changed 11 years ago by frank

  • Guest type changed from other to Windows

comment:2 Changed 11 years ago by frank

  • Component changed from other to guest additions

comment:3 Changed 11 years ago by frank

  • Summary changed from Windows XP cannot boot natively after installation of Guest Additions (black screen of death during boot) to Windows XP cannot boot natively after installation of Guest Additions (BSOD during boot)

comment:4 Changed 11 years ago by pentagonik

Please try again with 1.6.4 Guest Additions and report back if this error still occurs, thanks.

comment:5 Changed 11 years ago by frank

  • Version changed from VirtualBox 1.6.0 to VirtualBox 1.6.4

We already got reports that this still don't work with VBox-1.6.4.

comment:6 Changed 11 years ago by pentagonik

In the topic you mention a "BSOD", but in the text you're describing that the machine locks up (freezes). So what's the machine actually doing?

I tried to install the Guest Additions on a real system several times, too, no errors occured so far.

If you really getting a BSOD, could you please turn off the automatic restart (Start -> Settings -> Control Panel -> System -> Advanced -> Startup and Recovery -> "Automatically restart") and enabling the "Kernel Memory Dump" on the same page? If a BSOD happens then, please upload the newly created file (zipped) in "%SystemRoot%\MEMORY.DMP" to a location where I can download it. I'll take a look at it then. Thanks!

comment:7 follow-up: ↓ 8 Changed 11 years ago by frank

marq, any response for this one? Any other user experiencing the same problem?

comment:8 in reply to: ↑ 7 Changed 11 years ago by marq

My apologies for not responding sooner.

The 'B' in the BSOD stands for black, not blue; someone changed my original title which didn't use the (misleading) acronym. Thus, there's really no memory dump available - or am I wrong there? Anyway, as I wrote in the original post,

Once the Guest Additions are installed, booting natively fails. Immediately after showing the initial Windows splash screen, the mouse pointer appears in the center of the black screen, and the machine locks up completely. The keyboard doesn't react at all; doing a CTRL-ALT-DEL, for example, doesn't work.

My gut feeling is that the Windows OS hangs itself up / goes into some kind of infinite loop during its boot sequence; this might even happen before keyboard drivers are loaded (there is no reaction whatsoever to the keyboard; only pressing the on/off button for several seconds or removing the battery completely allowed me to get out of that unfortunate situation).

I can try to install the more recent version of the guest additions and see if the problem still occurs; but as the laptop is my only computer for my 'real' work as well, I'll need to make backups etc. That will take a while and won't happen before the weekend. Can you advice on what I can do to debug this a bit more?

Thanks!

comment:9 follow-up: ↓ 10 Changed 11 years ago by pentagonik

@marq: Are you able to boot up the VM in safe mode (hitting F8 several times when booting) after the black screen with the installed Guest Additions appear?

comment:10 in reply to: ↑ 9 Changed 11 years ago by firebird

Tested with GuestAdditions Version 2.0.2

After installing GuestAdditions into a native Windows XP SP2 installation (in order to boot this also as a RAW-vmdk from Linux with virtualbox) Windows comes up with a bluescreen after Login:

  1. Login appears
  2. NO mouse pointer!!!
  3. after entering user and password -> bluescreen (STOP 0x0000007F ...)

This also happened with Version 1.6.x

comment:11 Changed 11 years ago by firebird

Additional information:

  1. Bluescreen comes even without login after some time displaying the GINA.
  1. Booting into Save-Mode does not help - same failure
  2. Installation of Guest Additions without GINA.dll does not help
  3. Booting into VGA mode does not help

comment:12 Changed 11 years ago by firebird

Hello,

is someone investigating this BUG? What further information can I supply to help?

comment:13 Changed 10 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen this ticket if the problem persists with the latest release (2.2.2). Make sure to upgrade the guest additions to 2.2.2 as well.

comment:14 Changed 10 years ago by Kemosabe

  • Status changed from closed to reopened
  • Resolution fixed deleted

Tested with GuestAdditions 2.2.2 and VirtualBox 2.2.2!

Native XP BSOD stoped when I uninstalled Microsoft Compliance ACPI on my VM. Tried to disable ACPI from VM Settings, but won't boot (a friend said it solved his BSOD 0x7F error).

Still can't logon to native XP. As soon as I enter logon user and password, XP imediatelly logs off. Same in Safe Mode.

VM works fine.

I'm using separate HW Profiles for native and virtual startups. Thanks!

comment:15 Changed 10 years ago by Kemosabe

I've figured out what the problem was.

The BSOD 0x7F is indeed caused by VirtualBox GuestAdditions 2.2.2. After uninstalling them, no more BSOD.

As to my logon/logoff problem, it is related to the MBR. I used a "fake" MBR file to boot up the VM (as described here:  http://mesbalivernes.blogspot.com/2008/01/virtual-box-booting-from-existing.html). What happened next is that Windows XP only worked with the "fake" MBR (via VirtualBox). I tried to use that one on the native installation and lost my partition table :D. I got it back and have the "fake" MBR on the native installation working great.

Didn't have the time to get both native and VM working, but will be back to it ASAP.

Cheers!

comment:16 follow-up: ↓ 17 Changed 10 years ago by Kemosabe

I had a little more time and finally got it working.

To workaround the problems I was having, I fixed MBR for XP only (used TestDisk tool). Then, I booted with Ubuntu CD and made a Backup of the fixed MBR to my XP partition. Installed Ubuntu and VirtualBox. When creating the VM Raw Disk, instead of using the "fake" MBR, I used the one I backed up. That's it!

Both native and virtual for the same RAW disk work! Don't forget to previsously create the Hardware profiles.

Cheers!

comment:17 in reply to: ↑ 16 Changed 10 years ago by Kamex009

Replying to Kemosabe:

I had a little more time and finally got it working.

To workaround the problems I was having, I fixed MBR for XP only (used TestDisk tool). Then, I booted with Ubuntu CD and made a Backup of the fixed MBR to my XP partition. Installed Ubuntu and VirtualBox. When creating the VM Raw Disk, instead of using the "fake" MBR, I used the one I backed up. That's it!

Both native and virtual for the same RAW disk work! Don't forget to previsously create the Hardware profiles.

Cheers!

Kemosabe, could you please detail the process of fixing the MBR for the physical windows partition using testdisk? and the the backing up from linux of the MBR you just created... that's were I'm stuck and don't want to mess anything else, thankyou

comment:18 Changed 10 years ago by vi

If fails with similar problems (forcing mouse to right bottom corner, slow/defunct keyboard, BSoD adter certain time) in version 3.0.8. My attempt to create separate hardware profiles "With VBox"/"Without VBox" failed. If fails with both profiles.

comment:19 follow-up: ↓ 20 Changed 10 years ago by zyrdenack

I confirm the same behavior with my setup: WXP SP2 on raw ntfs partition works without problems with VBox Guest Additions while running virtualized with VBOX 3.0.12. This WXP instance does not work natively with VBox Guest Additions installed (can not control mouse nor keyboard, systems seems like freezed). After deinstallation of Guest Additions while working virtualized, WXP works fine natively. It would be great to know how to disable Guest Addtitions only while working natively. It looks like there are some VBox services that can not be switched off via services.msc (to make given service not start in native hardware profile).

comment:20 in reply to: ↑ 19 Changed 10 years ago by wzanatta

Same thing...

Host: Fedora 12 (fresh install) Guest: Windows XP SP2 (previously installed as native OS / company notebook) Hardware: HP ElliteBook 6930p VBox: 3.1.0 x86

-- Booting NATIVE after installing GuestAdditions on VM will hang on the blue screen right before the login screen with mouse cursor hung. No keyboard too.

Uninstalling GuestAdditions works. Reinstalling falls back into the problem.

comment:21 follow-up: ↓ 22 Changed 10 years ago by pentagonik

@wzanatta: Since you're seeing the bluescreen: What's the exact text of it, what does it say (error code, file name if present)?

comment:22 in reply to: ↑ 21 Changed 10 years ago by wzanatta

Replying to pentagonik:

@wzanatta: Since you're seeing the bluescreen: What's the exact text of it, what does it say (error code, file name if present)?

sorry. it is not a BSOD. It is a blank blue screen with only the hung mouse cursor in it.

I'm not sure on how to determine which driver could be causing that. I noticed that even when choosing the NATIVE profile, VBoxGuest.sys would load, thus I tried going in VM mode, disabling VBoxGuest.sys with "sc config vboxguest startup= disabled" and tried going on NATIVE again...although VBoxGuest.sys wasn't loading, the system still hangs at the same point.

again, I only could boot in NATIVE mode when uninstalled GuestAdditions. I'm still investigating...

comment:23 Changed 10 years ago by sunlover

wzanatta, I could not reproduce the hang. XP boots and works fine with VBox 3.1.0 both natively and in a VM. 3.1.0 additions were installed when the XP has been booted in the VM.

So any additional info and hints are welcome.

BTW, please attach VBox.log file when XP is booted as guest in the VM with additions installed. Thanks.

comment:24 Changed 10 years ago by wzanatta

tried everything from scratch... now, instead of letting the automated company restore do the job, I restored the XP ghost images by myself and started installing drivers one at a time...

so far, seems to be related to the Synaptics driver...

I'm still making some tests...going home now...I'll keep you guys informed.

comment:25 Changed 10 years ago by wzanatta

confirmed! my problem was related to the Synaptics driver (tried v13.2.6.2).

for some reason the Guest Additions + Synaptics combination was resulting in a freeze when starting windows in Native mode.

if you need further information, I'll be glad in helping...

thank you!

comment:26 Changed 10 years ago by WTcIPv2Ers

I have the same issue of being unable to boot Windows XP natively once guest additions are installed.

  • Host OS: FreeBSD 7.2
  • Guest OS: Windows XP SP3
  • VirtualBox version: virtualbox-3.0.51.r22902_3 (compiled from ports)
  • Real hardware: Fujitsu Lifebook S6410 (also has a Synaptics touchpad)

What I did not yet do:

  • Confirm that it really is the Synaptics driver which is the culprit
  • Confirm that I can get a working native Win XP boot by uninstalling the guest additions

Additional information:

  • When I boot natively, the three LED indicators above the keyboard of the S6410 for num lock, shift lock, and ??? blink (together) with a very short on time and varying (about 1 second) off time.
  • Win XP works for some time, then stops with a BSOD (sorry I did not take a photograph). The BSOD only says something about Windows being halted to prevent further damage to the system. There also is a line about starting to dump, and immediately following another one with end of dump, but it does not seem that any dump really takes place. (This is just memorized.)
  • Before I gave up (and reverted to my pre-VirtualBox WinXP setup by restoring the NT partitions from a backup) I also tried to disable the video and kernel VirtualBox drivers in Win XP, without success.

If I find out how to submit log files I could do that.

Regards

Changed 10 years ago by WTcIPv2Ers

WinXP running in VB under FreeBSD 7.2

comment:27 follow-up: ↓ 28 Changed 10 years ago by raffaellod

Same issue here. This is how I got to the empty blue screen of non-death:

  1. Regularly installed OEM (non-pre-activated) Windows XP Professional on real hardware (Acer Extensa 5620, with Synaptics touchpad), in dedicated partition (/dev/sda3) using a partitionedDevice VMDK.
  2. Installed all necessary real drivers, then copied the hardware profile to a new one to be only used for VirtualBox, and the original one to be only used for the real hardware.
  3. Backed up the whole (small, 7 GB) partition (simply dd if=/dev/sda3 of=sda3.backup bs=16M).
  4. Booted the guest in VirtualBox PUEL (under Gentoo Linux) in Failsafe, let it reinstall the world, and confirmed everything to be working in Normal mode.
  5. Shut down VirtualBox, I rebooted into Windows, to ensure the installation didn’t get hurt. Everything was as expected, so back to Gentoo and VirtualBox.
  6. Installed Guest Additions, and checked they work just fine. Shut down guest.
  7. Booted on the real hardware again, only to get an empty blue screen (the logon desktop, not the BSOD), with the mouse stuck in the center, and no input working. The only way out was 4 secs of power button. Same in Failsafe, except the background then is black.

And this is where most people seem to have stopped. I tried to take it further:

  1. Started again in VirtualBox, fired up RegEdit, browsed to CurrentControlSet\Services, and set Startup = 4 to all of the VBox* services I could see there. (Startup = 4 means “Disabled”.)
  2. Rebooted on the real hardware, to find out that while the system was now working, the mouse was still stuck in the center.
  3. So I tried uninstalling the driver from Device Manager (I can use Windows perfectly without a mouse), and rebooted, still on the real hardware.
  4. Same thing, the driver was just reinstalled, and still not working. So I decided to go back to Device Manager, and I disabled it altogether, just to see what would happen. Reboot on real hardware.
  5. Things got worse. It would get me to the login screen (I use the NT4-5 login screen, not the colorful blueish one), but I couldn’t type anything, and the mouse was obviously not working. My only way out was the power button, which Windows recognized perfectly, resulting in an ACPI-initiated proper shutdown. I tried in Failsafe too, same result.
  6. Back to VirtualBox, I expected to be able to try something different. Mere illusion. All I got was exactly the same behavior as on the real hardware: no keyboard nor mouse working. Only ACPI power button shutdown. Same in Failsafe.
  7. So, the only way out was dd if=sda3.backup of=/dev/sda3 bs=16M.

Now, I repeated the process from point 4 to point 5 of the first sequence, so I stopped before installing the Guest Additions, since I now know they will cause problems.

So, what can I do to help you debug this?

comment:28 in reply to: ↑ 27 Changed 10 years ago by raffaellod

When I say I reinstalled and uninstalled “the driver” in points 3 and 4 of the second list, I’m talking about the Synaptics touchpad driver. Sorry for the confusion.

comment:29 Changed 8 years ago by gluxon

I can reproduce this with Windows 7 (x86) and VirtualBox OSE 4.0.4 on Ubuntu 11.04 Beta 2. I'm using an nc6400 hp compaq laptop.

After the "Starting Windows" boot splash, I receive a black screen (of death) when booting natively. Uninstalling Guest Additions (4.0.4) fixes the problem, but I lose the native resolution when starting the operating system in VirtualBox.

Isn't there a way for the Guest Additions service to detect if the Operating System is running in VirtualBox and not start, probably resolving the problem?

comment:30 Changed 8 years ago by frank

  • Cc christian@… removed
  • Version changed from VirtualBox 1.6.4 to VirtualBox 4.0.6

Tickets #7320, #7341, #7939, #8314 marked as duplicates of this one.

comment:31 follow-up: ↓ 32 Changed 9 months ago by sschu

vboxmouse.sys crashes Win10 Pro in native boot, when unplugging some usb-device. Uninstalling and Reinstalling GA is no option, because the user has no Admin-Rights for his Windows-Installation. But in this case, the raw hardware is a Dell OptiPlex 5060 - so x86_64 hardware, not a Mac. The Windows Guest is Run on a Linux Host-System running Debian Virtualbox v5.52.20 with newest available GA. When uninstalling VBox GA the user can unplug his mouse withoud bsod complaining on IRQ_NOT_LESS_OR_EQUAL... Any hints how to solve? is there a way to only uninstall vboxmouse.sys ? For which functionality of GA is vboxmouse.sys needed?

comment:32 in reply to: ↑ 31 Changed 9 months ago by socratis

Replying to sschu:

the raw hardware is a Dell OptiPlex 5060 - so x86_64 hardware, not a Mac.

Not sure if you've checked lately, but Macs are x86_64 hardware. For years actually, since  Jan/2006 to be exact... ;)

comment:33 Changed 9 months ago by cheshirekow

Also having this issue. I'm using a linux host (Ubuntu 18.04) and I have windows 10 home version 1803. I experience this crash with Guest Additions 5.2.11 when I unplug a USB device. I have previously used this same windows installation for a few years, paired with ubuntu 16.04 and never had this problem.

I read in the forum thread that it might be due to installation of windows updates when windows is running as a guest. That is possibly something that I did. I very rarely boot windows natively... only to play games, so I'm not sure exactly *when* this problem started for me.

I have removed guest additions for now. I guess the fact that this bug is 10 years old is a good indicator of it's priority, but it would be great if this problem could be fixed.

Here's some info from the minidump (I don't see a way to attach, but I can provide the dump file too).

Windows 8 Kernel Version 17134 MP (12 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 17134.1.amd64fre.rs4_release.180410-1804
Machine Name:
Kernel base = 0xfffff801`f889a000 PsLoadedModuleList = 0xfffff801`f8c48150
Debug session time: Tue Dec  4 22:14:45.165 2018 (UTC - 5:00)
System Uptime: 0 days 20:39:17.923
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: 0000000000000000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, value 0 = read operation, 1 = write operation
Arg4: fffff8073dc7265c, address which referenced memory

Debugging Details:
------------------

TRIAGER: Could not open triage file : e:\dump_analysis\program\triage\modclass.ini, error 2

WRITE_ADDRESS: unable to get nt!MmSpecialPoolStart
unable to get nt!MmSpecialPoolEnd
unable to get nt!MmPagedPoolEnd
unable to get nt!MmNonPagedPoolStart
unable to get nt!MmSizeOfNonPagedPoolInBytes
 0000000000000000 

CURRENT_IRQL:  2

FAULTING_IP: 
VBoxMouse+265c
fffff807`3dc7265c 488908          mov     qword ptr [rax],rcx

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

BUGCHECK_STR:  AV

PROCESS_NAME:  System

TRAP_FRAME:  ffff8e86421e2420 -- (.trap 0xffff8e86421e2420)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=0000000000000000
rdx=ffffd280df17ae50 rsi=0000000000000000 rdi=0000000000000000
rip=fffff8073dc7265c rsp=ffff8e86421e25b0 rbp=ffffd280df9efd70
 r8=0000000000000020  r9=ffffd280df17ad00 r10=ffffa701993d5180
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe nc
VBoxMouse+0x265c:
fffff807`3dc7265c 488908          mov     qword ptr [rax],rcx ds:00000000`00000000=0000000000000000
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff801f8a54269 to fffff801f8a43690

STACK_TEXT:  
ffff8e86`421e22d8 fffff801`f8a54269 : 00000000`0000000a 00000000`00000000 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
ffff8e86`421e22e0 fffff801`f8a50ee5 : fffff801`f8c60d80 ffffd280`d8cc8448 ffffa701`993d5180 00000000`00000000 : nt!KiBugCheckDispatch+0x69
ffff8e86`421e2420 fffff807`3dc7265c : 00000000`00000000 00000000`00000000 00000000`41706e50 fffff801`f8e6f1c7 : nt!KiPageFault+0x425
ffff8e86`421e25b0 00000000`00000000 : 00000000`00000000 00000000`41706e50 fffff801`f8e6f1c7 ffffd280`df19cce0 : VBoxMouse+0x265c


STACK_COMMAND:  kb

FOLLOWUP_IP: 
VBoxMouse+265c
fffff807`3dc7265c 488908          mov     qword ptr [rax],rcx

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  VBoxMouse+265c

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: VBoxMouse

IMAGE_NAME:  VBoxMouse.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  5ad9ccac

FAILURE_BUCKET_ID:  X64_AV_VBoxMouse+265c

BUCKET_ID:  X64_AV_VBoxMouse+265c

Followup: MachineOwner
---------

comment:34 Changed 8 months ago by Quppa

What will it take to get this bug fixed? I'm happy to try and help submit a patch if possible, but I'm not sure what the best approach is. Is there something we can query in the DriverEntry function in VBoxMFDriver.cpp that tells us whether we're running under VirtualBox and exits early if so?

comment:35 Changed 8 months ago by socratis

@Quppa
There is for sure a function that checks and knows whether the OS is running in a VM, or natively. It is used for/in the "VBoxTray.exe" to know whether it will run or not. Natively it doesn't run, inside a VM it does. Maybe it doesn't call the function directly, maybe the "VMService.exe" calls it.

I don't know enough C to be able to actually help you with the programming aspect, but I have a pretty good understanding of the whole architecture. I'll try to get the devs involved. At least to give us a general sense of direction.

It might worth it to continue this discussion on the developer mailing list actually, or at the OSE section of the forums...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use