VirtualBox

Ticket #8314 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Dual boot: Cannot boot to real Windows after installing Guest Additions (4.0.2)

Reported by: rstribrn Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Versions:

  • Windows XP SP3 32bit
  • Ubuntu 10.10 x86_64
    • kernel 2.6.37
  • VirtualBox 4.0.2

How to reproduce: 1.) Start Windows as guest 2.) "Upgrade" guest additions from 3.2.x to 4.0.2 3.) Shutdown guest, shutdown host 4.) ERROR: Start Windows as host

=> Windows starts and displays login screen, then crashes to BSOD => Same result when booting to Safe mode

5.) Start Linux as host again 6.) Start Windows as guest

  • works fine

=> So I guess that the root cause is really mentioned Guest additions.

( I saw VirtualBox's sys drivers displayed when booting in Windows's Safe mode...so I've realized that this could be the problem)

Attachments

VBox_8314_regedit_export.reg Download (9.3 KB) - added by rstribrn 3 years ago.
Here is exported regedit (done when running as guest): HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}

Change History

comment:1 Changed 3 years ago by rstribrn

I've have not mentioned this explicitly before, but yes, I'm running the Windows (host/guest) from real partition. Just to be clear...

comment:2 Changed 3 years ago by sunlover

Could not reproduce this here. Do you use any third party mouse drivers in the XP? May be this is the same problem as  http://www.virtualbox.org/ticket/7939

comment:3 Changed 3 years ago by sunlover

What is the value of the registry key with installed guest additions:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}\UpperFilters

You can start regedit and search for VBoxMouse to find the registry key.

comment:4 Changed 3 years ago by frank

  • Priority changed from critical to major

Changed 3 years ago by rstribrn

Here is exported regedit (done when running as guest): HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96F-E325-11CE-BFC1-08002BE10318}

comment:5 Changed 3 years ago by rstribrn

Yes, it seems similar to  http://www.virtualbox.org/ticket/7939. I'm using Synaptic's driver which can also be seen in attached regedit export.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1633.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use