VirtualBox

Ticket #7320 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Native Windows XP won't boot with Guest additions installed

Reported by: cefn Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.8 Keywords: bsod guest additions windows xp
Cc: Guest type: Windows
Host type: Linux

Description

I've configured Virtualbox to run a natively installed windows directly from its original partition through Ubuntu.

Booting it both ways is possible until I install Guest additions. Subsequently, a Blue Screen of Death is encountered when trying to boot and log in to the windows instance.

Are there any procedures for selectively removing individual parts of the Guest additions drivers. I really need folder sharing but can live without the rest.

If I can uninstall individual components, leaving just shared folders, I could try to narrow down which driver generates the BSOD. Any ideas how to do this?

Attachments

BSOD.jpg Download (108.0 KB) - added by cefn 4 years ago.
Picture of BSOD
VBox.log Download (61.7 KB) - added by cefn 4 years ago.
Vbox.log after installing Guest Additions and rebooting virtually

Change History

comment:1 Changed 4 years ago by cefn

I didn't clarify that uninstalling the Guest additions brings the native windows back to full functionality, so it's definitely related to those drivers somehow.

comment:2 Changed 4 years ago by frank

Please attach a VBox.log file of your VM, if possible with Additions installed.

Changed 4 years ago by cefn

Picture of BSOD

Changed 4 years ago by cefn

Vbox.log after installing Guest Additions and rebooting virtually

comment:3 Changed 4 years ago by cefn

Thanks for the prompt reply, Frank.

The problem comes when I boot Windows natively with the Guest additions still installed, so I don't know how the VBox.log will help you.

In any case I've attached the latest VBox.log from a virtual boot, login and shutdown with the Guest additions installed, as well as the BSOD image I captured with my phone from the native boot before it shut itself down.

It would be easier for me and others if you point to how we get a VBox.log, though. From digging around I found that on my system it's in a hidden folder in my home directory... .Virtualbox/Machines/XXXXname/Logs ...but it's different for Macs and Windows. Perhaps you could point to an authoritative information page about this next time.

Lastly do you know if it's sensible to just uninstall the video drivers? I'm not sure I need them, and if it saves uninstalling the guest additions every reboot it will certainly be helpful. How should I go about removing them?

comment:4 Changed 4 years ago by frank

  • Component changed from other to guest additions
  • Summary changed from Windows XP won't boot with Guest additions installed to Native Windows XP won't boot with Guest additions installed

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1633.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use