VirtualBox

Ticket #7939 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VBoxMouse.sys in Guest Additions crashes native Windows Versions when using mousedrivers

Reported by: egalus Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hi,

first I want to admit that I really like Virtualbox, but it's a shame how long a simple bug can last in such a project. The first Ticket I can find on this issue is from Version 2.0.2 (Ticket #501) which already explains parts of the problem (here not for native Windows with additions but as the reason is the same it's still the same problem). Another Ticket matching the problem is Ticket #7341 - this time really telling you to look into guest additions when used in native windows.

I conducted my tests on Ubuntu 10.10 x64 with Virtualbox 4.0.0 and corresponding guest additions. As Guests I used Windows 7 x64 and Windows XP as shared Virtualbox/Native installations installed according to your forum guides ( http://forums.virtualbox.org/viewtopic.php?f=28&t=33356). Every time I install guest additions in one of the windows vms it runs nicely in virtualbox, but native boot show the former mentioned erratic mouse movements/resets in the lower left corner of the screen combined with automatic pressed mouse buttons. On my machine (a Thinkpad T61) this leads to a) an unusable native Windows if guest additions are installed b) after ~1 minute of this crazy mouse behavior I get a bsod related to the installed mouse driver

I have hunted down the problem to VBoxMouse.sys. This infamous Mouse Filter is installed with guest additions and causes the problems as it is "plugged" to any installed mouse driver (on Windows XP even disregarding hardware profiles - really a no go!). If I manually delete VBoxMouse.sys prior to booting native Windows the mouse pointer stands still and i get no more bsods. But the mouse is unusable as windows recognizes that VBoxMouse.sys is missing for the mouse driver and refuses to start the mouse without it. If I uninstall guest additions (which also removes the mouse filter VBoxMouse.sys) native Windows runs normally.

The bsods (as discussed in some forum posts too) happen in combination with the synaptics touchpad driver (in my case for my Thinkpad T61 touchpad) as VBoxMouse.sys also attaches to this driver.

A step by step plan suggestion for solving the problem: a) For a start it would be nice to be able to just uninstall the Mousedriver (VBoxMouse.Sys) but keep all other guest additions. b) After a) is accomplished one could think about the possibility for the user to choose to which mousedriver VBoxMouse.sys is allowed to bind to and which drivers will not be touched by it. c) Later on guest additions should be able to find out if the OS is running in Virtualbox or not and should only active their functions if they detect that they run in Virtualbox. This should be true for all drivers and services in guest additions.

It would be great if this everlasting bug would get a fix soon.

If have not attached a VBox.log file as the crashes do not happen in Virtualbox but are caused by guest additions on native windows installations. I have not included minidumps of windows as that was done in the mentioned tickets before and because the reason is totally clear as outlined above.

Regards, Norbert

Change History

comment:1 Changed 3 years ago by raffaellod

Seems related to ticket #1633. I’d also love to see the Guest Additions fixed, or at least have the ability not to install the mouse driver filter.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use