VirtualBox

Ticket #7341 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Native Windows XP BSOD after Guest Additions installed (RAW disk image)

Reported by: BanthaFodder Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I am running VBox 3.2.8 r64453 installed from Synaptic repository on Ubuntu 10.04.1 The hardware is a IBM Thinkpad T60

I have Windows XP (SP 2) installed on the 4th partition of the sata hard drive. It has 2 hardware profiles, "Native" and "VirtualBox" and I do use the correct profile depending upon how it is runing. This was originally installed natively outside of the VM.

I created the virtual disk like this:

VBoxManage internalcommands createrawvmdk -filename ~/.VirtualBox/HardDisks/OldXP.vmdk -rawdisk /dev/sda -partitions 4 -mbr ~/opensource.mbr -relative -register

having previously created the mbr.

This was able to boot as a VM (after having to set on IO APIC)

It was unable to find drivers for:

  • Base System Device
  • Video Controller (VGA Compatible)

(I don't remember the exact text for the VGA driver)

I tested booting natively and this still worked.

After searching it seemed the solution was to install Guest Additions for these drivers which I did and that did indeed solve the driver issue.

However, when booting back natively, after the login the system halted with a blue screen. STOP: 0x0000007F (0x80042000, 0x00000000, 0x00000000)

Trying to boot in Safe Mode natively produced the error in the same place.

Trying to boot as a VM was successful but slow. (later determined to be 100%CPU)

I noticed that even in safe mode the list of drivers included VBoxGuest.sys so immediately suspected this as the problem.

My first attempt was to boot in VBox, run msconfig and disabled the Service VBox Guest Additions Service and the Startup item VBoxTray.exe. Then boot back natively but still the same problem.

Booted back into the VM and uninstalled Guest Additions.

Re-booted back natively and successful.

Closest ticket I could find was 1633 but not exact match. However, I do have Synaptic drivers also which is mentioned in that thread.

Change History

comment:1 Changed 4 years ago by Klabang Geni

I have same experience when installed Guest Additions on Acer Asphire 4740G with Windows Home Premium 64 bit. After read this thread I enter the Safe Mode and uninstall Guest Additions. Now I use usb flash disk to shared my files between host and guest OS

comment:2 Changed 4 years ago by sunlover

BanthaFodder, the problem is not reproducible here. A minidump of the crash could help.

To get the minidump:
1) Boot XP VM, install guest additions.
2) Boot XP VM, go to Control Panel/System/Advanced/Startup and Recovery Settings
There in Write Debugging Information select Small memory dump (64K)
3) Boot XP natively and after crash boot again in the VM.

The minidump file will be in c:\windows\Minidump directory. Please send me the latest Mini*.dmp file to Vitali dot Pelenjow at oracle dot com

comment:3 Changed 4 years ago by BanthaFodder

I already had minidumps enabled. Have sent them to you.

I tried booting back in VM to see what what happened and it again spent a long time trying to find the two drivers I mentioned before (I did get the names right) Painfully slow at 100%CPU whilst doing this. I had to shut it down eventually.

As an aside, after Guest Additions was unistalled it remained in the Start Menu. Cleaned that up manually.

Hope you find the problem.

comment:4 Changed 3 years ago by BanthaFodder

Not heard anything on this. I have tried again after upgrading to 3.2.10 and still the same. 100% CPU usage when running as a VM and bluescreen when booting natively after Guest Additions installed.

comment:5 Changed 3 years ago by sunlover

I have not received any minidumps. Could you please try to attach a minidump to this ticket?

comment:6 Changed 3 years ago by frank

That (attaching to this ticket) will probably not work (file too big). Please either mail the minidump(s) to frank _dot_ mehnert _at_ oracle _dot_ com or mail me a short notice so I can provide you an FTP server for uploading. If possible, provide us the VBox 3.2.8 minidumps. Thank you!

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1633.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use