VirtualBox

Ticket #10998 (closed defect: fixed)

Opened 19 months ago

Last modified 5 months ago

OS X 10.6 Host & Guest: Upgrade from 4.1.8 to 4.2.1 results in Guest Boot Crash

Reported by: wyrdR Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.0 Keywords: panic,osx,os x,snow leopard,4.2,upgrade
Cc: Guest type: OSX Server
Host type: Mac OS X

Description

Upgrade VirtualBox from 4.1.8 to 4.2.0 causing crash of VM on boot; i.e. Fails to boot, Kernel Panic.

Both Host & Guest are Snow Leopard Mac OS X 10.6.8 Server.

Downgrading back to 4.1.8 fixes problem - i.e. VMs not damaged irretrievably.

Tried:

  • Straight upgrade: ERRORs
  • Exporting VM from 4.1.8 then removing the re-importing into 4.2.0 - ERRORs
  • Remove VM; Re-add new VM with old vdi (fresh, default settings): ERRORs

Attachments

VBox.log Download (111.8 KB) - added by wyrdR 19 months ago.
Log while 4.2.0 is installed & booting from re-imported VM
Screen shot 2012-11-07 at 09.43.34.png Download (63.5 KB) - added by alanbirtles 18 months ago.
panic screenshot

Change History

Changed 19 months ago by wyrdR

Log while 4.2.0 is installed & booting from re-imported VM

comment:1 follow-up: ↓ 4 Changed 19 months ago by frank

Could be an EFI problem. Could you also try VBox 4.1.22?

comment:2 follow-up: ↓ 3 Changed 19 months ago by Hachiman

Could you please attach the log of such boot fails?

comment:3 in reply to: ↑ 2 Changed 19 months ago by wyrdR

Replying to Hachiman:

Could you please attach the log of such boot fails?

I've attached VBox.log already. What other logs should I be looking for?

Last edited 19 months ago by wyrdR (previous) (diff)

comment:4 in reply to: ↑ 1 Changed 19 months ago by wyrdR

Replying to frank:

Could be an EFI problem. Could you also try VBox 4.1.22?

Upgrade to VBox 4.1.23 went OK.

comment:5 follow-ups: ↓ 6 ↓ 7 Changed 19 months ago by frank

Ok, if I understood you correctly then this is a 4.2.0 regression as 4.1.23 works for you, right?

comment:6 in reply to: ↑ 5 Changed 19 months ago by Hachiman

Replying to frank:

Ok, if I understood you correctly then this is a 4.2.0 regression as 4.1.23 works for you, right?

I've ment panics on the guest side? As soon they happen too early, you can only do screenshot of such cases.

comment:7 in reply to: ↑ 5 ; follow-up: ↓ 8 Changed 19 months ago by wyrdR

Replying to frank:

Ok, if I understood you correctly then this is a 4.2.0 regression as 4.1.23 works for you, right?

Correct; And just to clarify, working with 4.1.23 & 4.2.1 here; Both are apparently Mac OS X specific patches for 4.1.22 & 4.2.0 respectively.

/wonders: Am I the only one still using Snow Leopard as a host?

comment:8 in reply to: ↑ 7 Changed 19 months ago by Hachiman

Replying to wyrdR:

Replying to frank:

Ok, if I understood you correctly then this is a 4.2.0 regression as 4.1.23 works for you, right?

Correct; And just to clarify, working with 4.1.23 & 4.2.1 here; Both are apparently Mac OS X specific patches for 4.1.22 & 4.2.0 respectively.

Not only Mac host support, 4.2.1 contains UEFI related fixes also.

Changed 18 months ago by alanbirtles

panic screenshot

comment:9 Changed 18 months ago by alanbirtles

I am also seeing the same issue since upgrading to 4.2, screenshot attached taken with 4.2.4

comment:10 Changed 18 months ago by VenCain

Exact same for me; happens when running a Windows 7 Pro 64-bit host with a Snow Leopard Server Guest (MacBookPro8,3 + legit OS X server license) using VB 4.2.4.

Backing off to 4.1.22 allows me to run the guest.

-VenCain

comment:11 Changed 17 months ago by bjacke

Last edited 17 months ago by bjacke (previous) (diff)

comment:12 Changed 15 months ago by JessePeterson

Note other possible duplicate tickets #11401, #11288, #11052.

comment:13 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.3.2.

comment:14 Changed 5 months ago by wyrdR

Tried updating to 3.3.2 - New problem (below).

Trying to revert but not so easy. May have to completely wipe Virtual Box and guest and start again... :(


Failed to open a session for the virtual machine xadmin. Virtual 3.3.2

pgm#1: ROM at 00000000000ff000 by the name 'EFI Thunk (2)' was not found [ver=14 pass=final] (VERR_SSM_LOAD_CONFIG_MISMATCH). Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

comment:15 Changed 5 months ago by wyrdR

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:16 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please open a separate ticket for the new issue. Please also attach the complete VBox.log file to the new ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use