VirtualBox

Ticket #11401 (closed defect: fixed)

Opened 15 months ago

Last modified 6 months ago

Mac OS X instances do not boot

Reported by: JessePeterson Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: OSX Server
Host type: Mac OS X

Description

Since upgrading to 4.2.6 (from a 4.1.x version--forget which) any instance of Mac OS X (10.6.8 server, 10.6.8, 10.7, 10.8) does not start reporting the same error when starting the virtual machine. This is in 64 or 32 bit modes.

A 10.6.8 Server VM no longer runs (it did before) and 10.7, 10.8, 10.6.8 Server boot ISOs do not boot stopping at the same exact point (in 64-bit mode):

AppleIntelCPUPowerManagementClient: ready

The host machines are various Apple MacBook Pros, Mac minis, and Xserves.

Attachments

VBox.log Download (75.8 KB) - added by murphyc 14 months ago.
VBox.log
Screen Shot 2013-02-19 at 10.15.37 AM.png Download (98.7 KB) - added by murphyc 14 months ago.
kernel panic png

Change History

comment:1 Changed 15 months ago by JessePeterson

May be related to and/or duplicate of #11401, #11288, #11052, #10998. #10998 seems to have the most discussion and some folks are having success rolling back to VB 4.1 from 4.2 to allow Mac OS X to boot as a guest again.

comment:2 Changed 15 months ago by frank

A VBox.log file of such a VM session is missing.

Changed 14 months ago by murphyc

VBox.log

Changed 14 months ago by murphyc

kernel panic png

comment:3 Changed 14 months ago by murphyc

Both a VDI of 10.6.8, and DVD of 10.6.0 kernel panic with 4.2.6, but boot fine with 4.1.24. Attaching vbox.log and kernel panic screenshot.

comment:4 Changed 14 months ago by TGOS

I can verify this issue; affects any version of OS X as a guest. Ticket #11490 is probably a duplicate of this one. Many people report about panics during boot, but those panics can be eliminated by reducing the number of cores in the VM to one. While this avoids the panics, it causes the the boot to hang as described above. A downgrade of VirtualBox is not possible if you want to run it on 10.8.2 since the older version will not work on this host system.

comment:5 Changed 14 months ago by murphyc

XNU kernel panics whether the VM uses 1 or more CPUs. I am using VirtualBox 4.1.24 on OS X 10.8.2 as a work around.

comment:6 Changed 9 months ago by b2jrock

Just a note that I am successfully running osx 10.8 guests on osx 10.8.4 host under virtualbox 4.2.16.

comment:7 Changed 7 months ago by enzo

I experience the same issue.

Running on VBox 4.2.18, OS X 10.8 is working fine while 10.5 and 10.6 dump in AppleEFIRuntime and 10.7 halts after printing:

AppleIntelCPUPowerManagement: Ready

All four OS X versions are working fine on VBox 4.1.26.

comment:8 Changed 6 months ago by enzo

Looks like this is fixed in 4.3 final.

comment:9 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use