VirtualBox

Ticket #10999 (reopened defect)

Opened 4 years ago

Last modified 8 weeks ago

extended error 234 when trying to list directory

Reported by: itguru2 Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.1.22 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Running host windows 7 64 bit running guest win xp 32 bit, dos program foxprox doing a command prompt from within the program and a dir of a mapped drive or shared vbox folder

extended error 234 and no directory listing

Change History

comment:1 Changed 4 years ago by misal

I have the same problem using old Norton Commander 3.0, 4.0 :)

Did someone resolve this ?

comment:2 Changed 4 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

comment:3 Changed 2 months ago by GraemeS

I have this error using the Virtualbox Version 5.1.6 r110634 (Qt5.5.1) in a new XP environment under Win10 on a new Lenovo ideapad 110.

EG Quickbasic 5 file OPEN cannot retrieve a list of files to display. Nor can my own QB program display a file list.

Last edited 8 weeks ago by GraemeS (previous) (diff)

comment:4 Changed 8 weeks ago by GraemeS

  • Status changed from closed to reopened
  • Resolution obsolete deleted

comment:5 Changed 8 weeks ago by socratis

The most important question is: does it work on a physical computer? That is, if you have QuickBasic installed on an actual Windows XP computer, can it open/use network shares?

I don't have access to a Windows XP computer to try it out, but I do remember a lot of older programs, mostly DOS based, but even Windows based, having problems with Windows network shares, or mapped (as drives) network shares. They didn't know what they were.

So, can you try out and see if it is a VirtualBox bug or if it a limitation of QuickBasic?

comment:6 Changed 8 weeks ago by GraemeS

The problem is not confined to QB as it also occurs in a Windows-based software package but I do not know what that packages uses. The package developer states that it wont run natively on Win10. Note that the QB editor itself shows an empty list of files but will open a file if its name is entered.

As my old XP system is still accessible via remote access s/w, I will see if I can setup a shared network drive for a test then report back.

Last edited 8 weeks ago by GraemeS (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use