VirtualBox

Ticket #8182 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Unexpected error about USB 2.0!

Reported by: nim Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

It's really strange (again). I had successfully started the guest OS, and shut down at least 2 times (because I remember installing the new version addition). Last I saved the state and now I tried to resume it, I got this error:

Failed to open a session for the virtual machine Windows 7. Implementation of the USB 2.0 controller not found! Because the USB 2.0 controller state is part of the saved VM state, the VM cannot be started. To fix this problem, either install the 'Oracle VM VirtualBox Extension Pack' or disable USB 2.0 support in the VM settings (VERR_NOT_FOUND). Unknown error creating VM (VERR_NOT_FOUND).

What's the meaning of it? I had already several times of startup/shutdown, yet it complains about USB 2.0 support if I save it?

Attachments

Logs.7z Download (18.8 KB) - added by nim 3 years ago.

Change History

Changed 3 years ago by nim

comment:1 Changed 3 years ago by frank

Do you have the extension pack installed?

comment:2 Changed 3 years ago by nim

The key question is - I have not the ext pack installed, but it let me start/stop/save the VM and yet it complains about not having the ext USB support. What's the logic?

comment:3 Changed 3 years ago by frank

  • Priority changed from blocker to major

Yes, this is indeed a bug. The intention is to allow the user to start a VM but show a big fat warning if he enabled a feature which is only available from the extension pack (in your case USB 2.0). If there is a saved state of the VM available, we do not allow to start the VM if such a special feature is missing because in that case the hardware of the guest would change during restore which is not possible (the USB 2.0 controller is not hot-plug-able).

The actual problem in your case the saved state of the VM does actually not contain the information about the USB 2.0 controller because it was not available when you started the VM -- you got the warning and just ignored it.

So this check needs improvement.

To restore your VM you would need to edit your VM settings file manually: Make sure that no VBoxSVC daemon is running (GUI and all VMs terminated). Then change enabledEhci=true to enabledEhci=false in the settings file of your VM. After doing so you should be able to restore the VM.

comment:4 Changed 3 years ago by kschwebke

for the fix pls. consider also #8364 -- installing the ext pack does NOT resolve the problem! In this case the machine does not start either, and it's complaining about the present extension.

comment:5 follow-up: ↓ 6 Changed 3 years ago by fredrik

This is a terrible show stopper bug!

I cannot start my saved stated (snapshot) because VirtualBox complains about missing USB-2.0.

Nor can I disable USB-2.0 for my snapshot, since that is only possible on non-started Thus my snapshot is lost.

I am now disabling automatic update, your updates are not to be trusted.

comment:6 in reply to: ↑ 5 Changed 3 years ago by kallewoof

Replying to frank:

To restore your VM you would need to edit your VM settings file manually: Make sure that no VBoxSVC daemon is running (GUI and all VMs terminated). Then change enabledEhci=true to enabledEhci=false in the settings file of your VM. After doing so you should be able to restore the VM.

Where is this file located on a Mac? For that matter, what's the NAME of the file? I've looked around in e.g. ~/Library/VirtualBox/ and searched around in various ways but I can't find a file with "enabledEhci" in it using grep.

Replying to fredrik:

I am now disabling automatic update, your updates are not to be trusted.

QFT.

comment:7 Changed 3 years ago by kallewoof

I found the file after some digging around, in case anyone else wonders -- it's ~/Library/VirtualBox/Machines/[VIRTUAL-MACHINE-NAME]/[VIRTUAL-MACHINE-NAME].xml

Changing enabledEhci to false and then restarting VB gave me the following error:

Failed to open a session for the virtual machine ubu1004.
pci#0: Device in slot 0x58 has been removed! vendor=0x8086 device=0x265c [ver=3 pass=final] (VERR_SSM_LOAD_CONFIG_MISMATCH).

Not sure what device it's talking about. It could have been a USB device I had plugged in at the last boot but USB devices ARE hot-pluggable so that shouldn't cause a failure to boot, right?

comment:8 Changed 3 years ago by CP44

I am getting the same error with v4.0.4 - When I try to set enabledEhci="false" in the VM's xml file, it gets reset to "true" next time the VM attempts to start. This applies to all USB entries in the XML file (8 in mine).

(I am sure I am saving the file, and I have tried setting this with another VM selected and with the VirtualBox GUI shut down - it seems these values are being read from somewhere else - even when startup is attempted via VBoxManage, making the config file's change useless in this case.)

--John/CP44

comment:9 Changed 3 years ago by chrismilne

I am also getting this error. I can not change the xml or it just resets itself and presents the same error. I tried installing the extension pack and now i get this error:

pdm#1: Device 'usb=ehci'/0 not found in the saved state [ver = 4 pass = final] (VERR_SSM_LOAD_CONFIG_MISTMATCH)

My VM is currently unusable.

comment:10 Changed 3 years ago by anicka47

Same problem here. I changed the xml file and it remained modified (i.e. did not reset back to "true"), but nothing changed. Had to discard the saved state. Luckily I only lost about 4 hours of work, because I only upgraded VB yesterday.

comment:11 Changed 3 years ago by LoMo

I had the same problem this morning when I tried to open a "saved state" VM (Ubuntu Server).

The simple edit to the .xml file worked for me and it started up just fine after that, but I think I'll be doing full shut-downs from now on, though I have regular back-ups of the VM, just in case.

comment:12 Changed 3 years ago by LoMo

Oh, btw, host system OS X (10.6.6) and (Guest Ubuntu Server 10.10), so this is not a Windows-related issue.

comment:13 Changed 3 years ago by frank

The whole mess comes from allowing the user to start a VM with USB2.0 enabled even if no extension pack is there. This function was meant as convenience but this ticket shows that actually the opposite was achieved. So the next version will not allow to start a VM anymore if USB 2.0 is enabled but no extension pack is installed.

The following is only necessary if you have a VM which you want to start from a saved state. Either a VM to be started from a snapshot or from the last saved state. If your VM does not have any saved state (you start the VM from the powered off state) then either disable the USB2.0 VM setting or install the extension pack and your VM should start.

Otherwise there are two cases:

  1. You have a VM with a saved state containing USB2.0 / EHCI information. The saved state was probably created with an older (PUEL) version of VirtualBox or with VirtualBox version 4.0.x while the Oracle Extension Pack was installed, but now it is missing.
    To get this VM working with VBox 4.0 you have to install the Oracle Extension Pack. Editing the .xml/.vbox file would not help here but only make things worse. After the Oracle Extension Pack is installed your VM should start fine from the saved state.
  1. You have a VM with a saved state which does NOT contain USB2.0 / EHCI information. You started this VM with VBox 4.0.x but ignored the warning about the missing USB2.0 emulation. Later you saved the VM and now you are not able to start from this saved state.
    To get this VM working, you have to edit the settings files like I described above. When fiddling with the .xml / .vbox files, always make sure that no VBoxSVC daemon is running because that daemon is responsible for writing the settings files! If there are snapshots involved, then there is not only one enabledEhci=true in the settings file but there are several. You have to replace ALL occurrences. When this is done, save the settings file, double check that your replacements were really written and start your VM.

comment:14 Changed 3 years ago by krams

If you are getting the error about the device being removed from slot then you did not follow the suggestion to change enableEhci to false exactly as given :). If you had changed the USB enabled = true to USB Enabled = false along with the EHci setting you will get this error. Leave the first one enabled and only change the Ehci setting as mentioned. And do it only in the snapshot you are attempting to run.

comment:15 Changed 3 years ago by csbac

Hi!
Same problem after upgrading opensuse from 11.3 x64 to 11.4, fix didn't help. After a lot of fix tries and reinstallings I found out that the OpenSUSE virtualbox-4.0.4-1.6.1.x86_64 package does NOT support USB 2.0 with extpack installed, booted virtual machines have USB1.1 only, not even USB2 option in config.

Using the Oracle supplied VirtualBox-4.0-4.0.4_70112_openSUSE114-1.x86_64.rpm, it works.

Will post also on opensuse/Novell bugs.

Sebastian

comment:16 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use