VirtualBox

Ticket #8181 (closed defect: obsolete)

Opened 3 years ago

Last modified 2 months ago

OpenGL does not work after upgrade to 4.x

Reported by: piranha32 Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.0.2 Keywords: 3d, acceleration
Cc: Guest type: Windows
Host type: Linux

Description (last modified by misha) (diff)

After upgrade to VirtualBox 4 (Major 4, all minor versions), Sketchup stopped working. I tried to downgrade back to 3.2.12, but it did not help.
Also, other applications using OpenGL, which worked previously, stopped working after upgrade to VB4 with error messages indicating problems with OpenGL.
Downgrade to version 3.2.12 (host app and guest drivers) did not solve the problem. After upgrade of host app back to 4.0.2, leaving 3.2.12 extensions caused all applications to start properly (with a warning message from VB about disabled 3D acceleration).
2D and 3D accelerations are enabled in the VM settings, Memory size for the VM graphics card is set to 128MB (max).

System configuration:
Host:

OS: Linux dragon 2.6.32.26-175.fc12.x86_64 #1 SMP Wed Dec 1 21:39:34 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
Video card: nVidia Corporation G92+ [ GeForce GTS 250 ] 512 MB
Video driver: NVIDIA GLX Module 270.18 Tue Jan 18 22:03:05 PST 2011

Guest:

OS: Windows XP 64bit

Attachments

sketchup error 1.png Download (7.0 KB) - added by piranha32 3 years ago.
Error message #1 from Sketchup
sketchup error 2.png Download (7.1 KB) - added by piranha32 3 years ago.
Error message #2 from Sketchup
VB_WinXP64-2011-01-25-00-42-36.log Download (83.1 KB) - added by piranha32 3 years ago.
VBox.log file
VBoxTestOGL_2D_3D.log Download (11.9 KB) - added by piranha32 3 years ago.
Log file from VBoxTestOGL, 2D and 3D tests

Change History

Changed 3 years ago by piranha32

Error message #1 from Sketchup

Changed 3 years ago by piranha32

Error message #2 from Sketchup

Changed 3 years ago by piranha32

VBox.log file

Changed 3 years ago by piranha32

Log file from VBoxTestOGL, 2D and 3D tests

comment:1 Changed 3 years ago by piranha32

After switching off 3D acceleration in VM properties, applications started working (w/o acceleration).

comment:2 Changed 6 months ago by misha

  • Description modified (diff)

Could you check if the issue is still present with VBox 4.3 and 4.3 Guest Additions?
If it is - please attach a fresh VM log file here.

comment:3 Changed 2 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use