VirtualBox

Ticket #784 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Keyboard focus lost when minimizing and restoring virtualbox window => Fixed in SVN

Reported by: whoisrich Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Both the host and guest are Windows XP, I have not tried any other O/S.

Steps to re-create:

  1. Start guest O/S and open notepad.
  1. Single click virtualbox in the taskbar to minimize.
  1. Single click virtualbox in the taskbar to restore.
  1. Try and type something in the guest O/S notepad.

Things to note:

The problem seems to be that when the window is restored, the keyboard focus is on the virtualbox window rather than the guest. This can be confirmed by pressing ALT which activates the keyboard shortcuts for the virtualbox menu.

To regain focus you have to press ALT twice or click somewhere on the host O/S and then click back into the guest O/S.

I believe this to be a defect as using the minimize icon or minimizing by right clicking virtualbox in the taskbar, does not cause the problem.

Change History

comment:1 Changed 6 years ago by whoisrich

This is still an issue in Virtualbox 1.5.4.

comment:2 Changed 6 years ago by frank

Please try again with VirtualBox 1.5.6.

comment:3 Changed 6 years ago by whoisrich

Still an issue with VirtualBox 1.5.6

comment:4 Changed 6 years ago by hege

Vista host, XP guest.

VBox 1.5.6 constantly fails to capture/release keyboard. Sometimes partially, so alt-gr does not work for example.

comment:5 Changed 6 years ago by hege

Seems to be finally fixed in 1.6.0. Yay.

comment:6 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:7 Changed 6 years ago by whoisrich

  • Status changed from closed to reopened
  • Resolution fixed deleted

Ive upgraded to 1.6.0 and this problem has NOT been fixed.

Open notepad, type something, minimize and maximize the window using single clicks on the taskbar, then try to type and it will not work as focus is on the virtualbox frame and not on the guest o.s. within.

Re-opening the ticket.

comment:8 Changed 6 years ago by hege

Yup it seems it isn't completely fixed. It does occur a lot less with me though. I have no idea if there was even any fixes made in 1.6.0, but I would suppose so? Or then it was a side effect of something.

comment:9 Changed 6 years ago by whoisrich

This is still an issue in Virtualbox 1.6.2

comment:10 Changed 6 years ago by whoisrich

Still an issue with Virtualbox 1.6.4

comment:12 Changed 5 years ago by hege

I'm constantly losing AltGr key, I guess it happens even more when I have two VB running. I have to go to each one and maximize/minimize/type something in them to get it working again.

comment:13 Changed 5 years ago by hege

To be exact, to regain AltGr in host, I maximize VB guest and minimize it using the titlebar button.

comment:14 Changed 5 years ago by whoisrich

This is still an issue in 2.0.4 :(

comment:15 Changed 5 years ago by frank

  • Host type changed from other to Windows
  • Version changed from VirtualBox 1.5.0 to VirtualBox 2.0.4
  • Component changed from other to GUI

comment:16 Changed 5 years ago by frank

  • Summary changed from Keyboard focus lost when minimizing and restoring virtualbox window to Keyboard focus lost when minimizing and restoring virtualbox window => Fixed in SVN

Should be fixed in next version.

comment:17 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:18 Changed 5 years ago by whoisrich

Tested the release of 2.0.6 and problem is solved as you said it would be.

Thank you so much :D

comment:19 Changed 5 years ago by dmaker

  • Status changed from closed to reopened
  • Resolution fixed deleted

Not fixed. Still bugging with 2.1.2.

My problem steps to reproduce:

1) Start a guest OS (in my case: WinXP Pro SP3)

2) Put it in pause mode after the desktop and all systray stuff is loaded

3) Minimize the window to taskbar (clicking taskbar button)

4) Open Notepad in host (or dos prompt, etc. everything goes where you can input characters)

5) Press AltGr + 7

BUG: a number "7" is shown on the screen

-> should show a { (curly bracket) character (with my Finnish keyboard).. you can try any AltGr combination, it doesn't work when the paused OS window is minimized to the taskbar. After you have paused & resumed the OS window, it still blocks the AltGr key when minimized.. without any pauses initiated, the minimize works without blocking the AltGr.

!!! Only when you minimize the window using the button in the task bar. Clicking on the window minimize button works fine. !!!

Note to moderators: the #2410 (marked already as a duplicate (of this ticket)), #373 & #108 tickets are duplicates (or all are duplicates of the first ticket.. whatever).

comment:20 Changed 5 years ago by dmaker

Seems to be fixed now. Running 3.0.0. It was fixed in between versions 2.1.2 - 3.0.0.

comment:21 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use