VirtualBox

Ticket #108 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

keyboard stays grabbed when vbox has no focus

Reported by: xerces8 Owned by:
Priority: minor Component: other
Version: VirtualBox 1.3.6 Keywords:
Cc: Guest type: other
Host type: other

Description

Sometimes vbox keeps the keyboard even if the user switched focus to other applications.

These step reproduce the problem on my system (Win2000 SP4, vbox 1.3.6):

  • have some windows open (notepad , firefox etc)
  • have virtualbox started and start one virtual machine (I had windows running inside it, without vbox additions, since it was a new install)
  • host Windows task bar is set to "AutoHide" (I don't know if this is important)
  • type something in notepad
  • move the mouse to the bottom, so that the task bar appears
  • click the virtual guest window on the task bar
  • wait a few seconds (do not move the mouse pointer away from the task bar)
  • click the same button again

now the focus is back in the notepad window, but the keys do not work, the are grabbed by virtual box

Change History

comment:1 Changed 7 years ago by xerces8

It does not seem to happen when the mouse addition is installed. I tried it today and it did not happen. But the then I disabled the Mouse addition (menu VM/Disable Mouse Integration) and then I could reproduce it.

comment:2 Changed 7 years ago by xerces8

Update: Happens with additions too.

Also today it happened, that all the keys worked, except "AltGr" (the right Alt).

Also, sometimes vbox guest does not have the keyboard. I have to click in out to fix things.

Is it really that hard to track when the vbox window has focus and when not ?

comment:3 Changed 7 years ago by xerces8

OK, I reproduced this on a fresh install of WinXP pro SP2, first time install of vbox 1.3.6. That is : this is another PC, with a one month old Windows installation, vbox was never installed on it.

  • install vbox 1.3.6, default settings
  • start it
  • create a new VM, type : Windows 2003; all defaults (no disk)
  • start it
  • dismiss the dialog about grabbing the kbd
  • click inside the running VM window
  • dismiss the dialog about grabbing the mouse
  • release mouse by pressing right ctrl
  • select a window of notepad
  • on the task bar, click the VM window
  • click it again

Result:

  • focus is in notepad, but keys are grabbed by vbox

comment:4 Changed 7 years ago by frank

Please could you retry with VirtualBox 1.4.0?

comment:5 Changed 7 years ago by xerces8

I tried with 1.4.0 and I could not reproduce the problem. Appears to be fixed.

comment:6 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thank you for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use