VirtualBox

Ticket #2410 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

Alt Car key not working after minimizing a guest => Fixed in SVN

Reported by: mkdav Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

How to reproduce:

  1. Use the french canadian layout keyboard.
  2. Launch a guest OS.
  3. Minimize the virtualbox guest window.
  4. Try to use the AltCar key to write symbols such as @£¢¤¬. The AltCar key press is not recognized.
  5. focus back to the previously minimized window. The keyboard isn't captured and won't be until you do something in the menus.

This is pretty annoying, as the AltCar key is really useful in french canadian keyboards. Switching to another window without minimizing the guest virtualbox window works as expected.

Attachments

VBox.log.3 Download (62.6 KB) - added by mkdav 6 years ago.
The vbox.log file

Change History

comment:1 Changed 6 years ago by mkdav

A flash video is available on  http://screencast.com/t/jtKzIm6uW06 .

comment:2 Changed 6 years ago by frank

  • Component changed from other to GUI
  • Description modified (diff)

comment:3 Changed 6 years ago by frank

Please could you attach the VBox.log file of a VM session? Maybe there is some debugging output.

Changed 6 years ago by mkdav

The vbox.log file

comment:4 Changed 6 years ago by mkdav

I've noticed that bug happens only when you minimize the window using the button in the task bar. Clicking on the window minimize button works fine.

comment:5 Changed 5 years ago by csmate

Same problem here. The AltGr key is not working after minimizing the VirtualBox guest window by clicking on the taskbar icon. Using the system menu or clicking the minimize button works fine.

Turning the "Auto Capture Keyboard" option off does not help.

  • Hungarian Windows XP Pro host
  • VirtualBox 2.0.4
  • Right control set as host key

comment:6 Changed 5 years ago by frank

  • Summary changed from Alt Car key not working after minimizing a guest to Alt Car key not working after minimizing a guest => Fixed in SVN

We were able to reproduce the problem and fixed it (hopefully) properly. The next release will contain the fix.

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I will close this one as duplicate of #784.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use