VirtualBox

Ticket #2411 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Unpredictable, but repeatable VirtualBox crash - WinXP guest, browsing UNC => Fixed in 2.0.4

Reported by: myxiplx Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I have twice had VirtualBox crash in exactly the same way. I'm running a Windows XP Pro guest (SP2), on a Windows 2000 domain, and VirtualBox crashed when I entered a UNC path in the Run box.

The crash appears very intermittent as I can usually do this dozens of times with no problems, but eventually something seems to kill VirtualBox. Unfortunately it's going to be hard to reproduce as the first time it happened after the guest was running for two days, the second time it had been running for nearly four days.

The crash was caused by:

  • click Start
  • click Run
  • Enter a UNC path (the two causing crashes for me were both of the form \machine\c$)
  • Click Go

At this point VirtualBox instantly crashes and I'm left with a blank screen (in Fullscreen mode). Pressing Host+F takes me back to the main VirtualBox GUI, with a grey screen where my WinXP guest should be.

I attempted to do an ACPI shutdown of the guest (just in case it was a GUI issue), but the Virtualbox interface closed immediately when I did that, making me think the guest had in fact crashed completely.

I have the Virtualbox logs from both crashes if they are of any use, and I originally posted this on the forums here:  http://forums.virtualbox.org/viewtopic.php?p=41694#41694

I'm running VirtualBox on Ubuntu 8.04 (with all patches to around 1st Oct), and my guest is Windows XP pro SP2.

Ross

Attachments

VBox (copy) - second crash.log Download (137.0 KB) - added by myxiplx 6 years ago.
Log of second crash
VBox (copy) - windows crash.log Download (152.3 KB) - added by myxiplx 6 years ago.
Log of first crash

Change History

Changed 6 years ago by myxiplx

Log of second crash

Changed 6 years ago by myxiplx

Log of first crash

comment:1 Changed 6 years ago by ariel

I seem to be having the same (or a similar) problem.

I've been having this annoying problem since I upgraded to VBox 2.02 about 4 weeks ago.

This is under Ubuntu 8.04 (fully up to date). The guest is Windows XP SP3, also fully up to date.

The problem are sudden crashes of the VBox guest window (and application). The crash seems to be somewhat network related. Typically when opening firefox, or when clicking a link in firefox or opening a new tab, or when trying to copy and paste a file to a shared network folder, or saving an outlook email attachment to a shared network folder.

I see logs generated by VBox in my linux home folder, but the logs appear to be generated upon VBox launch, so not sure if they are related to the crash, they all look like this:

Log created: 2008-10-14T19:28:39.113373000Z Executable: /usr/lib/virtualbox/VirtualBox Arg[0]: /usr/lib/virtualbox/VirtualBox Arg[1]: -comment Arg[2]: VBWK Arg[3]: -startvm Arg[4]: d8d080d9-7aa7-451d-b889-bc3a9116e970

!!Assertion Failed!! Expression: <NULL> Location : /home/vbox/vbox-2.0.2/src/VBox/Devices/Network/slirp/tcp_subr.c(1341) VBoxU32PtrHashSlow NAT pointer hash error. pv=0000000000a88010 cpvHashUsed=66 cpvHashCollisions=198

comment:2 Changed 6 years ago by frank

  • Summary changed from Unpredictable, but repeatable VirtualBox crash - WinXP guest, browsing UNC to Unpredictable, but repeatable VirtualBox crash - WinXP guest, browsing UNC => Fixed in 2.0.4

myxiplx, your problem is an assertion within the guest additions which are fixed in 2.0.4. ariel, your problem is very different and a duplicate of #1046. A solution is currently being working on but 2.0.4 will still not contain the fix for it. Nevertheless I will make this defect as fixed as your problem is different from the original problem.

comment:3 Changed 6 years ago by myxiplx

Wow. Initially I wasn't too impressed with Virtualbox with it crashing all the time, but can't complain at all when the bug is replied to and fixed within 6 days. :-)

Thanks guys, your work on this is very much appreciated.

comment:4 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use