VirtualBox

Ticket #783 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

VirtualBox hogs memry when copying files -> fixed in SVN

Reported by: adamklobukowski Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords: memory leask shared folders
Cc: Guest type: other
Host type: other

Description

I'm trying to copy lots of small files (25000+ files, total size about 1GB) using Shared Folder with Linux as host and Windows XP as guest. I've set VM to have 512MB of RAM, and at the beginning, VirtualBox does not use much more. But after about 20% of files is copied, it starts to eat a lot of ram (it was 1.2GB when I stopped it), finally eating all available RAM.

Looks like there is a serious memory leak in shared folders code.

Attachments

VBox (copia).log.3 Download (73.0 KB) - added by donaldshimoda 4 years ago.
Version 3.2.2 log with problems
VBox.log Download (80.8 KB) - added by donaldshimoda 4 years ago.
Version 3.1.18 , same machine, working as expected

Change History

comment:1 Changed 7 years ago by sandervl73

comment:2 Changed 7 years ago by sandervl73

  • Reporter changed from adamklobukowski@… to adamklobukowski

comment:3 in reply to: ↑ description Changed 6 years ago by Lelik

Replying to adamklobukowski:

Looks like there is a serious memory leak in shared folders code.

If I understand correctly you have problem with version 1.5.0. Could you try VirtualBox and additions version 1.5.2?

comment:4 Changed 6 years ago by sandervl73

  • Summary changed from VirtualBox hogs memry when copying files to VirtualBox hogs memry when copying files -> fixed in SVN

comment:5 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:6 Changed 4 years ago by donaldshimoda

  • Status changed from closed to reopened
  • Resolution fixed deleted

Seems like this bug is here AGAIN version 3.2.2. Im compiling over a shared folder, the memory start growing up.

Im using a ubuntu 10.04 64 bits HOST 4GB RAM, and a XP 32 bits SP3 guest 1 GB RAM VM.

At start it only takes 33% of HOST SYSTEM MEMORY. When i compile a application inside my VM using a lot SHARED FOLDER, the memory grow in chunks of 10% , and end eating all my HOST SYSTEM MEMORY. If i suspend the VM after it get 100% of HOST memory, and restart, it use again only 33% of the memory.

I will downgrade rigth now to 3.1.x because it dont have this memory leak.

comment:7 follow-up: ↓ 8 Changed 4 years ago by frank

Please attach a VBox.log file of such a VM session.

comment:8 in reply to: ↑ 7 Changed 4 years ago by donaldshimoda

Replying to frank:

Please attach a VBox.log file of such a VM session.

I already downgrade to version 3.1.18, and the problem gone. My memory stay at 33% of host mempry, dont matter how much i use shared networks.

Changed 4 years ago by donaldshimoda

Version 3.2.2 log with problems

Changed 4 years ago by donaldshimoda

Version 3.1.18 , same machine, working as expected

comment:9 Changed 4 years ago by donaldshimoda

I mean version 3.1.8 , sorry.

comment:10 Changed 4 years ago by frank

Currently I'm not that sure that this problem results from the extensive usage of shared folders as I'm not aware of a related change in the moment (I might be wrong of course). Are you sure that this leak couldn't be the result of something else, for instance some guest 2D operations which are performed in parallel to your compile job? Sorry for asking this, but currently we are trying to reproduce this issue somehow.

comment:11 Changed 4 years ago by donaldshimoda

Actually i dont know the exact cause, I just reporting my impresions. OTOH, there no another thing than Delphi 2010 IDE running and compiling. That cause the memory grow, as the compile is on shared folders i suspected was related.

comment:12 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if this problem is still present with VBox 3.2.6 (don't forget to update the guest additions as well). We think we fixed related memory leaks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use