VirtualBox

Ticket #6262 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Can't attach USB Device: Google Nexus One => Fixed in SVN/3.1.6

Reported by: discoltk Owned by:
Priority: major Component: USB
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Solaris

Description

I am having a very similar problem as described in ticket #5873 while attaching a Nexus One to my Windows guest under OpenSolaris. I'm running VirtualBox 3.1.4 r57640 under svn_133.

Even when I have a filter created, VBox won't capture my Nexus One usb device.

I can sometimes get it to work with the following steps, although only sometimes will it work:

1) Close down vbox 2) modunload vboxusb and vboxusbmon 3) start vboxmanager (this reloads the module automaticaly), create the filter 4) detach device 5) start vbox guest instance 6) attach device

SOMETIMES (maybe 10% of the time), vbox is able to beat usba in the race to capture the device.

If and when I do get it to attach, if I need to disconnect the device while running vbox, it will fail to recapture it, and on subsequent launches of vbox it will not capture it.

Unloading the modules again in some cases has worked, but usually the "Current State" from list usbhost goes from "Held" to "Busy", possibly stopping at "Captured" briefly, although it won't actually attach under vbox and will go back to "Busy".

Change History

comment:1 Changed 4 years ago by ramshankar

Thanks for creating a new report.

You should never have to fiddle with the VirtualBox kernel modules. So don't do any modunload/modload with them.

Secondly, with a filtered approach there is no race between VirtualBox and USBA. USBA always asks VirtualBox first. So could you list the USB filter you've setup for the VM i.e. "VBoxManage showvminfo <the-vm-with-filters>"?

Also please show me the output of "tail -500f /var/adm/messages | grep vbox" once you tried to connect the device after setting up the filter.

comment:2 Changed 4 years ago by discoltk

Index:            0
Active:           yes
Name:             Google, Inc. Nexus One [0226]
VendorId:         18d1
ProductId:        4e12
Revision:         0226
Manufacturer:     Google, Inc.
Product:          Nexus One
Remote:           no
Serial Number:    HT9CMP800672


Feb 22 07:08:41 he3 genunix: [ID 408114 kern.info] /pci@0,0/pci10de,cb79@6,1/storage@2 (scsa2usb0) removed
Feb 23 19:16:39 he3 vboxdrv: [ID 703102 kern.notice] vboxusbmon: Capturing Nexus One 0x18d1:0x4e12:/pci@0,0/pci10de,cb79@6,1/device
Feb 23 19:16:39 he3 genunix: [ID 408114 kern.info] /pci@0,0/pci10de,cb79@6,1/device@2 (vboxusb4) online
Feb 23 19:16:39 he3 genunix: [ID 408114 kern.info] /pci@0,0/pci10de,cb79@6,1/device@2 (vboxusb4) removed
Feb 23 19:16:40 he3 usba: [ID 912658 kern.info] USB 2.0 device (usb18d1,4e12) operating at hi speed (USB 2.x) on USB 2.0 root hub: device@2, usb_mid13 at bus address 2
Feb 23 19:16:40 he3 usba: [ID 349649 kern.info] 	Google, Inc. Nexus One HT9CMP800672
Feb 23 19:16:40 he3 genunix: [ID 936769 kern.info] usb_mid13 is /pci@0,0/pci10de,cb79@6,1/device@2
Feb 23 19:16:40 he3 genunix: [ID 408114 kern.info] /pci@0,0/pci10de,cb79@6,1/device@2 (usb_mid13) online
Feb 23 19:16:40 he3 usba: [ID 349649 kern.info] usba:	no driver found for interface 1 (nodename: 'interface') of Google, Inc. Nexus One HT9CMP800672
Feb 23 19:16:40 he3 usba: [ID 912658 kern.info] USB 2.0 interface (usbif18d1,4e12.config1.0) operating at hi speed (USB 2.x) on USB 2.0 root hub: storage@0, scsa2usb4 at bus address 2
Feb 23 19:16:40 he3 usba: [ID 349649 kern.info] 	Google, Inc. Nexus One HT9CMP800672
Feb 23 19:16:40 he3 genunix: [ID 936769 kern.info] scsa2usb4 is /pci@0,0/pci10de,cb79@6,1/device@2/storage@0
Feb 23 19:16:40 he3 genunix: [ID 408114 kern.info] /pci@0,0/pci10de,cb79@6,1/device@2/storage@0 (scsa2usb4) online
Feb 23 19:16:40 he3 scsi: [ID 583861 kern.info] sd6 at scsa2usb4: target 0 lun 0
Feb 23 19:16:40 he3 genunix: [ID 936769 kern.info] sd6 is /pci@0,0/pci10de,cb79@6,1/device@2/storage@0/disk@0,0
Feb 23 19:16:40 he3 genunix: [ID 408114 kern.info] /pci@0,0/pci10de,cb79@6,1/device@2/storage@0/disk@0,0 (sd6) online

comment:3 Changed 4 years ago by ramshankar

Feb 23 19:16:39 he3 vboxdrv: [ID 703102 kern.notice] vboxusbmon: Capturing Nexus One 0x18d1:0x4e12:/pci@0,0/pci10de,cb79@6,1/device
Feb 23 19:16:39 he3 genunix: [ID 408114 kern.info] /pci@0,0/pci10de,cb79@6,1/device@2 (vboxusb4) online
Feb 23 19:16:39 he3 genunix: [ID 408114 kern.info] /pci@0,0/pci10de,cb79@6,1/device@2 (vboxusb4) removed

This shows the USB filter matched and the USB monitor did indeed take over the device, but for some reason it was "removed" which means the Solaris part of it still works. After some debugging I noticed this is a generic (not Solaris specific) 3.14 regression on all hosts. The problem has been fixed and should be part of the next release.

Thanks a lot for the report and logging info.

comment:4 Changed 4 years ago by ramshankar

  • Summary changed from Can't attach USB Device: Google Nexus One to Can't attach USB Device: Google Nexus One => Fixed in SVN/3.1.6

comment:5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #6251

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use