VirtualBox

Ticket #5873 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Can't attach USB Device: Apple iPod => fixed in SVN

Reported by: morettoni Owned by:
Priority: major Component: USB
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Windows
Host type: Solaris

Description

Under OpenSolaris (build snv_129) with VirtualBox 3.1.2 I can't attach my iPod nano with:

VBoxManage controlvm "WinXP Test" usbattach 693ac8db-a638-46cd-9a09-b5643db1fb36

and the output of "VBoxManage list usbhost" is:

UUID:               693ac8db-a638-46cd-9a09-b5643db1fb36
VendorId:           0x05ac (05AC)
ProductId:          0x1262 (1262)
Revision:           0.1 (0001)
Manufacturer:       Apple Inc.
Product:            iPod
SerialNumber:       000A27001B670D71
Address:            0x5ac:0x1262:1:/pci@0,0/pci1179,1@1a,7
Current State:      Captured

but no iPod under windows! Thanks for the help!

PS: tell me if you need more logs or test...

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by ramshankar

  • Summary changed from Can't attach USB Device: Apple iPod to Can't attach USB Device: Apple iPod => fixed in SVN

This is a known issue and has already been fixed internally, unfortunately the fix came a few minutes after 3.1.2 was released. Hence the fix for making the iPod work will be part of the subsequent release.

Thanks for reporting though.

comment:2 in reply to: ↑ 1 Changed 4 years ago by morettoni

Replying to ramshankar:

This is a known issue and has already been fixed internally, unfortunately the fix came a few minutes after 3.1.2 was released. Hence the fix for making the iPod work will be part of the subsequent release. Thanks for reporting though.

thanks to you too, hope to get the next relase asap (or there are some "internal" build to try?)

comment:3 follow-up: ↓ 4 Changed 4 years ago by ramshankar

Uploaded a test build for you here:  http://www.virtualbox.org/download/testcase/VirtualBox-3.1.3-SunOS-r56280.tar.gz

The link expires in 14 days. Just to be sure you're testing the new version, check the output of "modinfo | grep vb". Thank you for your feedback.

comment:4 in reply to: ↑ 3 Changed 4 years ago by morettoni

Replying to ramshankar:

Uploaded a test build for you here:  http://www.virtualbox.org/download/testcase/VirtualBox-3.1.3-SunOS-r56280.tar.gz

The link expires in 14 days. Just to be sure you're testing the new version, check the output of "modinfo | grep vb". Thank you for your feedback.

installed:

$ modinfo | grep vb
190 fffffffff7e087f0    a88 288   1  vboxnet (VirtualBox NetAdp 3.1.3r56280)
192 fffffffff7d23000  24de8 287   1  vboxdrv (VirtualBox HostDrv 3.1.3r56280)
239 fffffffff7ffab00   6a20 289   1  vboxflt (VirtualBox NetDrv 3.1.3r56280)
239 fffffffff7ffab00   6a20   -   1  vboxflt (VirtualBox NetMod 3.1.3r56280)
240 fffffffff8001150   4598 290   1  vboxusbmon (VirtualBox USBMon 3.1.3r56280)
241 fffffffff8903000   6e98 292   1  vboxusb (VirtualBox USB 3.1.3r56280)

but no effect:

list usbhost reports this:

UUID:               d37a1c74-b3bb-4ffa-9773-77a9eb5b494f
VendorId:           0x05ac (05AC)
ProductId:          0x1262 (1262)
Revision:           0.1 (0001)
Manufacturer:       Apple Inc.
Product:            iPod
SerialNumber:       000A27001B670D71
Address:            0x5ac:0x1262:1:/pci@0,0/pci1179,1@1a,7
Current State:      Busy

if I attach it:

$ VBoxManage controlvm "WinXP Test" usbattach d37a1c74-b3bb-4ffa-9773-77a9eb5b494f
VirtualBox Command Line Management Interface Version 3.1.3
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

the state changes to "Captured" but I don't have any device under windows, and the menu Devices->USB Devices the iPod is not flagged; same effect if I try to flag it with the menu.

comment:5 follow-up: ↓ 6 Changed 4 years ago by ramshankar

With your iPod plugged in, setup a USB filter for the VM. Then unplug your iPod, start your VM and replug it in a few seconds later.

Solaris does not let go of the iPod and is rather a shortcoming of the Solaris USBA/device detachment subsystem than VBox's fault, certain devices like the iPod need USB filters.

comment:6 in reply to: ↑ 5 Changed 4 years ago by morettoni

Replying to ramshankar:

With your iPod plugged in, setup a USB filter for the VM. Then unplug your iPod, start your VM and replug it in a few seconds later.

thanks, now all work fine, I just sync my iPod! great!!!!

comment:7 Changed 4 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed

comment:8 Changed 4 years ago by discoltk

I seem to have a very similar problem as described in this ticket while attaching a Nexus One to my Windows guest under OpenSolaris. I'm running VirtualBox 3.1.4 r57640 under svn_133.

I can sometimes get it to work with the following steps, although only sometimes will it work:

1) Close down vbox 2) modunload vboxusb and vboxusbmon 3) start vboxmanager, create the filter 4) detach device 5) start vbox guest instance 6) attach device

SOMETIMES (maybe 10% of the time), vbox is able to beat usba in the race to capture the device. If and when I do get it to attach, if I need to disconnect the device while running vbox, it will fail to recapture it, and on subsequent launches of vbox it will not capture it.

Unloading the modules again in some cases has worked, but usually the "Current State" from list usbhost goes from "Held" to "Busy", possibly stopping at "Captured" briefly, although it won't actually attach under vbox and will go back to "Busy".

I can open a new case if necessary, however this seems to be the same or similar behavior as was intended to be fixed by this ticket's resolution.

Thanks!

comment:9 Changed 4 years ago by ramshankar

Please consider opening a separate defect, and "2) modunload vboxusb and vboxusbmon" is not something you should ever have to do and in your list of steps you don't mention where you re-load these modules.

Could you please open a new defect with the details? Thank you.

comment:10 Changed 4 years ago by discoltk

Ok I'll open another one. The modules are loaded by VBoxManage and by the gui. There is no need to manually load them.

comment:11 Changed 4 years ago by rbalada

Please check if your fixes are not related to regression in ticket #6251  http://www.virtualbox.org/ticket/6251

Thanks

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use