VirtualBox

Ticket #6189 (closed defect: fixed)

Opened 4 years ago

Last modified 17 months ago

Zombie state if disk full => Fixed in SVN

Reported by: wacher Owned by:
Priority: minor Component: VM control
Version: VirtualBox 4.0.4 Keywords: save state
Cc: Guest type: Windows
Host type: Windows

Description

If you want to close your VM, but have not enough space to save machine state, the VM will be suspended. But you can't resume, can't close, can't do nothing. You have to kill the appropriate VirtualBox.exe process and VM will be 'aborted'.

Attachments

VBox.log.1 Download (51.6 KB) - added by wacher 4 years ago.

Change History

Changed 4 years ago by wacher

comment:1 Changed 3 years ago by frank

Still relevant with VBox 4.0.4?

comment:2 follow-up: ↓ 6 Changed 3 years ago by McNetic

Of course this is still relevant. How should the problem have vanished? You could test this by yourself easily be starting a virtual machine, removing write permissions to the directory it is stored in, and then trying to stop it with saving state. More information can be found in #6232.

comment:3 Changed 3 years ago by frank

  • Version changed from VirtualBox 3.1.4 to VirtualBox 4.0.4

Well, there were many changes in the related code between 3.1.4 and 4.0.4. Well, I just saw one reporter with VBox 3.2.10 so my question was indeed superfluous...

comment:4 Changed 3 years ago by wacher

The problem is still relevant in r71573.

comment:5 Changed 3 years ago by wacher

The problem is still relevant in 4.0.10 (see ticket #9180)

comment:6 in reply to: ↑ 2 Changed 3 years ago by Aslo

Happens to me with VirtualBox 4.1.0 on Ubuntu 64 bit Host / Windows XP 32bit Guest. I can provide logs if useful.

comment:7 Changed 2 years ago by ilyail3

Also active on Windows7 64bit host, can't we abort suspend, meaning leave the session as is?

comment:8 Changed 2 years ago by Csq

Bug still exists in 4.1.12

Why is this minor priority? One can easily lose data.

comment:9 Changed 2 years ago by McNetic

Especially as the fix should be pretty straightforward...

comment:10 Changed 2 years ago by frank

Patches are welcome. The fix isn't as easy as someone might expect. I think all we can do is to set the VM into a paused state, warn the user and allow him to free some disk space. I understand that the current behavior is annoying but on the other side, every modern operating system has a warning mechanism for low-disk space, therefore the user is warned before this can happen. Nevertheless we will work on a fix (as I said, useful patches can speed up this process).

comment:11 Changed 2 years ago by wacher

I don't know what kind of fix do you think, a notification is more than enough. No space? The VBox don't complete its job. OK. The the main problem is the "zombie state".

If I ran out of free space, okay, I understood, abort the current job, drop the incomplete .sav file. That would be fine, but now I lose control of VM.

comment:12 Changed 2 years ago by frank

  • Summary changed from Zombie state if disk full to Zombie state if disk full => Fixed in SVN

Well, I think we fixed the behavior properly and the fix will be included in the next maintenance release.

comment:13 Changed 2 years ago by wacher

It would be great, thank you.

comment:14 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VirtualBox 4.1.16.

comment:15 Changed 18 months ago by Ivan Perez

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm using VirtualBox 4.1.8r75467, this error is still present. I can't find any way to resume or close the vm.

comment:16 Changed 18 months ago by Ivan Perez

(My apologies, misread the 4.1.16 for 4.1.6. Please, close the ticket, seeing as I can't do it myself.)

comment:17 Changed 17 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use