VirtualBox

Ticket #6232 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Virtual machine hangs after trying to close with saving when disk is full

Reported by: McNetic Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.4 Keywords: suspend, save
Cc: Guest type: Windows
Host type: Windows

Description

I did the following:

  • closed a running virtual machine
  • chose 'save state' in the upcoming dialog
  • encountered error 'disk full' (the disk was really full), causing machine to stuck in suspended mode
  • freed up enough disk space (some hundred gb anyways)
  • tried to close virtual machine again - window does not react to any input
  • tried resume virtual machine from main window - encountering error VBOX_E_INVALID_VM_STATE

Appearently, after the 'disk full' error, the internal suspend state is not set 100% correctly. It should be possible to resume the machine or at least to try to continue saving the state. Currently, killing the process and losing state is the only way out.

Attachments

Windows 7 x64-2010-02-18-13-32-43.log Download (47.9 KB) - added by McNetic 4 years ago.
vbox.log file
VBox.log Download (38.6 KB) - added by jayen 3 years ago.
Ubuntu Lucid - Windows XP.log

Change History

Changed 4 years ago by McNetic

vbox.log file

comment:1 Changed 4 years ago by rickylau

Same @ Host: Windows XP (x86), Guest: any, VirtualBox 3.2.4 & 3.2.6

Any (seems to be) error in saving state will cause that error (At least I tried disk full / read-only)

Changed 3 years ago by jayen

Ubuntu Lucid - Windows XP.log

comment:2 Changed 3 years ago by jayen

Same problem. Host: Ubuntu Lucid with vbox 3.2.10. Guest Windows XP with guest additions. Log attached.

After this: 00:31:41.259 Changing the VM state from 'SAVING' to 'SUSPENDED'.

In the machine menu in the VM window, only the "Close" option isn't greyed out, but has no effect. In the manager window, resuming or pausing gives an error.

comment:3 Changed 3 years ago by wacher

duplicate of #6189

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use