VirtualBox

Ticket #6188 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Seamless Mode Broken on Win 7 Host -> fixed after 3.1.4

Reported by: jcwi65 Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I have not had any issues with seamless mode until now. I set up Vista in the VM and running on Windows 7 host. When switching to seamless the process attempts to start and then return to the normal window. Full screen works fine.

Change History

comment:1 Changed 4 years ago by plaintiger

i'm seeing this too on the Mac host, except if the process is attempting to start, i don't see that. i just select "Seamless Mode" from the contextual menu, or press Host + L, and nothing happens. no checkmark next to the contextual menu item and no change in my display.

comment:2 Changed 4 years ago by plaintiger

oh, and i'm running a win 7 guest, btw, in case that matters.

comment:3 Changed 4 years ago by jpbro

I'm also experiencing this problem after installing 3.1.4 on a Windows 7 Host and a Windows 2000 Guest OS.

Like the original submitter, when pressing Host+L, the window flickers as if it is going to go to seamless mode, but then reverts to windowed mode. Full-screen mode works perfectly.

Using the Machine menu > Seamless Mode has the same result as Host+L (flicker, then back to windowed mode).

In the forum, Perryg mentioned to try clicking the Host+L key twice, but unfortunately this doesn't correct the problem on my system. That thread is here:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=27959&start=0

comment:4 Changed 4 years ago by jpbro

I just noticed Ticket #6185, and it seems that moving the windows task bar to the bottom of the screen has solved the problem for me. I do however prefer to have my taskbar on the side of the screen, and VBox used to work in seamless mode with this configuration (but it is broken in 3.1.4). Hopefully this will help jcwi65 and plaintiger temporarily.

comment:5 Changed 4 years ago by tdchadwick

Host: MacBook Pro with OSX 10.6.2 VM: Windows 7 Professional

I too upgraded from 3.1.2 to 3.1.4. Had Seamless mode working just fine prior to upgrade. After upgrade, also installed Guest Additions update to 3.1.4. Seamless shows enabled but clicking on Seamless or Cmd-L causes screen to flick to full screen, but Guest OS does not resize to full. Reinstalled Guest Additions (I'm assuming this is where the problem lies) with same result after system restart.

Trying Cmd-L, multiple times just causes the screen to flicker each time, but with same result.

comment:6 Changed 4 years ago by jcwi65

I went back to 3.1.2, that one works just fine.

comment:7 Changed 4 years ago by tjhouser

Host: Mac OS Snow Leopard Guest is Win XP

Seamless was working fine in 3.1.2 stopped working with update.

Screen flickers, but stays in windowed mode. Task bar is on bottom. I tried the suggested double Host+L, but this affects no change.

comment:8 Changed 4 years ago by alexandrnevski

I can also confirm the same bug. Host Windows 7 HP, guest Windows XP SP3, Vbox - 3.1.4

comment:9 Changed 4 years ago by gkatona

Same problem here with 3.1.4 only. I am using ubuntu 9.10 as host and windows 7 as guest. It is probably a very subtle problem, because with freshly installed ubuntu 9.10 the problem does not appear (I tested it on a different machine).

comment:10 Changed 4 years ago by michael

  • Summary changed from Seamless Mode Broken on Win 7 Host to Seamless Mode Broken on Win 7 Host -> fixed after 3.1.4

We found the problem and fixed this.

comment:11 Changed 4 years ago by jpbro

Thank you very much!

comment:12 Changed 4 years ago by tdchadwick

Michael, you changed the status of this problem ticket, but did not provide a solution. Care to enlighten us on the fix? ...or am I missing something here?

comment:13 Changed 4 years ago by michael

Of course. Bear with me though, this is somewhat technical. The problem was an attempt to fix something else. Sometimes a guest changes its resolution - outside of our control - while seamless is active. Since this rather messes up seamless, we made a change that exits seamless if the guest switches to a resolution different to the host one. However, if the Windows task bar is at the side of the screen, then the host screen width without the taskbar becomes shorter, and the new width is not a multiple of eight. Most guests don't like screen widths which aren't a multiple of eight, so they adjust their resolution slightly, which in turn made VirtualBox exit from seamless. The fix is pretty simple - we just added a bit of tolerence when we check the guest width.

This fix will be in any VirtualBox versions after 3.1.4.

Did I express that more or less understandably?

comment:14 Changed 4 years ago by jamin

I have same problem with Seemless mode on Linux ubuntu 9.10 host with a windows xp guest. I tryed moving task bar to bottom of screen in the guest but that didn't fix it either. I might go back to 3.1.2

comment:15 Changed 4 years ago by michael

Ticket #6244 has been marked a duplicate of this one.

comment:16 Changed 4 years ago by tdchadwick

Michael, Thanks for the technical explanation. I am new to this forum and did not recognize you as a VirtualBox Rep. I thought you were another user who had figured out a solution and was hoping you'd elaborate. My apologies. However, I greatly appreciated your response and am looking forward to the next release.

comment:17 Changed 4 years ago by montego

I am running 3.1.4 already and on ubuntu 9.10 host with windows xp guest. I have always had my task bar at the default bottom of the screen AND I have not changed my screen resolution. Simply going from 3.1.2 to 3.1.4 has broken seamless mode for me. Definitely a "downer" as it was one of my reasons for switching from VMWare as it just seemed to offer me a better "windows" experience in the guest.

comment:18 Changed 4 years ago by michael

montego, if you attack a log file from a gues session where you saw this problem I should be able to tell you if it is the same issue or not. If it is then future releases of VirtualBox should fix it.

comment:19 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use