VirtualBox

Ticket #5375 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Long continuing keypress freezes WindowsXp-Host => Fixed in SVN

Reported by: Softestware Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.0 Keywords: Keystroke
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Hi,

If I press a key on the keyboard for a very long time the input devices and maybe the whole system freezes until the key is released.

I first encountered this while "walking" in a 3D video game, where this bug also results in a Network-Lag but it not only happens in games it also can be reproduced on the Desktop.

The guest OS here is Windows XP with SP3, with a 2 CPU host and guest.

Steps to reproduce:

  1. Create new empty textfile
  2. Press a character key
  3. Move the mouse several times in a slow/normal speed from edge to edge (while the key is still pressed)

Expected results: Character is written to text file endlessly and mouse cursor moves over the screen.

Real result: Mouse and Screen freezes until the key press is released.

The mouse move only hastens the thing, it also happens without mouse but than it takes way longer. I normally manage to get two freezes before the character hits the border, sometimes only one.

If you need additional information , I'm glad to help as good as I can.

Bye, Karsten

Attachments

Windows XP Full 3D-2009-12-03-13-29-11.log Download (40.2 KB) - added by Technologov 4 years ago.
VBox log on RHEL 5 host.

Change History

comment:1 Changed 4 years ago by Technologov

Updated to VBox 3.1.0

I am able to reproduce it here, according to your steps.

Host1: RHEL 5.3/x64, Core 2 P8600, VBox 3.1.0. (reproducible here)

Host2: Windows 7, x64, Core 2 Q6600, VBox 3.1.0. (non-reproducible here)

Guest: Windows XP.

It happens both with UP and SMP VM. (ACPI, ACPI SMP and even Standard PC HALs in XP)

Strangely enough, it does not happen on Windows Hosts !

-Technologov

Changed 4 years ago by Technologov

VBox log on RHEL 5 host.

comment:2 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.0.8 to VirtualBox 3.1.0
  • Description modified (diff)

Confirmed using a Windows XP guest and on a Debian / Lenny host. Most probably a bug in the PS/2 mouse/keyboard emulation.

comment:3 Changed 4 years ago by mhanor

I've missed this report bug confirmed for Windows XP SP3 32 bit host, #6249

comment:4 Changed 4 years ago by mhanor

the issue is present in VB 3.1.6, host&guest XP SP3 32 bit
just open Notepad, start pressing a letter key and while keeping it pressed, move the mouse cursor inside the guest (mouse integration can be enabled or disabled)

comment:5 Changed 4 years ago by frank

  • Summary changed from Long continuing keypress freezes WindowsXp-Host to Long continuing keypress freezes WindowsXp-Host => Fixed in SVN

We think we finally fixed this bug. The fix will be available with the next release of VBox.

comment:6 Changed 4 years ago by frank

You might want to try  VBox 3.2.0 Beta 1 which has the fix included.

comment:7 Changed 4 years ago by mhanor

yep, it's fixed (host&guest Windows XP)

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.1.8

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use